summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-06-13 23:37:54 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-06-13 23:37:54 +0000
commitf7eb62ed5625272d2a062a05cabfc1887713415d (patch)
treeda6009a050adc4959cc65cf237c7ece24bd925a1 /sci-libs/scipy
parentAdd sci herd as co-maintainer. (diff)
downloadgentoo-2-f7eb62ed5625272d2a062a05cabfc1887713415d.tar.gz
gentoo-2-f7eb62ed5625272d2a062a05cabfc1887713415d.tar.bz2
gentoo-2-f7eb62ed5625272d2a062a05cabfc1887713415d.zip
When checking for ATLAS, do it case-insensitively. Future planning for blas-config and lapack-config as eselect wrappers.
(Portage version: 2.1)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog7
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.4.82
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.4.8-r12
-rw-r--r--sci-libs/scipy/scipy-0.4.8-r1.ebuild8
4 files changed, 14 insertions, 5 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 80be5d10330c..974927837e32 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.3 2006/04/13 01:52:37 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.4 2006/06/13 23:37:54 spyderous Exp $
+
+ 13 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ scipy-0.4.8-r1.ebuild:
+ When checking for ATLAS, do it case-insensitively. Future planning for
+ blas-config and lapack-config as eselect wrappers.
*scipy-0.4.8-r1 (13 Apr 2006)
diff --git a/sci-libs/scipy/files/digest-scipy-0.4.8 b/sci-libs/scipy/files/digest-scipy-0.4.8
index 34e44425482c..c5e4f5e27612 100644
--- a/sci-libs/scipy/files/digest-scipy-0.4.8
+++ b/sci-libs/scipy/files/digest-scipy-0.4.8
@@ -1 +1,3 @@
MD5 854db037c56a0a359f877e8f852925ea scipy-0.4.8.tar.gz 2623917
+RMD160 a6cd4aeec75aced07bb23113c43f00a9e80ffdc9 scipy-0.4.8.tar.gz 2623917
+SHA256 40edd0bc444ae88c97b587b7bb7f2e6fe9758c382c9ac0d4cfa87b4db7ef2a35 scipy-0.4.8.tar.gz 2623917
diff --git a/sci-libs/scipy/files/digest-scipy-0.4.8-r1 b/sci-libs/scipy/files/digest-scipy-0.4.8-r1
index 34e44425482c..c5e4f5e27612 100644
--- a/sci-libs/scipy/files/digest-scipy-0.4.8-r1
+++ b/sci-libs/scipy/files/digest-scipy-0.4.8-r1
@@ -1 +1,3 @@
MD5 854db037c56a0a359f877e8f852925ea scipy-0.4.8.tar.gz 2623917
+RMD160 a6cd4aeec75aced07bb23113c43f00a9e80ffdc9 scipy-0.4.8.tar.gz 2623917
+SHA256 40edd0bc444ae88c97b587b7bb7f2e6fe9758c382c9ac0d4cfa87b4db7ef2a35 scipy-0.4.8.tar.gz 2623917
diff --git a/sci-libs/scipy/scipy-0.4.8-r1.ebuild b/sci-libs/scipy/scipy-0.4.8-r1.ebuild
index 99cdd3788517..81a0e06848e8 100644
--- a/sci-libs/scipy/scipy-0.4.8-r1.ebuild
+++ b/sci-libs/scipy/scipy-0.4.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.4.8-r1.ebuild,v 1.2 2006/05/02 22:24:24 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.4.8-r1.ebuild,v 1.3 2006/06/13 23:37:54 spyderous Exp $
inherit distutils fortran
@@ -46,14 +46,14 @@ pkg_setup() {
echo
einfo "Checking active BLAS implementations for ATLAS."
blas-config -p
- if ! blas-config -p | grep "F77 BLAS:" | grep -q f77-ATLAS; then
+ if ! blas-config -p | grep "F77 BLAS:" | grep -q -i atlas; then
eerror "Your F77 BLAS profile is not set to the ATLAS implementation,"
eerror "which is required by ${PN} to compile and run properly."
eerror "Use: 'blas-config -f ATLAS' to activate ATLAS."
echo
bad_profile=1
fi
- if ! blas-config -p | grep "C BLAS:" | grep -q c-ATLAS; then
+ if ! blas-config -p | grep "C BLAS:" | grep -q -i atlas; then
eerror "Your C BLAS profile is not set to the ATLAS implementation,"
eerror "Which is required by ${PN} to compile and run properly."
eerror "Use: 'blas-config -c ATLAS' to activate ATLAS."
@@ -62,7 +62,7 @@ pkg_setup() {
fi
einfo "Checking active LAPACK implementation for ATLAS."
lapack-config -p
- if ! lapack-config -p | grep "F77 LAPACK:" | grep -q f77-ATLAS; then
+ if ! lapack-config -p | grep "F77 LAPACK:" | grep -q -i atlas; then
eerror "Your F77 LAPACK profile is not set to the ATLAS implementation,"
eerror "which is required by ${PN} to compile and run properly."
eerror "Use: 'lapack-config ATLAS' to activate ATLAS."