summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-12-28 20:30:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-12-28 20:30:19 +0000
commit362e32cac429ac6f15c4904f5229360bccba0fba (patch)
tree8a6c86a6ab1fdf720d1152a89f781007611fc362 /sci-libs/superlu/superlu-4.1-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-362e32cac429ac6f15c4904f5229360bccba0fba.tar.gz
gentoo-2-362e32cac429ac6f15c4904f5229360bccba0fba.tar.bz2
gentoo-2-362e32cac429ac6f15c4904f5229360bccba0fba.zip
Fixed patch for missing includes bug #349783. Changed the pkg-config cflags value.
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/superlu/superlu-4.1-r1.ebuild')
-rw-r--r--sci-libs/superlu/superlu-4.1-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sci-libs/superlu/superlu-4.1-r1.ebuild b/sci-libs/superlu/superlu-4.1-r1.ebuild
new file mode 100644
index 000000000000..f9653b0a039c
--- /dev/null
+++ b/sci-libs/superlu/superlu-4.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/superlu/superlu-4.1-r1.ebuild,v 1.1 2010/12/28 20:30:19 bicatali Exp $
+
+EAPI="2"
+
+inherit autotools eutils toolchain-funcs
+
+MY_PN=SuperLU
+
+DESCRIPTION="Sparse LU factorization library"
+HOMEPAGE="http://crd.lbl.gov/~xiaoye/SuperLU/"
+SRC_URI="${HOMEPAGE}/${PN}_${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="virtual/blas"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( app-shells/tcsh )"
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-blas="$(pkg-config --libs blas)" \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ cd TESTING
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ FORTRAN="$(tc-getFC)" \
+ LOADER="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ LOADOPTS="${LDFLAGS}" \
+ BLASLIB="$(pkg-config --libs blas)" \
+ SUPERLULIB="${S}/SRC/.libs/libsuperlu.so" \
+ LD_LIBRARY_PATH="${S}/SRC/.libs" \
+ || die "emake matrix generation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+
+ if use doc; then
+ dodoc DOC/ug.pdf || die
+ dohtml DOC/html/* || die
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r EXAMPLE FORTRAN || die
+ fi
+}