summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-28 14:20:47 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-28 14:20:47 +0000
commitbffc0ec274b19abbe2a6edd10ef380b5fcef91b5 (patch)
tree479f4dae3560446321299d5fc10498951d124614 /sci-libs/superlu/superlu-4.3.ebuild
parentFixing slot for #406149 (diff)
downloadgentoo-2-bffc0ec274b19abbe2a6edd10ef380b5fcef91b5.tar.gz
gentoo-2-bffc0ec274b19abbe2a6edd10ef380b5fcef91b5.tar.bz2
gentoo-2-bffc0ec274b19abbe2a6edd10ef380b5fcef91b5.zip
Moved to autotools-utils, EAPI=4, fix blas/lapack detection and add USE=static-libs
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/superlu/superlu-4.3.ebuild')
-rw-r--r--sci-libs/superlu/superlu-4.3.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/sci-libs/superlu/superlu-4.3.ebuild b/sci-libs/superlu/superlu-4.3.ebuild
index c082f2a58f69..73840c0985f9 100644
--- a/sci-libs/superlu/superlu-4.3.ebuild
+++ b/sci-libs/superlu/superlu-4.3.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/superlu/superlu-4.3.ebuild,v 1.1 2011/11/27 04:14:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/superlu/superlu-4.3.ebuild,v 1.2 2012/02/28 14:20:47 jlec Exp $
EAPI=4
-inherit autotools eutils fortran-2 toolchain-funcs multilib
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2 toolchain-funcs multilib
MY_PN=SuperLU
@@ -25,20 +27,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_PN}_${PV}"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.2-autotools.patch
- sed -i -e "s/4.2/${PV}/" configure.ac || die
- eautoreconf
-}
+AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
src_configure() {
- econf \
- --with-blas="$(pkg-config --libs blas)" \
- $(use_enable static-libs static)
+ local myeconfargs=( --with-blas="$(pkg-config --libs blas)" )
+ autotools-utils_src_configure
}
src_test() {
- cd TESTING
+ cd "${AUTOTOOLS_BUILD_DIR}"/TESTING
emake -j1 \
CC="$(tc-getCC)" \
FORTRAN="$(tc-getFC)" \
@@ -53,7 +51,7 @@ src_test() {
}
src_install() {
- default
+ autotools-utils_src_install
use doc && dodoc DOC/ug.pdf && dohtml DOC/html/*
if use examples; then
insinto /usr/share/doc/${PF}/examples