summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-29 00:29:20 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-29 00:29:20 +0000
commit20f1bcbf1fe084ab46650e8d1cd0d31b8e2db0f6 (patch)
tree5aa47468c1eaa43f8b673333948cae20486c1866 /sci-libs/szip/szip-1.1-r1.ebuild
parentx86, sparc, mips stable (Manifest recommit) (diff)
downloadgentoo-2-20f1bcbf1fe084ab46650e8d1cd0d31b8e2db0f6.tar.gz
gentoo-2-20f1bcbf1fe084ab46650e8d1cd0d31b8e2db0f6.tar.bz2
gentoo-2-20f1bcbf1fe084ab46650e8d1cd0d31b8e2db0f6.zip
Moved from dev-libs/szip to sci-libs/szip.
Diffstat (limited to 'sci-libs/szip/szip-1.1-r1.ebuild')
-rw-r--r--sci-libs/szip/szip-1.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/szip/szip-1.1-r1.ebuild b/sci-libs/szip/szip-1.1-r1.ebuild
new file mode 100644
index 000000000000..4ab79af6e80d
--- /dev/null
+++ b/sci-libs/szip/szip-1.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/szip/szip-1.1-r1.ebuild,v 1.3 2004/12/29 00:29:20 ribosome Exp $
+
+inherit eutils
+
+MY_P="${P/-}"
+
+DESCRIPTION="Szip is an implementation of the extended-Rice lossless compression algorithm"
+HOMEPAGE="http://hdf.ncsa.uiuc.edu/HDF5/doc_resource/SZIP/"
+SRC_URI="ftp://ftp.ncsa.uiuc.edu/HDF/szip/src/${MY_P}.tar.gz"
+LICENSE="szip"
+
+SLOT="0"
+KEYWORDS="x86 amd64 ppc"
+
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-fPIC.patch
+}
+
+src_compile() {
+ ./configure -s --prefix="/usr" || die
+ emake CFLAGS="${CFLAGS} -DHAVE_UNISTD_H -DUSE_MMAP" || die
+}
+
+src_install() {
+ dodir /usr/include
+ dodir /usr/lib
+ make prefix=${D}/usr install || die
+}