summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-13 17:14:16 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-13 17:14:16 +0000
commit1761477d61fb94a56930a15703d55293bc4352f1 (patch)
treeb0f4c281886ee7cb553659ac1feb98406780b403 /sci-libs
parentMask vulnerable versions of mesa, bug #472280. (diff)
downloadgentoo-2-1761477d61fb94a56930a15703d55293bc4352f1.tar.gz
gentoo-2-1761477d61fb94a56930a15703d55293bc4352f1.tar.bz2
gentoo-2-1761477d61fb94a56930a15703d55293bc4352f1.zip
sci-libs/arpack: Version BUmp
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/arpack/ChangeLog7
-rw-r--r--sci-libs/arpack/arpack-3.1.3.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sci-libs/arpack/ChangeLog b/sci-libs/arpack/ChangeLog
index a6638798a9e8..b20f4d4398f2 100644
--- a/sci-libs/arpack/ChangeLog
+++ b/sci-libs/arpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/arpack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/arpack/ChangeLog,v 1.52 2013/07/18 12:50:22 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arpack/ChangeLog,v 1.53 2013/10/13 17:14:16 jlec Exp $
+
+*arpack-3.1.3 (13 Oct 2013)
+
+ 13 Oct 2013; Justin Lecher <jlec@gentoo.org> +arpack-3.1.3.ebuild:
+ Version BUmp
18 Jul 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
arpack-3.1.2-r1.ebuild:
diff --git a/sci-libs/arpack/arpack-3.1.3.ebuild b/sci-libs/arpack/arpack-3.1.3.ebuild
new file mode 100644
index 000000000000..86686d8ed362
--- /dev/null
+++ b/sci-libs/arpack/arpack-3.1.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arpack/arpack-3.1.3.ebuild,v 1.1 2013/10/13 17:14:16 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs
+
+MY_P="${PN}-ng-${PV}"
+
+DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
+HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ http://forge.scilab.org/index.php/p/arpack-ng/"
+SRC_URI="
+ http://forge.scilab.org/upload/arpack-ng/files/${MY_P}.tar.gz
+ doc? (
+ http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
+ http://www.caam.rice.edu/software/ARPACK/DOCS/tutorial.ps.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples mpi static-libs"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[fortran] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ tc-export PKG_CONFIG
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ $(use_enable mpi)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc DOCUMENTS/*.doc
+ newdoc DOCUMENTS/README README.doc
+ use doc && dodoc "${WORKDIR}"/*.ps
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r EXAMPLES
+ if use mpi; then
+ insinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
+ doins -r PARPACK/EXAMPLES/MPI
+ fi
+ fi
+}