summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-03 12:27:50 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-03 12:27:50 +0000
commit4862a2fd3d7aeaca11539972d4c971a01b901688 (patch)
treead591f3818ba7e16e7064e7401c755258552d9c8 /sci-libs
parentVersion bump by Ben 'yngwin' de Groot <yngwin@gmail.com> wrt bug #370139. (diff)
downloadgentoo-2-4862a2fd3d7aeaca11539972d4c971a01b901688.tar.gz
gentoo-2-4862a2fd3d7aeaca11539972d4c971a01b901688.tar.bz2
gentoo-2-4862a2fd3d7aeaca11539972d4c971a01b901688.zip
Moved to autotools-utils.eclass
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/clipper/ChangeLog7
-rw-r--r--sci-libs/clipper/clipper-20100511-r1.ebuild38
2 files changed, 25 insertions, 20 deletions
diff --git a/sci-libs/clipper/ChangeLog b/sci-libs/clipper/ChangeLog
index 23699d626140..55181bcee4e2 100644
--- a/sci-libs/clipper/ChangeLog
+++ b/sci-libs/clipper/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/clipper
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/ChangeLog,v 1.14 2011/06/26 10:13:02 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/ChangeLog,v 1.15 2012/02/03 12:27:50 jlec Exp $
+
+ 03 Feb 2012; Justin Lecher <jlec@gentoo.org> clipper-20100511-r1.ebuild:
+ Moved to autotools-utils.eclass
*clipper-20100511-r1 (26 Jun 2011)
diff --git a/sci-libs/clipper/clipper-20100511-r1.ebuild b/sci-libs/clipper/clipper-20100511-r1.ebuild
index 77a615368bb2..e89a42fe1663 100644
--- a/sci-libs/clipper/clipper-20100511-r1.ebuild
+++ b/sci-libs/clipper/clipper-20100511-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/clipper-20100511-r1.ebuild,v 1.1 2011/06/26 10:13:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/clipper-20100511-r1.ebuild,v 1.2 2012/02/03 12:27:50 jlec Exp $
EAPI=4
-WANT_AUTOMAKE="1.11"
+AUTOTOOLS_AUTORECONF=true
-inherit autotools eutils flag-o-matic
+inherit autotools-utils eutils flag-o-matic
DESCRIPTION="Object-oriented libraries for crystallographic data and crystallographic computation"
HOMEPAGE="http://www.ysbl.york.ac.uk/~cowtan/clipper/clipper.html"
@@ -16,7 +16,7 @@ SRC_URI="http://www.ysbl.york.ac.uk/~cowtan/clipper/clipper-2.1-${PV:2:${#PV}}-a
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug"
+IUSE="debug static-libs"
RDEPEND="
sci-libs/ccp4-libs
@@ -26,13 +26,13 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}"/${PN}-2.1
-src_prepare() {
- epatch "${FILESDIR}"/20091215-missing-var.patch
+PATCHES=( "${FILESDIR}"/20091215-missing-var.patch )
+src_prepare() {
# ccp4 provides these, and more.
sed -i -e "s:examples::g" "${S}"/Makefile.am
- AT_M4DIR="config" eautoreconf
+ autotools-utils_src_prepare
}
src_configure() {
@@ -40,20 +40,22 @@ src_configure() {
# on 64-bit systems
append-flags -fno-strict-aliasing
- econf \
- --enable-ccp4 \
- --enable-cif \
- --enable-cns \
- --enable-contrib \
- --enable-minimol \
- --enable-mmdb \
- --enable-phs \
- --with-mmdb="${EPREFIX}"/usr \
+ local myeconfargs=(
+ --enable-ccp4
+ --enable-cif
+ --enable-cns
+ --enable-contrib
+ --enable-minimol
+ --enable-mmdb
+ --enable-phs
+ --with-mmdb="${EPREFIX}"/usr
$(use_enable debug)
+ )
+ autotools-utils_src_configure
}
src_test() {
emake \
- -C examples \
+ -C "${AUTOTOOLS_BUILD_DIR}"/examples \
check
}