summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-06 12:01:36 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-06 12:01:36 +0000
commit779e76a482559f405cf3acf6223543f316e5eb14 (patch)
tree804a517079dcdddb8d5fce8deed252665d1a0b4a /sci-libs
parentCleaned up more tc stuff. (diff)
downloadgentoo-2-779e76a482559f405cf3acf6223543f316e5eb14.tar.gz
gentoo-2-779e76a482559f405cf3acf6223543f316e5eb14.tar.bz2
gentoo-2-779e76a482559f405cf3acf6223543f316e5eb14.zip
New library, used to evaluate integrals over Cartesian Gaussian functions. Useful in quantum chemistry. Is autodetected by sci-chemistry/mpqc now and used for very advanced methods, but hopefully will be able to fix that behavior soon.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libint/ChangeLog13
-rw-r--r--sci-libs/libint/Manifest3
-rw-r--r--sci-libs/libint/files/digest-libint-1.1.21
-rw-r--r--sci-libs/libint/files/dont-append-mcpu.patch16
-rw-r--r--sci-libs/libint/libint-1.1.2.ebuild39
-rw-r--r--sci-libs/libint/metadata.xml9
6 files changed, 81 insertions, 0 deletions
diff --git a/sci-libs/libint/ChangeLog b/sci-libs/libint/ChangeLog
new file mode 100644
index 000000000000..d6c4247a9e66
--- /dev/null
+++ b/sci-libs/libint/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-libs/libint
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/ChangeLog,v 1.1 2005/12/06 12:01:36 spyderous Exp $
+
+*libint-1.1.2 (06 Dec 2005)
+
+ 06 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/dont-append-mcpu.patch, +metadata.xml, +libint-1.1.2.ebuild:
+ New library, used to evaluate integrals over Cartesian Gaussian functions.
+ Useful in quantum chemistry. Is autodetected by sci-chemistry/mpqc now and
+ used for very advanced methods, but hopefully will be able to fix that
+ behavior soon.
+
diff --git a/sci-libs/libint/Manifest b/sci-libs/libint/Manifest
new file mode 100644
index 000000000000..1d82976b042e
--- /dev/null
+++ b/sci-libs/libint/Manifest
@@ -0,0 +1,3 @@
+MD5 0730269bdb4a466ff828dfbb1ed77444 files/digest-libint-1.1.2 64
+MD5 7e1902351932e8fa08fffb0f3374a73f files/dont-append-mcpu.patch 647
+MD5 a9f8ceb14d112110bcf25d7dbbad3dd2 libint-1.1.2.ebuild 895
diff --git a/sci-libs/libint/files/digest-libint-1.1.2 b/sci-libs/libint/files/digest-libint-1.1.2
new file mode 100644
index 000000000000..e8fd0804c7ea
--- /dev/null
+++ b/sci-libs/libint/files/digest-libint-1.1.2
@@ -0,0 +1 @@
+MD5 df23c63d46be7dd88a70a39e98f67d34 libint-1.1.2.tar.gz 376882
diff --git a/sci-libs/libint/files/dont-append-mcpu.patch b/sci-libs/libint/files/dont-append-mcpu.patch
new file mode 100644
index 000000000000..72b5e437051b
--- /dev/null
+++ b/sci-libs/libint/files/dont-append-mcpu.patch
@@ -0,0 +1,16 @@
+diff -urN libint-1.1.2.orig/configure libint-1.1.2/configure
+--- libint-1.1.2.orig/configure 2003-12-05 13:24:55.000000000 -0800
++++ libint-1.1.2/configure 2005-12-06 03:27:37.000000000 -0800
+@@ -3554,10 +3554,10 @@
+ cpu_arch_option="-mcpu=$target_cpu"
+ fi
+ if test X$GCC = Xyes; then
+- COPTIONS_MISC="$COPTIONS_MISC $cpu_arch_option"
++ COPTIONS_MISC="$COPTIONS_MISC"
+ fi
+ if test X$GXX = Xyes; then
+- CXXOPTIONS_MISC="$CXXOPTIONS_MISC $cpu_arch_option"
++ CXXOPTIONS_MISC="$CXXOPTIONS_MISC"
+ fi
+ echo "$as_me:3562: result: IA-32: $cpu_arch_option" >&5
+ echo "${ECHO_T}IA-32: $cpu_arch_option" >&6
diff --git a/sci-libs/libint/libint-1.1.2.ebuild b/sci-libs/libint/libint-1.1.2.ebuild
new file mode 100644
index 000000000000..0a97feb6e381
--- /dev/null
+++ b/sci-libs/libint/libint-1.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.2.ebuild,v 1.1 2005/12/06 12:01:36 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="Used to evaluate traditional and novel two-body matrix elements (integrals) over Cartesian Gaussian functions"
+HOMEPAGE="http://www.ccmst.gatech.edu/evaleev/libint/"
+SRC_URI="http://www.ccmst.gatech.edu/evaleev/libint/src/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/dont-append-mcpu.patch
+}
+
+src_compile() {
+ sed -i \
+ -e "s:^COPTIONS_OPT=.*:COPTIONS_OPT=\"${CFLAGS}\":g" \
+ -e "s:^CXXOPTIONS_OPT=.*:CXXOPTIONS_OPT=\"${CXXFLAGS}\":g" \
+ ${S}/configure
+
+ econf \
+ --enable-shared \
+ --enable-deriv \
+ --enable-r12 \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ #make DESTDIR=${D} install || die
+ einstall || die
+}
diff --git a/sci-libs/libint/metadata.xml b/sci-libs/libint/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-libs/libint/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>