summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-24 12:20:01 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-24 12:20:01 +0000
commit7b7c772bdec27e437eca39450da5d19b626127a5 (patch)
treedc797d404e04eec586b66b810c46e062e1b14692 /sci-libs
parentUSE flag doc added (diff)
downloadgentoo-2-7b7c772bdec27e437eca39450da5d19b626127a5.tar.gz
gentoo-2-7b7c772bdec27e437eca39450da5d19b626127a5.tar.bz2
gentoo-2-7b7c772bdec27e437eca39450da5d19b626127a5.zip
sci-libs/nlopt: Fix deprecated macro usage, #466988
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/ChangeLog6
-rw-r--r--sci-libs/nlopt/metadata.xml10
-rw-r--r--sci-libs/nlopt/nlopt-2.2.4.ebuild6
-rw-r--r--sci-libs/nlopt/nlopt-2.3-r1.ebuild6
-rw-r--r--sci-libs/nlopt/nlopt-2.3-r2.ebuild7
5 files changed, 21 insertions, 14 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index c7743941bedc..c9315edb51ef 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.21 2013/03/04 17:19:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.22 2013/04/24 12:20:01 jlec Exp $
+
+ 24 Apr 2013; Justin Lecher <jlec@gentoo.org> nlopt-2.2.4.ebuild,
+ nlopt-2.3-r1.ebuild, nlopt-2.3-r2.ebuild, metadata.xml:
+ Fix deprecated macro usage, #466988
04 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> nlopt-2.3-r2.ebuild:
Remove pure C++ tests when testing C library, bug #460284
diff --git a/sci-libs/nlopt/metadata.xml b/sci-libs/nlopt/metadata.xml
index 55d520d4b3ca..4b343041281b 100644
--- a/sci-libs/nlopt/metadata.xml
+++ b/sci-libs/nlopt/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
NLopt is a library for nonlinear optimization,
providing a common interface for a number of different free
optimization routines available online as well as original
@@ -15,7 +15,7 @@
* Algorithms for unconstrained optimization, bound-constrained
optimization, and general nonlinear inequality constraints.
</longdescription>
-<use>
- <flag name="octave">Add plugin for <pkg>sci-mathematics/octave</pkg></flag>
-</use>
+ <use>
+ <flag name="octave">Add plugin for <pkg>sci-mathematics/octave</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/nlopt/nlopt-2.2.4.ebuild b/sci-libs/nlopt/nlopt-2.2.4.ebuild
index 65e3b9664c71..77ad380b37db 100644
--- a/sci-libs/nlopt/nlopt-2.2.4.ebuild
+++ b/sci-libs/nlopt/nlopt-2.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.9 2012/07/09 17:14:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.10 2013/04/24 12:20:01 jlec Exp $
EAPI=4
@@ -78,7 +78,7 @@ src_install() {
if use python; then
installation() {
rm *.la
- emake DESTDIR=${D} install \
+ emake DESTDIR="${D}" install \
pyexecdir="${EPREFIX}$(python_get_sitedir)" \
pythondir="${EPREFIX}$(python_get_sitedir)"
}
diff --git a/sci-libs/nlopt/nlopt-2.3-r1.ebuild b/sci-libs/nlopt/nlopt-2.3-r1.ebuild
index 1ec445c23993..ce82d7573474 100644
--- a/sci-libs/nlopt/nlopt-2.3-r1.ebuild
+++ b/sci-libs/nlopt/nlopt-2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.3-r1.ebuild,v 1.1 2012/08/03 17:43:29 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.3-r1.ebuild,v 1.2 2013/04/24 12:20:01 jlec Exp $
EAPI=4
@@ -93,7 +93,7 @@ src_install() {
installation() {
cd "${AUTOTOOLS_BUILD_DIR}"
rm *.la
- emake DESTDIR=${D} install \
+ emake DESTDIR="${D}" install \
pyexecdir="${EPREFIX}$(python_get_sitedir)" \
pythondir="${EPREFIX}$(python_get_sitedir)"
}
diff --git a/sci-libs/nlopt/nlopt-2.3-r2.ebuild b/sci-libs/nlopt/nlopt-2.3-r2.ebuild
index b7017e205366..97e787eb298c 100644
--- a/sci-libs/nlopt/nlopt-2.3-r2.ebuild
+++ b/sci-libs/nlopt/nlopt-2.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.3-r2.ebuild,v 1.2 2013/03/04 17:19:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.3-r2.ebuild,v 1.3 2013/04/24 12:20:01 jlec Exp $
EAPI=5
@@ -33,6 +33,9 @@ PATCHES=(
)
src_prepare() {
+ sed \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' \
+ -i configure.ac || die
autotools-utils_src_prepare
if use python; then
sed -i \
@@ -106,7 +109,7 @@ src_install() {
installation() {
cd "${AUTOTOOLS_BUILD_DIR}"
rm *.la
- emake DESTDIR=${D} install \
+ emake DESTDIR="${D}" install \
pyexecdir="${EPREFIX}$(python_get_sitedir)" \
pythondir="${EPREFIX}$(python_get_sitedir)"
}