summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-19 23:07:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-19 23:07:24 +0000
commitb4a8a008a5a41fc81e912b877af8b5153366768a (patch)
tree0f8d47b9f779d9f7b800f42738df995a2490f58d /sci-libs
parentKeyworded on alpha, bug #424649 (diff)
downloadgentoo-2-b4a8a008a5a41fc81e912b877af8b5153366768a.tar.gz
gentoo-2-b4a8a008a5a41fc81e912b877af8b5153366768a.tar.bz2
gentoo-2-b4a8a008a5a41fc81e912b877af8b5153366768a.zip
Version bump. Switch to EAPI5
(Portage version: 2.2.01.22013-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hypre/ChangeLog8
-rw-r--r--sci-libs/hypre/hypre-2.9.0b.ebuild86
-rw-r--r--sci-libs/hypre/metadata.xml4
3 files changed, 95 insertions, 3 deletions
diff --git a/sci-libs/hypre/ChangeLog b/sci-libs/hypre/ChangeLog
index 88f678367755..285066fac975 100644
--- a/sci-libs/hypre/ChangeLog
+++ b/sci-libs/hypre/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/hypre
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/ChangeLog,v 1.10 2013/02/21 21:31:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/ChangeLog,v 1.11 2013/06/19 23:07:24 bicatali Exp $
+
+*hypre-2.9.0b (19 Jun 2013)
+
+ 19 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> +hypre-2.9.0b.ebuild,
+ metadata.xml:
+ Version bump. Switch to EAPI5
21 Feb 2013; Justin Lecher <jlec@gentoo.org> hypre-2.8.0b-r1.ebuild,
metadata.xml:
diff --git a/sci-libs/hypre/hypre-2.9.0b.ebuild b/sci-libs/hypre/hypre-2.9.0b.ebuild
new file mode 100644
index 000000000000..055aa6acf681
--- /dev/null
+++ b/sci-libs/hypre/hypre-2.9.0b.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hypre/hypre-2.9.0b.ebuild,v 1.1 2013/06/19 23:07:24 bicatali Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="Parallel matrix preconditioners library"
+HOMEPAGE="http://acts.nersc.gov/hypre/"
+SRC_URI="https://computation.llnl.gov/casc/hypre/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="blas doc examples fortran lapack mpi"
+
+RDEPEND="
+ sci-libs/superlu
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( "${WORKDIR}"/${P}/{CHANGELOG,COPYRIGHT,README} )
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ # link with system superlu and propagate LDFLAGS
+ sed -i \
+ -e 's:@LIBS@:@LIBS@ -lsuperlu:' \
+ -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
+ config/Makefile.config.in || die
+ sed -i \
+ -e '/HYPRE_ARCH/s: = :=:g' \
+ configure || die
+ # link with system blas and lapack
+ sed -i \
+ -e '/^BLASFILES/d' \
+ -e '/^LAPACKFILES/d' \
+ lib/Makefile || die
+ tc-export CC
+}
+
+src_configure() {
+ local myeconfargs+=(
+ --enable-shared
+ --without-superlu
+ --without-strict-checking
+ $(use_enable fortran)
+ $(use_with mpi MPI)
+ )
+ if use blas; then
+ myeconfargs+=(
+ --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')"
+ --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')"
+ )
+ else
+ myeconfargs+=( --without-blas )
+ fi
+ if use lapack; then
+ myeconfargs+=(
+ --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')"
+ --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')"
+ )
+ else
+ myeconfargs+=( --without-lapack )
+ fi
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ dolib.so hypre/lib/lib*
+ insinto /usr/include/hypre
+ doins -r hypre/include/*
+
+ use doc && dodoc "${WORKDIR}"/${P}/docs/*.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/hypre/metadata.xml b/sci-libs/hypre/metadata.xml
index a44d7feb10d7..2cbd2140f8a5 100644
--- a/sci-libs/hypre/metadata.xml
+++ b/sci-libs/hypre/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-mathematics</herd>
- <longdescription lang="en">
+<herd>sci-mathematics</herd>
+<longdescription lang="en">
Hypre is a set of matrix preconditioning libraries to aid in the
solution of large systems of linear equations.
</longdescription>