summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-30 18:19:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-30 18:19:15 +0000
commitd75c3285b7bdf4a601111cac2c041e86297df1e4 (patch)
treedff440588cba1ad32b8e52827420b53474f6c2df /sci-libs
parentRemove package mask for SELinux userspace 2.4, migrations have been tested an... (diff)
downloadgentoo-2-d75c3285b7bdf4a601111cac2c041e86297df1e4.tar.gz
gentoo-2-d75c3285b7bdf4a601111cac2c041e86297df1e4.tar.bz2
gentoo-2-d75c3285b7bdf4a601111cac2c041e86297df1e4.zip
initial import, ebuild by me
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/orocos_kdl/ChangeLog11
-rw-r--r--sci-libs/orocos_kdl/metadata.xml20
-rw-r--r--sci-libs/orocos_kdl/orocos_kdl-1.3.0.ebuild68
-rw-r--r--sci-libs/orocos_kdl/orocos_kdl-9999.ebuild68
4 files changed, 167 insertions, 0 deletions
diff --git a/sci-libs/orocos_kdl/ChangeLog b/sci-libs/orocos_kdl/ChangeLog
new file mode 100644
index 000000000000..5245d8dadfb8
--- /dev/null
+++ b/sci-libs/orocos_kdl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/orocos_kdl
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/orocos_kdl/ChangeLog,v 1.1 2014/10/30 18:19:15 aballier Exp $
+
+*orocos_kdl-9999 (30 Oct 2014)
+*orocos_kdl-1.3.0 (30 Oct 2014)
+
+ 30 Oct 2014; Alexis Ballier <aballier@gentoo.org> +orocos_kdl-1.3.0.ebuild,
+ +orocos_kdl-9999.ebuild, +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/sci-libs/orocos_kdl/metadata.xml b/sci-libs/orocos_kdl/metadata.xml
new file mode 100644
index 000000000000..2b0f95aff409
--- /dev/null
+++ b/sci-libs/orocos_kdl/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>aballier@gentoo.org</email>
+<name>Alexis Ballier</name>
+</maintainer>
+<longdescription lang="en">
+ The Kinematics and Dynamics Library (KDL) develops an application
+ independent framework for modelling and computation of kinematic chains,
+ such as robots, biomechanical human models, computer-animated figures,
+ machine tools, etc. It provides class libraries for geometrical objects
+ (point, frame, line,... ), kinematic chains of various families (serial,
+ humanoid, parallel, mobile,... ), and their motion specification and
+ interpolation.
+</longdescription>
+ <use>
+ <flag name="models">Build models for some well known robots.</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-libs/orocos_kdl/orocos_kdl-1.3.0.ebuild b/sci-libs/orocos_kdl/orocos_kdl-1.3.0.ebuild
new file mode 100644
index 000000000000..cdfb47b4e852
--- /dev/null
+++ b/sci-libs/orocos_kdl/orocos_kdl-1.3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/orocos_kdl/orocos_kdl-1.3.0.ebuild,v 1.1 2014/10/30 18:19:15 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/orocos/orocos_kinematics_dynamics"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="http://github.com/orocos/orocos_kinematics_dynamics/archive/v${PV}.tar.gz -> orocos_kinematics_dynamics-${PV}.tar.gz"
+fi
+
+DESCRIPTION="Kinematics and Dynamics Library (KDL)"
+HOMEPAGE="http://www.orocos.org/kdl"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc test examples models"
+
+RDEPEND="dev-cpp/eigen:3"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+ doc? ( app-doc/doxygen )"
+REQUIRED_USE="examples? ( models )"
+
+DOCS=( README )
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ S=${WORKDIR}/${P}/orocos_kdl
+else
+ S=${WORKDIR}/orocos_kinematics_dynamics-${PV}/orocos_kdl
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable test TESTS)"
+ "$(cmake-utils_use_enable examples EXAMPLES)"
+ "-DBUILD_MODELS=$(usex models ON OFF)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ cd "${BUILD_DIR}"
+ use doc && emake docs
+}
+
+src_test() {
+ cd "${BUILD_DIR}"
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ cd "${BUILD_DIR}"
+ use doc && dohtml -r doc/api/html/*
+ use examples && dobin "${BUILD_DIR}/examples/"{geometry,trajectory_example,chainiksolverpos_lma_demo}
+}
diff --git a/sci-libs/orocos_kdl/orocos_kdl-9999.ebuild b/sci-libs/orocos_kdl/orocos_kdl-9999.ebuild
new file mode 100644
index 000000000000..fc95d964b864
--- /dev/null
+++ b/sci-libs/orocos_kdl/orocos_kdl-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/orocos_kdl/orocos_kdl-9999.ebuild,v 1.1 2014/10/30 18:19:15 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/orocos/orocos_kinematics_dynamics"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="http://github.com/orocos/orocos_kinematics_dynamics/archive/v${PV}.tar.gz -> orocos_kinematics_dynamics-${PV}.tar.gz"
+fi
+
+DESCRIPTION="Kinematics and Dynamics Library (KDL)"
+HOMEPAGE="http://www.orocos.org/kdl"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc test examples models"
+
+RDEPEND="dev-cpp/eigen:3"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+ doc? ( app-doc/doxygen )"
+REQUIRED_USE="examples? ( models )"
+
+DOCS=( README )
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ S=${WORKDIR}/${P}/orocos_kdl
+else
+ S=${WORKDIR}/orocos_kinematics_dynamics-${PV}/orocos_kdl
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable test TESTS)"
+ "$(cmake-utils_use_enable examples EXAMPLES)"
+ "-DBUILD_MODELS=$(usex models ON OFF)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ cd "${BUILD_DIR}"
+ use doc && emake docs
+}
+
+src_test() {
+ cd "${BUILD_DIR}"
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ cd "${BUILD_DIR}"
+ use doc && dohtml -r doc/api/html/*
+ use examples && dobin "${BUILD_DIR}/examples/"{geometry,trajectory_example,chainiksolverpos_lma_demo}
+}