summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-11 02:29:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-11 02:29:32 +0000
commite24afb1aa1ba39acdd1aa0ec4f829f955c7272e3 (patch)
tree505d02b9d0ecb0e908c9c9cf9c37f95fca13788b /sci-libs
parentFixed glibc bug #275020, thanks Andrew Savchenko, and add missing header (diff)
downloadgentoo-2-e24afb1aa1ba39acdd1aa0ec4f829f955c7272e3.tar.gz
gentoo-2-e24afb1aa1ba39acdd1aa0ec4f829f955c7272e3.tar.bz2
gentoo-2-e24afb1aa1ba39acdd1aa0ec4f829f955c7272e3.zip
More as-needed fixes, thanks to Kacper Kowalik closing bug #284518
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog6
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.3-as-needed.patch10
-rw-r--r--sci-libs/hdf5/hdf5-1.8.3.ebuild5
3 files changed, 18 insertions, 3 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 2fa7aae19e29..701f43e5b71c 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.35 2009/08/24 14:13:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.36 2009/09/11 02:29:30 bicatali Exp $
+
+ 11 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org> hdf5-1.8.3.ebuild,
+ files/hdf5-1.8.3-as-needed.patch:
+ More as-needed fixes, thanks to Kacper Kowalik closing bug #284518
24 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org> hdf5-1.8.3.ebuild:
Replaced use-based dependency for virtual by atom based ones. Thanks
diff --git a/sci-libs/hdf5/files/hdf5-1.8.3-as-needed.patch b/sci-libs/hdf5/files/hdf5-1.8.3-as-needed.patch
index 42962d66181a..677264b22b53 100644
--- a/sci-libs/hdf5/files/hdf5-1.8.3-as-needed.patch
+++ b/sci-libs/hdf5/files/hdf5-1.8.3-as-needed.patch
@@ -29,3 +29,13 @@
# Public headers
include_HEADERS=H5PacketTable.h
+--- hdf5-1.8.3.orig/hl/src/Makefile.am 2009-05-13 17:03:11.000000000 +0200
++++ hdf5-1.8.3/hl/src/Makefile.am 2009-09-10 19:22:57.489698969 +0200
+@@ -31,6 +31,7 @@
+ libhdf5_hl_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE)
+
+ libhdf5_hl_la_SOURCES=H5DS.c H5IM.c H5LT.c H5LTanalyze.c H5LTparse.c H5PT.c H5TB.c
++libhdf5_hl_la_LIBADD=$(top_builddir)/src/libhdf5.la
+
+ # Public header files (to be installed)
+ include_HEADERS=hdf5_hl.h H5IMpublic.h H5LTpublic.h H5TBpublic.h H5DSpublic.h H5PTpublic.h
diff --git a/sci-libs/hdf5/hdf5-1.8.3.ebuild b/sci-libs/hdf5/hdf5-1.8.3.ebuild
index f1d987aa7ac1..40a4e2aeb078 100644
--- a/sci-libs/hdf5/hdf5-1.8.3.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.3.ebuild,v 1.2 2009/08/24 14:13:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.3.ebuild,v 1.3 2009/09/11 02:29:30 bicatali Exp $
EAPI=2
-inherit eutils autotools
+inherit eutils autotools flag-o-matic
DESCRIPTION="General purpose library and file format for storing scientific data"
HOMEPAGE="http://www.hdfgroup.org/HDF5/"
@@ -52,6 +52,7 @@ src_prepare() {
}
src_configure() {
+ filter_flags -
# threadsafe incompatible with many options
local myconf="--disable-threadsafe"
use threads && ! use fortran && ! use cxx && ! use mpi \