summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-07-11 15:39:49 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-07-11 15:39:49 +0000
commitf6d3339ea8f63b0cf1f3141ce553316b4493fcc3 (patch)
treeff9c25070178d2ceb74a7d80e3bb2729713b9a16 /sci-libs
parentMark 1.0.0 stable on ia64 (diff)
downloadgentoo-2-f6d3339ea8f63b0cf1f3141ce553316b4493fcc3.tar.gz
gentoo-2-f6d3339ea8f63b0cf1f3141ce553316b4493fcc3.tar.bz2
gentoo-2-f6d3339ea8f63b0cf1f3141ce553316b4493fcc3.zip
Version bump and added fortran.eclass since configure checks for fortran. This fixes bug #139849.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog9
-rw-r--r--sci-libs/fftw/fftw-3.1.2.ebuild116
-rw-r--r--sci-libs/fftw/files/digest-fftw-3.1.23
3 files changed, 127 insertions, 1 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index fc71e787ea81..4d742e633449 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/fftw
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.35 2006/06/28 10:31:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.36 2006/07/11 15:39:49 markusle Exp $
+
+*fftw-3.1.2 (11 Jul 2006)
+
+ 11 Jul 2006; Markus Dittrich <markusle@gentoo.org> +fftw-3.1.2.ebuild:
+ Version bump and added fortran.eclass since configure checks for
+ fortran. Thanks to Adam Piatyszek <ediap@et.put.poznan.pl>
+ for his ebuild. This fixes bug #139849.
28 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> fftw-3.1.1.ebuild:
Add src_test support for fftw.
diff --git a/sci-libs/fftw/fftw-3.1.2.ebuild b/sci-libs/fftw/fftw-3.1.2.ebuild
new file mode 100644
index 000000000000..c7f5389adc21
--- /dev/null
+++ b/sci-libs/fftw/fftw-3.1.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.1.2.ebuild,v 1.1 2006/07/11 15:39:49 markusle Exp $
+
+inherit flag-o-matic eutils toolchain-funcs autotools fortran
+
+DESCRIPTION="C subroutine library for computing the Discrete Fourier Transform (DFT)"
+HOMEPAGE="http://www.fftw.org/"
+SRC_URI="http://www.fftw.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="altivec sse sse2 test"
+
+DEPEND="test? ( dev-lang/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if [[ "${ARCH}" == "ppc-macos" ]];then
+ epatch "${FILESDIR}"/${PN}-ppc-macos.patch
+ fi
+
+ # fix info file
+ sed -e 's/Texinfo documentation system/Libraries/' \
+ -i doc/fftw3.info || die "failed to fix info file"
+
+ cd "${WORKDIR}"
+ mv ${P} ${P}-single
+ cp -pPR ${P}-single ${P}-double
+ cp -pPR ${P}-single ${P}-longdouble
+}
+
+src_compile() {
+ # filter -Os according to docs
+ replace-flags -Os -O2
+
+ local myconfcommon="--enable-shared --enable-threads"
+ local myconfsingle=""
+ local myconfdouble=""
+ local myconflongdouble=""
+
+ if use sse2; then
+ myconfsingle="$myconfsingle --enable-sse"
+ myconfdouble="$myconfdouble --enable-sse2"
+ elif use sse; then
+ myconfsingle="$myconfsingle --enable-sse"
+ fi
+ # altivec only helps floats, not doubles
+ if use altivec; then
+ myconfsingle="$myconfsingle --enable-altivec"
+ fi
+
+ cd "${S}-single"
+ econf \
+ ${myconfcommon} \
+ --enable-float \
+ ${myconfsingle} || \
+ die "./configure in single failed"
+ emake || die
+
+ #the only difference here is no --enable-float
+ cd "${S}-double"
+ econf \
+ ${myconfcommon} \
+ ${myconfdouble} || \
+ die "./configure in double failed"
+ emake || die
+
+ #the only difference here is --enable-long-double
+ cd "${S}-longdouble"
+ econf \
+ ${myconfcommon} \
+ --enable-long-double \
+ ${myconflongdouble} || \
+ die "./configure in long double failed"
+ emake || die
+}
+
+src_install () {
+ #all builds are installed in the same place
+ #libs have distinuguished names; include files, docs etc. identical.
+ cd "${S}-single"
+ emake DESTDIR="${D}" install || die
+
+ cd "${S}-double"
+ emake DESTDIR="${D}" install || die
+
+ cd "${S}-longdouble"
+ emake DESTDIR="${D}" install || die
+
+ # Install documentation.
+ cd "${S}-single"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS
+
+ cd doc/html
+ dohtml -r .
+}
+
+src_test () {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ local testbase="perl check.pl --nthreads=1 --estimate"
+ for d in single double longdouble; do
+ cd "${S}-${d}"/tests
+ for p in 0 1 2; do
+ n="${d/longdouble/long double} / ${p}-D"
+ einfo "Testing $n"
+ ${testbase} -${p}d || die "Failure: $n"
+ done
+ done
+}
diff --git a/sci-libs/fftw/files/digest-fftw-3.1.2 b/sci-libs/fftw/files/digest-fftw-3.1.2
new file mode 100644
index 000000000000..6aad4cc12694
--- /dev/null
+++ b/sci-libs/fftw/files/digest-fftw-3.1.2
@@ -0,0 +1,3 @@
+MD5 08f2e21c9fd02f4be2bd53a62592afa4 fftw-3.1.2.tar.gz 2736360
+RMD160 13069b3582eeaa1fba1614cdca2dfbc2e45ab585 fftw-3.1.2.tar.gz 2736360
+SHA256 e1b92e97fe27efcbd150212d0d287ac907bd2fef0af32e16284fef5d1c1c26bf fftw-3.1.2.tar.gz 2736360