summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-03 08:31:34 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-03 08:31:34 +0000
commit0521935464fe24c32a3fdbe52e3e22d451c9f130 (patch)
treefdf7e6d8de072f9db7feb54d9e8c71788fad242d /sci-mathematics/4ti2
parentRespect LDFLAGS. (diff)
downloadgentoo-2-0521935464fe24c32a3fdbe52e3e22d451c9f130.tar.gz
gentoo-2-0521935464fe24c32a3fdbe52e3e22d451c9f130.tar.bz2
gentoo-2-0521935464fe24c32a3fdbe52e3e22d451c9f130.zip
Make it gold resistant, #369849
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/4ti2')
-rw-r--r--sci-mathematics/4ti2/4ti2-1.3.2-r1.ebuild30
-rw-r--r--sci-mathematics/4ti2/4ti2-1.3.2.ebuild10
-rw-r--r--sci-mathematics/4ti2/ChangeLog10
-rw-r--r--sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch30
4 files changed, 73 insertions, 7 deletions
diff --git a/sci-mathematics/4ti2/4ti2-1.3.2-r1.ebuild b/sci-mathematics/4ti2/4ti2-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..0d95a4899a10
--- /dev/null
+++ b/sci-mathematics/4ti2/4ti2-1.3.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/4ti2/4ti2-1.3.2-r1.ebuild,v 1.1 2011/06/03 08:31:33 jlec Exp $
+
+EAPI=4
+
+inherit autotools autotools-utils
+
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="http://www.4ti2.de/"
+SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ sci-mathematics/glpk[gmp]
+ dev-libs/gmp[-nocxx]"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${P}-gold.patch )
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+}
diff --git a/sci-mathematics/4ti2/4ti2-1.3.2.ebuild b/sci-mathematics/4ti2/4ti2-1.3.2.ebuild
index 3d86b60ccd78..65d27d1c8c32 100644
--- a/sci-mathematics/4ti2/4ti2-1.3.2.ebuild
+++ b/sci-mathematics/4ti2/4ti2-1.3.2.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/4ti2/4ti2-1.3.2.ebuild,v 1.3 2010/11/21 17:46:59 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/4ti2/4ti2-1.3.2.ebuild,v 1.4 2011/06/03 08:31:33 jlec Exp $
-EAPI="3"
+EAPI=3
inherit autotools-utils
-DESCRIPTION="software package for algebraic, geometric and combinatorial problems"
-HOMEPAGE="http://www.4ti2.de"
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="http://www.4ti2.de/"
SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
LICENSE="GPL-2"
diff --git a/sci-mathematics/4ti2/ChangeLog b/sci-mathematics/4ti2/ChangeLog
index 49027557b27c..0b366642500d 100644
--- a/sci-mathematics/4ti2/ChangeLog
+++ b/sci-mathematics/4ti2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/4ti2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/4ti2/ChangeLog,v 1.3 2010/11/21 17:46:59 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/4ti2/ChangeLog,v 1.4 2011/06/03 08:31:33 jlec Exp $
+
+*4ti2-1.3.2-r1 (03 Jun 2011)
+
+ 03 Jun 2011; Justin Lecher <jlec@gentoo.org> 4ti2-1.3.2.ebuild,
+ +4ti2-1.3.2-r1.ebuild, +files/4ti2-1.3.2-gold.patch:
+ Make it gold resistant, #369849
21 Nov 2010; Markus Meier <maekke@gentoo.org> 4ti2-1.3.2.ebuild:
x86 stable, bug #346079
diff --git a/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch b/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
new file mode 100644
index 000000000000..6da08f434654
--- /dev/null
+++ b/sci-mathematics/4ti2/files/4ti2-1.3.2-gold.patch
@@ -0,0 +1,30 @@
+ m4/glpk-check.m4 | 2 +-
+ src/groebner/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/m4/glpk-check.m4 b/m4/glpk-check.m4
+index a3227dd..683d55b 100644
+--- a/m4/glpk-check.m4
++++ b/m4/glpk-check.m4
+@@ -27,7 +27,7 @@ BACKUP_CXXFLAGS=${CXXFLAGS}
+ BACKUP_LIBS=${LIBS}
+ BACKUP_CXX=${CXX}
+
+-CXX="./libtool --mode=link ${CXX}"
++CXX="libtool --mode=link ${CXX}"
+
+ AC_MSG_CHECKING(for GLPK)
+
+diff --git a/src/groebner/Makefile.am b/src/groebner/Makefile.am
+index 992c4ae..ba2f463 100644
+--- a/src/groebner/Makefile.am
++++ b/src/groebner/Makefile.am
+@@ -269,7 +269,7 @@ lib4ti2int64_la_SOURCES = $(lib4ti2sources)
+ # Arbitrary precision flags.
+ # 4ti2 uses GMP (GLPL), an arbitrary precision arithmetic library.
+ if HAVE_GMP_WITH_CXX
+-4ti2gmp_LDADD = lib4ti2gmp.la
++4ti2gmp_LDADD = lib4ti2gmp.la -lgmp
+ 4ti2gmp_CPPFLAGS = -D_4ti2_GMP_ $(GMP_CFLAGS)
+ 4ti2gmp_SOURCES = $(4ti2sources)
+ lib4ti2gmp_la_CPPFLAGS = -D_4ti2_GMP_