summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-12-17 03:31:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-12-17 03:31:49 +0000
commit383316e66fbaf4030c62395f026413e81de5a91e (patch)
treef672264d078f5f462038d35ab238ac1f5936783b /sci-mathematics/cgal
parentVersion bump. Add confd file and make init file workable with list:set, bug #... (diff)
downloadgentoo-2-383316e66fbaf4030c62395f026413e81de5a91e.tar.gz
gentoo-2-383316e66fbaf4030c62395f026413e81de5a91e.tar.bz2
gentoo-2-383316e66fbaf4030c62395f026413e81de5a91e.zip
Added mpfi support, thanks Martin von Gagern, bug #393651. Switched to EAPI4
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/cgal')
-rw-r--r--sci-mathematics/cgal/ChangeLog5
-rw-r--r--sci-mathematics/cgal/cgal-3.9.ebuild16
-rw-r--r--sci-mathematics/cgal/metadata.xml3
3 files changed, 15 insertions, 9 deletions
diff --git a/sci-mathematics/cgal/ChangeLog b/sci-mathematics/cgal/ChangeLog
index 7d3e90292105..cb08f4f2fc77 100644
--- a/sci-mathematics/cgal/ChangeLog
+++ b/sci-mathematics/cgal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/cgal
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.11 2011/11/25 18:40:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.12 2011/12/17 03:31:49 bicatali Exp $
+
+ 17 Dec 2011; Sébastien Fabbro <bicatali@gentoo.org> cgal-3.9.ebuild:
+ Added mpfi support, thanks Martin von Gagern, bug #393651. Switched to EAPI4
*cgal-3.9 (25 Nov 2011)
diff --git a/sci-mathematics/cgal/cgal-3.9.ebuild b/sci-mathematics/cgal/cgal-3.9.ebuild
index c0486b920429..cea0973bd5c6 100644
--- a/sci-mathematics/cgal/cgal-3.9.ebuild
+++ b/sci-mathematics/cgal/cgal-3.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-3.9.ebuild,v 1.1 2011/11/25 18:40:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-3.9.ebuild,v 1.2 2011/12/17 03:31:49 bicatali Exp $
-EAPI=3
+EAPI=4
CMAKE_BUILD_TYPE=Release
inherit base multilib cmake-utils
@@ -18,7 +18,7 @@ SRC_URI="http://gforge.inria.fr/frs/download.php/${PID}/${MY_P}.tar.xz
LICENSE="LGPL-2.1 MIT QPL"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+cxx doc examples +gmp lapack qt4"
+IUSE="+cxx doc examples +gmp lapack mpfi qt4"
RDEPEND="dev-libs/boost
dev-libs/mpfr
@@ -28,7 +28,8 @@ RDEPEND="dev-libs/boost
gmp? ( dev-libs/gmp[cxx=] )
lapack? ( virtual/lapack )
qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-opengl:4 )"
+ x11-libs/qt-opengl:4 )
+ mpfi? ( sci-libs/mpfi )"
DEPEND="${RDEPEND}
app-arch/xz-utils
dev-util/pkgconfig"
@@ -60,17 +61,16 @@ src_configure() {
$(cmake-utils_use_with gmp)
$(cmake-utils_use_with lapack CPACK)
$(cmake-utils_use_with qt4 CGAL_Qt4)
+ $(cmake-utils_use_with mpfi)
)
cmake-utils_src_configure
}
src_install() {
cmake-utils_src_install
- if use doc; then
- dohtml -r "${WORKDIR}"/doc_html/cgal_manual/*
- fi
+ use doc && dohtml -r "${WORKDIR}"/doc_html/cgal_manual/*
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r examples || die
+ doins -r examples
fi
}
diff --git a/sci-mathematics/cgal/metadata.xml b/sci-mathematics/cgal/metadata.xml
index ede8b8ce8651..51bda3ad07d7 100644
--- a/sci-mathematics/cgal/metadata.xml
+++ b/sci-mathematics/cgal/metadata.xml
@@ -15,4 +15,7 @@
* the Support Library which offers interfaces to other packages,
e.g., for visualisation, and I/O, and other support facilities.
</longdescription>
+<use>
+ <flag name='mpfi'>Enable support for multiple recision interval arithmetic via <pkg>sci-mathematics/mpfi</pkg></flag>
+</use>
</pkgmetadata>