summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-27 13:32:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-27 13:32:51 +0000
commitdadb7ca999b28f5692c822109744205d14f6c2a1 (patch)
tree0796d1fb6d2981e271bf0bf7a33d9caaefa7aeec /sci-mathematics/ggnfs
parentChange dev-libs/jthread dependency to be more strict (diff)
downloadgentoo-2-dadb7ca999b28f5692c822109744205d14f6c2a1.tar.gz
gentoo-2-dadb7ca999b28f5692c822109744205d14f6c2a1.tar.bz2
gentoo-2-dadb7ca999b28f5692c822109744205d14f6c2a1.zip
Initial import, ebuild by me
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/ggnfs')
-rw-r--r--sci-mathematics/ggnfs/ChangeLog9
-rw-r--r--sci-mathematics/ggnfs/Manifest3
-rw-r--r--sci-mathematics/ggnfs/ggnfs-0.77.1.ebuild53
-rw-r--r--sci-mathematics/ggnfs/metadata.xml8
4 files changed, 73 insertions, 0 deletions
diff --git a/sci-mathematics/ggnfs/ChangeLog b/sci-mathematics/ggnfs/ChangeLog
new file mode 100644
index 000000000000..ce899c1e5282
--- /dev/null
+++ b/sci-mathematics/ggnfs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-mathematics/ggnfs
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ggnfs/ChangeLog,v 1.1 2012/11/27 13:32:51 patrick Exp $
+
+*ggnfs-0.77.1 (27 Nov 2012)
+
+ 27 Nov 2012; Patrick Lauer <patrick@gentoo.org> +ggnfs-0.77.1.ebuild,
+ +metadata.xml:
+ Initial import, ebuild by me
diff --git a/sci-mathematics/ggnfs/Manifest b/sci-mathematics/ggnfs/Manifest
new file mode 100644
index 000000000000..34da9ad28e90
--- /dev/null
+++ b/sci-mathematics/ggnfs/Manifest
@@ -0,0 +1,3 @@
+DIST ggnfs-0.77.1.zip 2279013 SHA256 f6509661f22c562b3616e99989d39c160e8f49664e1fe3215d2f0d1441003a7a SHA512 77f5050d1310df5de45e80a25c8421cc9240ce11776fc4af596ce19d8b064b926dcc7e6dd7b2ef12d86056f7af0b67db2f746fc261cba24bbcf1efef06287513 WHIRLPOOL 5cb0e67aebd7ed9001ea2347b2211f9ca84ec50d18982436b111c0abb1c3223c66fbb5d029fa38d43e1137e7e7c7087daca85648fba7da92bbfcfe3760ccf87e
+EBUILD ggnfs-0.77.1.ebuild 1792 SHA256 91769b8a8fa2127b0ca39df5be99263f1ce1fb35d9adf6d74b4693f38d2ad22f SHA512 9dbecf48a1376d76f8bc32065c9630e142b26a0eaedce24ef1306685621d73e9568f443464b83cf4289423dc463a4527c3dddd72b81a1ae47f0383f1c2084c49 WHIRLPOOL 6c6138b7d711a43e8131c44e244f0be13fb5bd97e0c78a1ebc4ebeeff036f88e2dd0c2c41a592b7747a50616d3b85209afbaf07101195a7a213823a1d4b3740d
+MISC metadata.xml 233 SHA256 65209e280ca6de32a92e1a57301ff69fb3472e55ba07848d6f80405d35e92d47 SHA512 0d30bfb39315a04767e07896409f5d3954f8e954e20fcbac7b92bb9a636c9f61c50b1b2cf55e6c1db9a199a0edc159b5c8cc8f541efb9c4adafa28e3652cff7b WHIRLPOOL 027c5101e1cbc665c9d2ef240f73a874c9f49a9b70175c5947e012df61de484585088a46b6ce9078816e548e6bcc326e7223539cc999159eee2757d0a2eb1480
diff --git a/sci-mathematics/ggnfs/ggnfs-0.77.1.ebuild b/sci-mathematics/ggnfs/ggnfs-0.77.1.ebuild
new file mode 100644
index 000000000000..474de667c31c
--- /dev/null
+++ b/sci-mathematics/ggnfs/ggnfs-0.77.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ggnfs/ggnfs-0.77.1.ebuild,v 1.1 2012/11/27 13:32:51 patrick Exp $
+
+EAPI=4
+DESCRIPTION="A suite of algorithms to help factoring large integers"
+# inactive old homepage exists, this is a fork
+HOMEPAGE="https://github.com/radii/ggnfs"
+# snapshot because github makes people stupid
+SRC_URI="http://dev.gentooexperimental.org/~dreeevil/${P}.zip"
+
+inherit eutils
+
+LICENSE="GPL-2"
+SLOT="0"
+# Need to test if it actually compiles on x86
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !sci-mathematics/cado-nfs" # file collisions, fixable
+
+S=${WORKDIR}/${PN}-master
+
+src_prepare() {
+ echo "#define GGNFS_VERSION \"0.77.1-$ARCH\"" > include/version.h
+ # fix directory symlink, add missing targets, rewrite variable used by portage internally
+ cd src/lasieve4 && rm -f -r asm && ln -s ppc32 asm || die
+ sed -i -e 's/all: liblasieve.a/all: liblasieve.a liblasieveI11.a liblasieveI15.a liblasieveI16.a/' asm/Makefile || die
+ cd "${S}"
+ sed -i -e 's/ARCH/MARCH/g' Makefile src/Makefile || die
+ sed -i -e 's/$(LSBINS) strip/$(LSBINS)/' src/Makefile || die #No stripping!
+}
+
+src_configure() { :; }
+
+src_compile() {
+ # setting MARCH like this is fugly, but it uses -march=$ARCH - better fix welcome
+ # it also assumes a recent-ish compiler
+ cd src
+ HOST="generic" MARCH="native" emake
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin/"
+ for i in gnfs-lasieve4I11e gnfs-lasieve4I12e gnfs-lasieve4I13e gnfs-lasieve4I14e \
+ gnfs-lasieve4I15e gnfs-lasieve4I16e makefb matbuild matprune matsolve pol51m0b pol51m0n \
+ pol51opt polyselect procrels sieve sqrt; do
+ cp "${S}/bin/${i}" "${D}/usr/bin/" || die
+ done
+ # TODO: docs? File collisions?
+}
diff --git a/sci-mathematics/ggnfs/metadata.xml b/sci-mathematics/ggnfs/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/sci-mathematics/ggnfs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>