summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-03-23 15:04:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-03-23 15:04:29 +0000
commit87b39631a4e3f566e73e71d25089c20668ec01b1 (patch)
treeccd38b6e7815e1b932cb4d9cc7f4adc9a6f7678a /sci-mathematics/glpk
parentFix net-libs/libiscsi-1.9.0 builds, bug #462140 (diff)
downloadgentoo-2-87b39631a4e3f566e73e71d25089c20668ec01b1.tar.gz
gentoo-2-87b39631a4e3f566e73e71d25089c20668ec01b1.tar.bz2
gentoo-2-87b39631a4e3f566e73e71d25089c20668ec01b1.zip
Version bump
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics/glpk')
-rw-r--r--sci-mathematics/glpk/ChangeLog7
-rw-r--r--sci-mathematics/glpk/glpk-4.48.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index ed1aeb1a3fc4..8a71679bb263 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/glpk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.60 2013/02/21 16:53:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.61 2013/03/23 15:04:29 bicatali Exp $
+
+*glpk-4.48 (23 Mar 2013)
+
+ 23 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> +glpk-4.48.ebuild:
+ Version bump
21 Feb 2013; Justin Lecher <jlec@gentoo.org> glpk-4.47.ebuild, metadata.xml:
Drop la files
diff --git a/sci-mathematics/glpk/glpk-4.48.ebuild b/sci-mathematics/glpk/glpk-4.48.ebuild
new file mode 100644
index 000000000000..8f59d936162c
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.48.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.48.ebuild,v 1.1 2013/03/23 15:04:29 bicatali Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs autotools-utils
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc examples gmp odbc mysql static-libs"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RDEPEND="
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )
+ odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable mysql)
+ $(use_enable odbc)
+ $(use_with gmp)
+ )
+ if use mysql || use odbc; then
+ myeconfargs+=( --enable-dl )
+ else
+ myeconfargs+=( --disable-dl )
+ fi
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags libiodbc)
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ use doc && dodoc doc/*.pdf doc/notes/*.pdf doc/*.txt
+}