summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-25 07:36:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-25 07:36:31 +0000
commit845d81a7a6be831032b9da44c1cdc415b671bb41 (patch)
tree2aed1ef47cb626c6f4101880cf3c672d990a4d7a /sci-mathematics/gmp-ecm
parentamd64 stable, bug #442436 (diff)
downloadgentoo-2-845d81a7a6be831032b9da44c1cdc415b671bb41.tar.gz
gentoo-2-845d81a7a6be831032b9da44c1cdc415b671bb41.tar.bz2
gentoo-2-845d81a7a6be831032b9da44c1cdc415b671bb41.zip
Add more useflags
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/gmp-ecm')
-rw-r--r--sci-mathematics/gmp-ecm/ChangeLog8
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r2.ebuild (renamed from sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r1.ebuild)20
-rw-r--r--sci-mathematics/gmp-ecm/metadata.xml3
3 files changed, 27 insertions, 4 deletions
diff --git a/sci-mathematics/gmp-ecm/ChangeLog b/sci-mathematics/gmp-ecm/ChangeLog
index 25f38af4daa8..1087d52df43e 100644
--- a/sci-mathematics/gmp-ecm/ChangeLog
+++ b/sci-mathematics/gmp-ecm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gmp-ecm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/ChangeLog,v 1.2 2012/11/19 07:14:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/ChangeLog,v 1.3 2012/11/25 07:36:31 patrick Exp $
+
+*gmp-ecm-6.4.3-r2 (25 Nov 2012)
+
+ 25 Nov 2012; Patrick Lauer <patrick@gentoo.org> +gmp-ecm-6.4.3-r2.ebuild,
+ -gmp-ecm-6.4.3-r1.ebuild, metadata.xml:
+ Add more useflags
*gmp-ecm-6.4.3-r1 (19 Nov 2012)
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r1.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r2.ebuild
index b725bea3508e..8157ed2d681a 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r1.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r1.ebuild,v 1.1 2012/11/19 07:14:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r2.ebuild,v 1.1 2012/11/25 07:36:31 patrick Exp $
EAPI=4
DESCRIPTION="Elliptic Curve Method for Integer Factorization"
@@ -12,13 +12,27 @@ inherit eutils
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="custom-tune openmp"
-DEPEND="dev-libs/gmp"
+DEPEND="dev-libs/gmp
+ openmp? ( sys-devel/gcc[openmp] )"
RDEPEND="${DEPEND}"
S=${WORKDIR}/ecm-${PV}
+src_configure() {
+ # --enable-shellcmd is broken
+ econf $(use_enable openmp) || die
+}
+
+src_compile() {
+ emake || die
+ if use custom-tune; then
+ ./bench_mulredc | tail -n 4 >> `readlink ecm-params.h` || die
+ make clean; emake || die
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install || die
mkdir -p "${D}/usr/include/${PN}/"
diff --git a/sci-mathematics/gmp-ecm/metadata.xml b/sci-mathematics/gmp-ecm/metadata.xml
index 24cbb90cf0c4..943079ae9149 100644
--- a/sci-mathematics/gmp-ecm/metadata.xml
+++ b/sci-mathematics/gmp-ecm/metadata.xml
@@ -5,4 +5,7 @@
<email>patrick@gentoo.org</email>
<name>Patrick Lauer</name>
</maintainer>
+ <use>
+ <flag name='custom-tune'>Improve performance of some operations by selecting machine-specific defaults</flag>
+ </use>
</pkgmetadata>