summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-11 12:49:15 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-11 12:49:15 +0000
commit6986f93914c4282c190c2dc33871722ee2a8431c (patch)
tree264fd69c9f112d633a49708d62928fcc0af26743 /sci-mathematics/mlpy
parentVersion bump, drop old (diff)
downloadgentoo-2-6986f93914c4282c190c2dc33871722ee2a8431c.tar.gz
gentoo-2-6986f93914c4282c190c2dc33871722ee2a8431c.tar.bz2
gentoo-2-6986f93914c4282c190c2dc33871722ee2a8431c.zip
sci-mathematics/mlpy: Bump to EAPI=5 and distutils-r1.eclass
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics/mlpy')
-rw-r--r--sci-mathematics/mlpy/ChangeLog7
-rw-r--r--sci-mathematics/mlpy/metadata.xml12
-rw-r--r--sci-mathematics/mlpy/mlpy-3.5.0.ebuild28
3 files changed, 27 insertions, 20 deletions
diff --git a/sci-mathematics/mlpy/ChangeLog b/sci-mathematics/mlpy/ChangeLog
index e739bcdae166..5cd8089b57ab 100644
--- a/sci-mathematics/mlpy/ChangeLog
+++ b/sci-mathematics/mlpy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/mlpy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/ChangeLog,v 1.2 2012/12/06 20:36:31 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/ChangeLog,v 1.3 2013/12/11 12:49:15 jlec Exp $
+
+ 11 Dec 2013; Justin Lecher <jlec@gentoo.org> mlpy-3.5.0.ebuild, metadata.xml:
+ Bump to EAPI=5 and distutils-r1.eclass
06 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
mlpy-3.5.0.ebuild:
diff --git a/sci-mathematics/mlpy/metadata.xml b/sci-mathematics/mlpy/metadata.xml
index 2e8d0acb37bf..993d1832e9ea 100644
--- a/sci-mathematics/mlpy/metadata.xml
+++ b/sci-mathematics/mlpy/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>dberkholz@gentoo.org</email>
- <name>Donnie Berkholz</name>
-</maintainer>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <maintainer>
+ <email>dberkholz@gentoo.org</email>
+ <name>Donnie Berkholz</name>
+ </maintainer>
+ <longdescription lang="en">
mlpy provides a wide range of state-of-the-art machine learning
methods for supervised and unsupervised problems and it is aimed at
finding a reasonable compromise among modularity, maintainability,
diff --git a/sci-mathematics/mlpy/mlpy-3.5.0.ebuild b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
index 1ab2093cb732..ba376d760b0d 100644
--- a/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
+++ b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
@@ -1,30 +1,34 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/mlpy-3.5.0.ebuild,v 1.2 2012/12/06 20:36:31 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/mlpy-3.5.0.ebuild,v 1.3 2013/12/11 12:49:15 jlec Exp $
-EAPI=4
+EAPI=5
-inherit distutils
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
DESCRIPTION="High-performance Python library for predictive modeling"
HOMEPAGE="https://mlpy.fbk.eu/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND=">=sci-libs/gsl-1.11
- >=dev-python/numpy-1.3
- >=sci-libs/scipy-0.7
- >=dev-lang/python-2.6"
+
+RDEPEND="
+ >=sci-libs/gsl-1.11
+ >=dev-python/numpy-1.3[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.7[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-src_install() {
- distutils_src_install
+pyhton_install_all() {
+ distutils-r1_python_install_all
if use doc; then
pushd docs 2>/dev/null || die
- emake html || die
+ emake html
dohtml -r build/html/*
popd 2>/dev/null || die
fi