summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-23 09:32:45 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-23 09:32:45 +0000
commitb4e2ede8596996b37ca5257ddf754e4d5038b90c (patch)
tree41e5fda429e2ef5c82aecf1159f50e8682233aa6 /sci-mathematics/octave
parentVersion bump. (diff)
downloadgentoo-2-b4e2ede8596996b37ca5257ddf754e4d5038b90c.tar.gz
gentoo-2-b4e2ede8596996b37ca5257ddf754e4d5038b90c.tar.bz2
gentoo-2-b4e2ede8596996b37ca5257ddf754e4d5038b90c.zip
Fix check if mpich2 is not installed, #224913
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog6
-rw-r--r--sci-mathematics/octave/octave-2.1.73-r1.ebuild29
-rw-r--r--sci-mathematics/octave/octave-2.1.73.ebuild29
3 files changed, 33 insertions, 31 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index bb5b08c6a347..8a5e747f8cad 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.91 2010/06/13 15:07:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.92 2010/06/23 09:32:45 jlec Exp $
+
+ 23 Jun 2010; Justin Lecher <jlec@gentoo.org> octave-2.1.73.ebuild,
+ octave-2.1.73-r1.ebuild:
+ Fix check if mpich2 is not installed, #224913
13 Jun 2010; Raúl Porcel <armin76@gentoo.org> octave-3.2.4-r1.ebuild:
alpha/sparc stable wrt #318649
diff --git a/sci-mathematics/octave/octave-2.1.73-r1.ebuild b/sci-mathematics/octave/octave-2.1.73-r1.ebuild
index 262ba7da7654..79dcffdb64f8 100644
--- a/sci-mathematics/octave/octave-2.1.73-r1.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.10 2009/09/23 20:11:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.11 2010/06/23 09:32:45 jlec Exp $
inherit flag-o-matic fortran autotools
@@ -59,25 +59,24 @@ src_compile() {
# octave links agains -lmpi by default
# mpich needs -lmpich instead
if use mpi ; then
- if built_with_use sys-cluster/mpich2 cxx ; then
- elog "mpich2 must be built without C++ support!"
- die "please rebuild mpich2 with USE=-cxx..."
- else
CC="mpicc"
if has_version 'sys-cluster/mpich' ; then
- CXX="mpiCC"
- myconf="${myconf} --with-mpi=mpich"
+ CXX="mpiCC"
+ myconf="${myconf} --with-mpi=mpich"
elif has_version 'sys-cluster/mpich2' ; then
- F77="mpif77"
- myconf="${myconf} --with-mpi=mpich"
+ if built_with_use sys-cluster/mpich2 cxx ; then
+ elog "mpich2 must be built without C++ support!"
+ die "please rebuild mpich2 with USE=-cxx..."
+ fi
+ F77="mpif77"
+ myconf="${myconf} --with-mpi=mpich"
else
- myconf="${myconf} --with-mpi=mpi"
- fi
+ myconf="${myconf} --with-mpi=mpi"
fi
else
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- myconf="${myconf} --without-mpi"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ myconf="${myconf} --without-mpi"
fi
CC="${CC}" CXX="${CXX}" F77="${F77}" \
diff --git a/sci-mathematics/octave/octave-2.1.73.ebuild b/sci-mathematics/octave/octave-2.1.73.ebuild
index 3252acd3c459..9f27909978b6 100644
--- a/sci-mathematics/octave/octave-2.1.73.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73.ebuild,v 1.12 2009/09/23 20:11:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73.ebuild,v 1.13 2010/06/23 09:32:45 jlec Exp $
inherit flag-o-matic fortran
@@ -53,25 +53,24 @@ src_compile() {
# octave links agains -lmpi by default
# mpich needs -lmpich instead
if use mpi ; then
- if built_with_use sys-cluster/mpich2 cxx ; then
- elog "mpich2 must be built without C++ support!"
- die "please rebuild mpich2 with USE=-cxx..."
- else
CC="mpicc"
if has_version 'sys-cluster/mpich' ; then
- CXX="mpiCC"
- myconf="${myconf} --with-mpi=mpich"
+ CXX="mpiCC"
+ myconf="${myconf} --with-mpi=mpich"
elif has_version 'sys-cluster/mpich2' ; then
- F77="mpif77"
- myconf="${myconf} --with-mpi=mpich"
+ if built_with_use sys-cluster/mpich2 cxx ; then
+ elog "mpich2 must be built without C++ support!"
+ die "please rebuild mpich2 with USE=-cxx..."
+ fi
+ F77="mpif77"
+ myconf="${myconf} --with-mpi=mpich"
else
- myconf="${myconf} --with-mpi=mpi"
- fi
+ myconf="${myconf} --with-mpi=mpi"
fi
else
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- myconf="${myconf} --without-mpi"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ myconf="${myconf} --without-mpi"
fi
CC="${CC}" CXX="${CXX}" F77="${F77}" \