summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-05-04 16:34:52 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-05-04 16:34:52 +0000
commite616efe64e33c5d45eb7f395af8ee81077599588 (patch)
treed0d4bd49cd553ff0e6b8b97412f695380cd9c0dc /sci-mathematics/pari
parentUpdate download URL. (diff)
downloadgentoo-2-e616efe64e33c5d45eb7f395af8ee81077599588.tar.gz
gentoo-2-e616efe64e33c5d45eb7f395af8ee81077599588.tar.bz2
gentoo-2-e616efe64e33c5d45eb7f395af8ee81077599588.zip
Version bump and cleanup.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-mathematics/pari')
-rw-r--r--sci-mathematics/pari/ChangeLog8
-rw-r--r--sci-mathematics/pari/pari-2.1.5-r4.ebuild82
-rw-r--r--sci-mathematics/pari/pari-2.1.7.ebuild86
-rw-r--r--sci-mathematics/pari/pari-2.3.3.ebuild (renamed from sci-mathematics/pari/pari-2.3.0.ebuild)69
4 files changed, 50 insertions, 195 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index eba8eaea5217..2e06b92745f5 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.57 2008/04/03 12:37:59 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.58 2008/05/04 16:34:52 markusle Exp $
+
+*pari-2.3.3 (04 May 2008)
+
+ 04 May 2008; Markus Dittrich <markusle@gentoo.org> -pari-2.1.5-r4.ebuild,
+ -pari-2.1.7.ebuild, -pari-2.3.0.ebuild, +pari-2.3.3.ebuild:
+ Version bump and cleanup.
03 Apr 2008; Markus Dittrich <markusle@gentoo.org> pari-2.3.2-r1.ebuild:
Made the ebuild mode generic for it to work on BSD also (see bug #214379).
diff --git a/sci-mathematics/pari/pari-2.1.5-r4.ebuild b/sci-mathematics/pari/pari-2.1.5-r4.ebuild
deleted file mode 100644
index 7318d313a9d7..000000000000
--- a/sci-mathematics/pari/pari-2.1.5-r4.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.5-r4.ebuild,v 1.6 2007/11/16 15:46:32 markusle Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
-HOMEPAGE="http://pari.math.u-bordeaux.fr/"
-SRC_URI="http://pari.math.u-bordeaux.fr/pub/${PN}/unix/OLD/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ~mips ~ppc ~sparc x86"
-
-IUSE="doc emacs"
-
-DEPEND="doc? ( virtual/tetex )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/docs.patch
- epatch "${FILESDIR}"/wrong_functype.patch
-
-}
-
-src_compile() {
- #need to force optimization here, as it breaks without
- if is-flag -O0; then
- replace-flags -O0 -O2
- elif ! is-flag -O?; then
- append-flags -O2
- fi
-
- #we also need to force -fPIC
- if ! is-flag -fPIC; then append-flags -fPIC; fi
-
- ./Configure \
- --host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
- --prefix=/usr \
- --miscdir=/usr/share/doc/${P} \
- --datadir=/usr/share/${P} \
- --libdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man/man1 || die "./configure failed"
- addwrite "/var/lib/texmf"
- addwrite "/usr/share/texmf"
- addwrite "/var/cache/fonts"
- if use amd64; then
- # Fixes BUG #49583
- einfo "Building shared library..."
- cd Olinux-x86_64
- emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
- einfo "Building executables..."
- emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exectuables failed!"
- elif use alpha; then
- einfo "Building shared library..."
- cd Olinux-alpha
- emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
- einfo "Building executables..."
- emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exec tu ables failed!"
- elif use hppa; then
- einfo "Building shared library..."
- cd Olinux-hppa*
- mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
- emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" ${mymake} lib-dyn || die "Building shared library failed!"
- einfo "Building executables..."
- emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exec tu ables failed!"
- else
- emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp || die
- fi
- use doc || rm -rf doc/*.tex
- use doc && emake doc
-}
-
-src_install () {
- make DESTDIR="${D}" install || die
- if use emacs; then
- insinto /usr/share/emacs/site-lisp
- doins emacs/pari.el
- fi
- dodoc AUTHORS Announce.2.1 CHANGES README TODO
-}
diff --git a/sci-mathematics/pari/pari-2.1.7.ebuild b/sci-mathematics/pari/pari-2.1.7.ebuild
deleted file mode 100644
index 6c1000791242..000000000000
--- a/sci-mathematics/pari/pari-2.1.7.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.7.ebuild,v 1.7 2007/11/16 15:46:32 markusle Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
-HOMEPAGE="http://pari.math.u-bordeaux.fr/"
-SRC_URI="http://pari.math.u-bordeaux.fr/pub/${PN}/unix/OLD/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 hppa ~mips ppc sparc x86"
-IUSE="doc emacs"
-
-DEPEND="doc? ( virtual/tetex )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/docs.patch
-}
-
-src_compile() {
- # Fix usage of toolchain
- tc-getAS; tc-getLD; tc-getCC; tc-getCXX
-
- # Special handling for sparc
- local myhost
- [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparc64-linux" \
- || myhost="$(echo ${CHOST} | cut -f "1 3" -d '-')"
- einfo "Building for ${myhost}"
-
- #need to force optimization here, as it breaks without
- if is-flag -O0; then
- replace-flags -O0 -O2
- elif ! is-flag -O?; then
- append-flags -O2
- fi
- #we also need to force -fPIC throughout on amd64
- if [ "${ARCH}" = "amd64" ] && ! is-flag -fPIC; then append-flags -fPIC; fi
-
- ./Configure \
- --host=${myhost} \
- --prefix=/usr \
- --miscdir=/usr/share/doc/${PF} \
- --datadir=/usr/share/${P} \
- --libdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man/man1 || die "./configure failed"
- addwrite "/var/lib/texmf"
- addwrite "/usr/share/texmf"
- addwrite "/var/cache/fonts"
-
- if use hppa
- then
- mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
- fi
-
- # Shared libraries should be PIC on ALL architectures.
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
- # Fixes BUG #49583
- einfo "Building shared library..."
- cd Olinux-* || die "Bad directory. File a BUG!"
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
-
- einfo "Building executables..."
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
-
- use doc || rm -rf doc/*.tex
- use doc && emake doc
-}
-
-src_test() {
- ebegin "Testing pari kernel"
- make CFLAGS="-Wl,-lpari" test-kernel > /dev/null
- eend $?
-}
-
-src_install() {
- make DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install || die
- if use emacs; then
- insinto /usr/share/emacs/site-lisp
- doins emacs/pari.el
- fi
- dodoc AUTHORS Announce.2.1 CHANGES README TODO
-}
diff --git a/sci-mathematics/pari/pari-2.3.0.ebuild b/sci-mathematics/pari/pari-2.3.3.ebuild
index 8ba50baadabc..5ddfd4d87fa5 100644
--- a/sci-mathematics/pari/pari-2.3.0.ebuild
+++ b/sci-mathematics/pari/pari-2.3.3.ebuild
@@ -1,38 +1,45 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.0.ebuild,v 1.6 2007/11/16 15:46:32 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.3.ebuild,v 1.1 2008/05/04 16:34:52 markusle Exp $
-inherit eutils toolchain-funcs flag-o-matic
+inherit elisp-common eutils flag-o-matic multilib toolchain-funcs
-DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
+DESCRIPTION="A software package for computer-aided number theory"
HOMEPAGE="http://pari.math.u-bordeaux.fr/"
SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc emacs X"
DEPEND="doc? ( virtual/tetex )
sys-libs/readline
- X? ( x11-libs/libX11 )"
+ X? ( x11-libs/libX11 )
+ emacs? ( virtual/emacs )"
+SITEFILE=50${PN}-gentoo.el
+
+get_compile_dir() {
+ pushd "${S}/config" >& /dev/null
+ local fastread=yes
+ source ./get_archos
+ popd >& /dev/null
+ echo "O${osname}-${arch}"
+}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/"${PN}-2.3.2-strip.patch
+ epatch "${FILESDIR}/"${PN}-2.3.2-ppc-powerpc-arch-fix.patch
+
# disable default building of docs during install
sed -e "s:install-doc install-examples:install-examples:" \
-i config/Makefile.SH || die "Failed to fix makefile"
}
src_compile() {
- # Special handling for sparc
- local myhost
- [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparc64-linux" \
- || myhost="$(echo ${CHOST} | cut -f "1 3" -d '-')"
- einfo "Building for ${myhost}"
-
#need to force optimization here, as it breaks without
if is-flag -O0; then
replace-flags -O0 -O2
@@ -41,22 +48,21 @@ src_compile() {
fi
./Configure \
- --host=${myhost} \
--prefix=/usr \
--datadir=/usr/share/${P} \
--libdir=/usr/$(get_libdir) \
- --mandir=/usr/share/man/man1 || die "./configure failed"
+ --mandir=/usr/share/man/man1 || die "./Configure failed"
- if use hppa
- then
+ if use hppa; then
mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
fi
# Shared libraries should be PIC on ALL architectures.
# Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
# Fixes BUG #49583
+ local installdir=$(get_compile_dir)
einfo "Building shared library..."
- cd Olinux-* || die "Bad directory. File a BUG!"
+ cd "${installdir}" || die "Bad directory. File a BUG!"
emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
einfo "Building executables..."
@@ -66,32 +72,43 @@ src_compile() {
cd "${S}"
emake docpdf || die "Failed to generate docs"
fi
+
+ if use emacs; then
+ cd "${S}/emacs"
+ elisp-comp *.el || die "elisp-comp failed"
+ fi
}
src_test() {
- ebegin "Testing pari kernel"
- make test-kernel > /dev/null
- eend $?
+ make test-kernel
}
src_install() {
- make DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install || \
+ emake DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install || \
die "Install failed"
if use emacs; then
- insinto /usr/share/emacs/site-lisp
- doins emacs/pari.el
+ elisp-install ${PN} emacs/*.el emacs/*.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
- dodoc AUTHORS Announce.2.1 CHANGES README TODO
+ dodoc AUTHORS Announce.2.1 CHANGES README TODO NEW
if use doc; then
- make DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install-doc \
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install-doc \
|| die "Failed to install docs"
insinto /usr/share/doc/${PF}
doins doc/*.pdf || die "Failed to install pdf docs"
fi
#remove superfluous doc directory
- rm -fr "${D}"/usr/share/${P}/doc || \
+ rm -fr "${D}/usr/share/${P}/doc" || \
die "Failed to clean up doc directory"
}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}