summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2014-06-26 12:22:39 +0000
committerThomas Kahle <tomka@gentoo.org>2014-06-26 12:22:39 +0000
commit872b52f63c53970ad4e30392a300486275336a79 (patch)
tree49a519fe7b04419395762d1141bd694b8a43917a /sci-mathematics/polymake
parentminor enhancement wrt #492846 (diff)
downloadgentoo-2-872b52f63c53970ad4e30392a300486275336a79.tar.gz
gentoo-2-872b52f63c53970ad4e30392a300486275336a79.tar.bz2
gentoo-2-872b52f63c53970ad4e30392a300486275336a79.zip
bump to 2.13
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 565C32BC)
Diffstat (limited to 'sci-mathematics/polymake')
-rw-r--r--sci-mathematics/polymake/ChangeLog9
-rw-r--r--sci-mathematics/polymake/polymake-2.13.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/sci-mathematics/polymake/ChangeLog b/sci-mathematics/polymake/ChangeLog
index 65bac841042e..66292da46b72 100644
--- a/sci-mathematics/polymake/ChangeLog
+++ b/sci-mathematics/polymake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/polymake
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.11 2013/09/14 12:44:47 tomka Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.12 2014/06/26 12:22:39 tomka Exp $
+
+*polymake-2.13 (26 Jun 2014)
+
+ 26 Jun 2014; Thomas Kahle <tomka@gentoo.org> +polymake-2.13.ebuild:
+ bump to 2.13
14 Sep 2013; Thomas Kahle <tomka@gentoo.org> -files/2.10-drop-jreality.patch,
-files/2.10-soname.patch, -polymake-2.10.ebuild, -polymake-2.11.ebuild:
diff --git a/sci-mathematics/polymake/polymake-2.13.ebuild b/sci-mathematics/polymake/polymake-2.13.ebuild
new file mode 100644
index 000000000000..e93e99ec5390
--- /dev/null
+++ b/sci-mathematics/polymake/polymake-2.13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/polymake-2.13.ebuild,v 1.1 2014/06/26 12:22:39 tomka Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+MY_PV=${PV}-1
+
+DESCRIPTION="research tool for polyhedral geometry and combinatorics"
+SRC_URI="http://polymake.org/lib/exe/fetch.php/download/${PN}-${MY_PV}.tar.bz2"
+HOMEPAGE="http://polymake.org"
+
+IUSE="libpolymake"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-libs/gmp
+ dev-libs/boost
+ dev-libs/libxml2:2
+ dev-perl/XML-LibXML
+ dev-libs/libxslt
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-Writer
+ dev-perl/Term-ReadLine-Gnu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # Don't strip
+ sed -i '/system "strip $to"/d' support/install.pl || die
+
+ einfo "During compile this package uses up to"
+ einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
+ einfo "you run into trouble."
+}
+
+src_configure () {
+ export CXXOPT=$(get-flag -O)
+ # Configure does not accept --host, therefore econf cannot be used
+ ./configure --prefix="${EPREFIX}/usr" \
+ --without-java \
+ $(use_with libpolymake callable) \
+ --without-prereq \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
+ "${myconf}" || die
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install
+ dosym libpolymake.so "${EPREFIX}/usr/$(get_libdir)/libpolymake.so.0"
+}
+
+pkg_postinst(){
+ elog "Docs can be found on http://www.polymake.org/doku.php/documentation"
+ elog " "
+ elog "Support for jreality is missing, sorry (see bug #346073)."
+}