summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-08-01 12:24:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-08-01 12:24:11 +0000
commitdaa46bdbf12173997ecf8332b662f2623d235003 (patch)
treea5aba92af91c909e188134b58d44038a66ffa4c7 /sci-mathematics/rkward
parentChanged wxwindows to wxwidgets use flag (diff)
downloadgentoo-2-daa46bdbf12173997ecf8332b662f2623d235003.tar.gz
gentoo-2-daa46bdbf12173997ecf8332b662f2623d235003.tar.bz2
gentoo-2-daa46bdbf12173997ecf8332b662f2623d235003.zip
Version bumps and fixes, thanks to Michel Lang, bug #269940.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/rkward')
-rw-r--r--sci-mathematics/rkward/ChangeLog9
-rw-r--r--sci-mathematics/rkward/rkward-0.4.9b.ebuild36
-rw-r--r--sci-mathematics/rkward/rkward-0.5.0d.ebuild (renamed from sci-mathematics/rkward/rkward-0.5.0c.ebuild)2
3 files changed, 45 insertions, 2 deletions
diff --git a/sci-mathematics/rkward/ChangeLog b/sci-mathematics/rkward/ChangeLog
index e6eae0de78f1..6e1c71fc69d4 100644
--- a/sci-mathematics/rkward/ChangeLog
+++ b/sci-mathematics/rkward/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/rkward
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/ChangeLog,v 1.16 2009/04/01 11:56:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/ChangeLog,v 1.17 2009/08/01 12:24:11 bicatali Exp $
+
+*rkward-0.5.0d (18 Jun 2009)
+*rkward-0.4.9b (18 Jun 2009)
+
+ 18 Jun 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +rkward-0.4.9b.ebuild, -rkward-0.5.0c.ebuild, +rkward-0.5.0d.ebuild:
+ Version bumps and fixes, thanks to Michel Lang, bug #269940.
*rkward-0.5.0c (01 Apr 2009)
diff --git a/sci-mathematics/rkward/rkward-0.4.9b.ebuild b/sci-mathematics/rkward/rkward-0.4.9b.ebuild
new file mode 100644
index 000000000000..1906ecb95e4a
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.4.9b.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/rkward-0.4.9b.ebuild,v 1.1 2009/08/01 12:24:11 bicatali Exp $
+
+EAPI="2"
+
+ARTS_REQUIRED="never"
+
+inherit eutils kde
+
+DESCRIPTION="An IDE/GUI for the R-project"
+HOMEPAGE="http://rkward.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rkward/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/R"
+RDEPEND="${DEPEND}
+ dev-lang/php[cli]
+ !>=sci-mathematics/rkward-0.5
+ !>=kde-base/kdelibs-4"
+
+need-kde 3
+
+src_install() {
+ # rbackend needed directory (R-2.5.0 broken)
+ dodir /usr/$(get_libdir)/R/library
+ kde_src_install
+ # already provided by R
+ rm -f "${D}"/usr/$(get_libdir)/R/library/R.css
+ # already provided by kdelibs
+ rm -f "${D}"/share/apps/katepart/syntax/r.xml
+}
diff --git a/sci-mathematics/rkward/rkward-0.5.0c.ebuild b/sci-mathematics/rkward/rkward-0.5.0d.ebuild
index 3f40260f8f83..e13a3d763c07 100644
--- a/sci-mathematics/rkward/rkward-0.5.0c.ebuild
+++ b/sci-mathematics/rkward/rkward-0.5.0d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/rkward-0.5.0c.ebuild,v 1.1 2009/04/01 11:56:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/rkward-0.5.0d.ebuild,v 1.1 2009/08/01 12:24:11 bicatali Exp $
EAPI="2"
KDE_MINIMAL="4.1"