summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-04-25 14:32:04 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-04-25 14:32:04 +0000
commitf9ad3955340948b11429f8be0f892e3b2cd1b86c (patch)
treeaa66ea961849350d46a5776c84458b9047fd677f /sci-mathematics/scilab
parentVersion bump (bug #131131). (diff)
downloadgentoo-2-f9ad3955340948b11429f8be0f892e3b2cd1b86c.tar.gz
gentoo-2-f9ad3955340948b11429f8be0f892e3b2cd1b86c.tar.bz2
gentoo-2-f9ad3955340948b11429f8be0f892e3b2cd1b86c.zip
Revision bump (see bug #117490). Currently package masked for furter testing.
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'sci-mathematics/scilab')
-rw-r--r--sci-mathematics/scilab/ChangeLog9
-rw-r--r--sci-mathematics/scilab/files/digest-scilab-4.03
-rw-r--r--sci-mathematics/scilab/files/scilab-4.0-makefile.patch43
-rw-r--r--sci-mathematics/scilab/scilab-4.0.ebuild124
4 files changed, 178 insertions, 1 deletions
diff --git a/sci-mathematics/scilab/ChangeLog b/sci-mathematics/scilab/ChangeLog
index c64b0a348c42..7e8230c48066 100644
--- a/sci-mathematics/scilab/ChangeLog
+++ b/sci-mathematics/scilab/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/scilab
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.18 2006/04/25 13:51:34 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.19 2006/04/25 14:32:04 markusle Exp $
+
+*scilab-4.0 (25 Apr 2006)
+
+ 25 Apr 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/scilab-4.0-makefile.patch, +scilab-4.0.ebuild:
+ Revision bump (see bug #117490). Currently package masked for
+ furter testing.
25 Apr 2006; Markus Dittrich <markusle@gentoo.org> scilab-2.7-r3.ebuild:
Removed virtual/x11 since all necessary X dependencies are being
diff --git a/sci-mathematics/scilab/files/digest-scilab-4.0 b/sci-mathematics/scilab/files/digest-scilab-4.0
new file mode 100644
index 000000000000..b1e8cc22071d
--- /dev/null
+++ b/sci-mathematics/scilab/files/digest-scilab-4.0
@@ -0,0 +1,3 @@
+MD5 26e1c1480453bb1021bcea3ac412ad19 scilab-4.0-src.tar.gz 12523941
+RMD160 13e8637b0793650b0dd2ae07ccaa6bbbff62375c scilab-4.0-src.tar.gz 12523941
+SHA256 e0f0e784909020c34c4512cf34f946373950cb5f8ee5499a16af73880189d41d scilab-4.0-src.tar.gz 12523941
diff --git a/sci-mathematics/scilab/files/scilab-4.0-makefile.patch b/sci-mathematics/scilab/files/scilab-4.0-makefile.patch
new file mode 100644
index 000000000000..99a6f731dc90
--- /dev/null
+++ b/sci-mathematics/scilab/files/scilab-4.0-makefile.patch
@@ -0,0 +1,43 @@
+--- scilab-4.0-old/Makefile.in 2006-02-14 06:14:22.000000000 -0600
++++ scilab-4.0/Makefile.in 2006-04-23 10:09:01.000000000 -0500
+@@ -206,28 +206,12 @@
+ pvm3/bin/@PVMARCH@/*
+
+ INSTBINDISTFILES = \
+- .pvmd.conf \
+- ACKNOWLEDGEMENTS \
+- CHANGES \
+- Makefile \
+- Makefile.OBJ \
+- Makefile.incl \
+- Makemex \
+- Path.incl \
+- README_Unix \
+- Version.incl \
+- configure \
+- libtool \
+- license.txt \
+- licence.txt \
+ scilab.quit \
+ scilab.star \
+ X11_defaults \
+ bin \
+- config \
+ contrib \
+ demos \
+- examples \
+ imp/NperiPos.ps \
+ imp/giffonts \
+ macros \
+@@ -261,11 +245,7 @@
+ @if test `pwd`/.. != $(PREFIX)/lib ; then \
+ install -d $(PREFIX)/lib/$(SCIBASE); \
+ ( for file in $(INSTBINDISTFILES) @PVMINST1@; do tar cf - $${file} | (cd $(PREFIX)/lib/$(SCIBASE); tar xf -); done); \
+- (cd $(PREFIX)/lib/$(SCIBASE);touch .binary; make postinstall PREFIX=$(PREFIX) ) \
+ fi
+- install -d $(PREFIX)/share/doc/$(DOCNAME)/
+- install ACKNOWLEDGEMENTS CHANGES README_Unix Version.incl \
+- licence.txt license.txt $(PREFIX)/share/doc/$(DOCNAME)
+ install -d $(PREFIX)/bin
+ $(RM) $(PREFIX)/bin/scilab
+ ln -fs $(PREFIX)/lib/$(SCIBASE)/bin/scilab $(PREFIX)/bin/scilab
diff --git a/sci-mathematics/scilab/scilab-4.0.ebuild b/sci-mathematics/scilab/scilab-4.0.ebuild
new file mode 100644
index 000000000000..eb3585a228fb
--- /dev/null
+++ b/sci-mathematics/scilab/scilab-4.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.0.ebuild,v 1.1 2006/04/25 14:32:04 markusle Exp $
+
+inherit eutils fortran toolchain-funcs multilib
+
+DESCRIPTION="Scientific software package for numerical computations (Matlab lookalike)"
+LICENSE="scilab"
+SRC_URI="http://scilabsoft.inria.fr/download/stable/${P}-src.tar.gz"
+HOMEPAGE="http://www.scilab.org/"
+
+SLOT="0"
+IUSE="ocaml tcltk gtk Xaw3d java"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="virtual/blas
+ virtual/lapack
+ sys-libs/ncurses
+ gtk? (
+ media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ >=x11-libs/gtk+-2
+ >=x11-libs/libzvt-2
+ x11-libs/vte
+ =gnome-extra/gtkhtml-2*
+ )
+ tcltk? ( >=dev-lang/tk-8.4
+ >=dev-lang/tcl-8.4 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ ocaml? ( dev-lang/ocaml )"
+
+DEPEND="${RDEPEND}
+ app-text/sablotron"
+
+pkg_setup() {
+ if ! use gtk && ! use tcltk; then
+ echo
+ eerror 'scilab must be built with either USE="gtk" or USE="tcltk"'
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ sed -e '/^ATLAS_LAPACKBLAS\>/s,=.*,= $(ATLASDIR)/liblapack.so $(ATLASDIR)/libblas.so $(ATLASDIR)/libcblas.so,' \
+ -e 's,$(SCIDIR)/libs/lapack.a,,' \
+ -i Makefile.OBJ.in || die "Failed to fix Makefile.OBJ.in"
+
+ sed -e "s:\$(PREFIX):\${D}/\$(PREFIX):g" \
+ -i Makefile.in || die "Failed to fix Makefile.in"
+
+ sed -e "s:@CC_OPTIONS@:${CFLAGS}:" \
+ -e "s:@FC_OPTIONS@:${FFLAGS}:" \
+ -e "s:@LD_LDFLAGS@:$LDFLAGS}:" \
+ -i Makefile.incl.in || die "Failed to fix Makefile.incl.in"
+}
+
+src_compile() {
+ local myopts
+ myopts="${myopts} --with-atlas-library=/usr/$(get_libdir)"
+
+ econf $(use_with tcltk tk) \
+ $(use_with Xaw3d xaw3d) \
+ $(use_with gtk gtk2 ) \
+ $(use_with ocaml) \
+ $(use_with java ) \
+ ${myopts} || die "econf failed"
+ env HOME="${S}" emake all || die "emake failed"
+}
+
+src_install() {
+ DESTDIR="${D}" make install || die "installation failed"
+
+ # some postinstall fixes
+ echo "SCIDIR=/usr/$(get_libdir)/${P}" > \
+ "${D}/usr/$(get_libdir)/${P}/Path.incl"
+ strip "${D}/usr/$(get_libdir)/${P}/bin/scilex"
+
+ # install docs
+ dodoc ACKNOWLEDGEMENTS CHANGES README_Unix RELEASE_NOTES \
+ Readme_Visual.txt license.txt \
+ || die "failed to install docs"
+
+ # install examples
+ insinto /usr/share/${PN}/
+ doins -r examples/ || die "failed to install examples"
+
+ # The compile and install process causes the work folder
+ # to be registered as the runtime folder in many files.
+ # This is corrected here.
+ BAD_REF="${WORKDIR}/${P}"
+ FIXED_REF="/usr/$(get_libdir)/${P}"
+ BIN_TO_FIX="Blpr BEpsf Blatexpr2 Blatexprs Blatexpr scilab"
+ for i in ${BIN_TO_FIX}; do
+ sed -e "s%${BAD_REF}%${FIXED_REF}%" -i \
+ "${D}"/usr/$(get_libdir)/${P}/bin/${i} || \
+ die "Failed to fix wrapper scripts"
+ done
+ MAN_TO_FIX="eng fr"
+ for i in ${MAN_TO_FIX}; do
+ for j in "${D}"/usr/$(get_libdir)/${P}/man/${i}/*.h*; do
+ sed -e "s%${BAD_REF}%${FIXED_REF}%" -i ${j} || \
+ die "Failed to fix manuals"
+ done
+ done
+ MISC_TO_FIX="util/Blatdoc util/Blatdocs"
+ for i in ${MISC_TO_FIX}; do
+ sed -e "s%${BAD_REF}%${FIXED_REF}%" -i \
+ "${D}"/usr/$(get_libdir)/${P}/${i} || \
+ die "Failed to fix Blatdocs"
+ done
+}
+
+pkg_postinst() {
+ einfo "To tell Scilab about your printers, set the environment"
+ einfo "variable PRINTERS in the form:"
+ einfo
+ einfo "PRINTERS=\"firstPrinter:secondPrinter:anotherPrinter\""
+}