summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-14 08:38:25 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-14 08:38:25 +0000
commit302f5ef4c514716944988f8bb9ac81b8cc3f5b24 (patch)
tree8aa0524022741d1a4f07f101c8717ec84bbf187a /sci-mathematics/snns
parentAdd 2.9 development branch (bug #298387 by sping). (diff)
downloadgentoo-2-302f5ef4c514716944988f8bb9ac81b8cc3f5b24.tar.gz
gentoo-2-302f5ef4c514716944988f8bb9ac81b8cc3f5b24.tar.bz2
gentoo-2-302f5ef4c514716944988f8bb9ac81b8cc3f5b24.zip
Respect LDFLAGS wrt bug 332475. Thanks to Diego for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/snns')
-rw-r--r--sci-mathematics/snns/ChangeLog6
-rw-r--r--sci-mathematics/snns/files/4.2-ldflags.patch42
-rw-r--r--sci-mathematics/snns/snns-4.2-r8.ebuild5
3 files changed, 50 insertions, 3 deletions
diff --git a/sci-mathematics/snns/ChangeLog b/sci-mathematics/snns/ChangeLog
index 6e04c1206b14..9c029965167e 100644
--- a/sci-mathematics/snns/ChangeLog
+++ b/sci-mathematics/snns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/snns
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.20 2010/06/04 16:03:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.21 2010/08/14 08:38:24 xarthisius Exp $
+
+ 14 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/4.2-ldflags.patch, snns-4.2-r8.ebuild:
+ Respect LDFLAGS wrt bug 332475. Thanks to Diego for report.
04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
snns-4.2-r8.ebuild:
diff --git a/sci-mathematics/snns/files/4.2-ldflags.patch b/sci-mathematics/snns/files/4.2-ldflags.patch
new file mode 100644
index 000000000000..752380d1d8f0
--- /dev/null
+++ b/sci-mathematics/snns/files/4.2-ldflags.patch
@@ -0,0 +1,42 @@
+Respect LDFLAGS
+
+https://bugs.gentoo.org/show_bug.cgi?id=332475
+
+--- tools/sources/Makefile
++++ tools/sources/Makefile
+@@ -147,19 +147,19 @@
+ # Linking of single stand alone programs
+
+ analyze: analyze.o
+- $(CC) analyze.o -lm -o analyze
++ $(CC) $(LDFLAGS) analyze.o -lm -o analyze
+
+ pat_sel_simple: pat_sel_simple.o
+- $(CC) pat_sel_simple.o -lm -o pat_sel_simple
++ $(CC) $(LDFLAGS) pat_sel_simple.o -lm -o pat_sel_simple
+
+ mkhead: mkhead.o
+- $(CC) mkhead.o -lm -o mkhead
++ $(CC) $(LDFLAGS) mkhead.o -lm -o mkhead
+
+ mkout: mkout.o
+- $(CC) mkout.o -lm -o mkout
++ $(CC) $(LDFLAGS) mkout.o -lm -o mkout
+
+ mkpat: mkpat.o
+- $(CC) mkpat.o -lm -o mkpat
++ $(CC) $(LDFLAGS) mkpat.o -lm -o mkpat
+
+
+ # Make sure that kernel libs are available and up to date
+--- xgui/sources/Makefile
++++ xgui/sources/Makefile
+@@ -202,7 +202,7 @@
+ # Linking of xgui
+
+ xgui: $(LIBXGUI1) $(LIBXGUI2) $(BN3DLIB) $(KERNELLIBS)
+- $(CC) $(LIBXGUI1) $(LIBXGUI2) $(BN3DLIB) \
++ $(CC) $(LDFLAGS) $(LIBXGUI1) $(LIBXGUI2) $(BN3DLIB) \
+ $(X_LIBS) -lXaw3d -lXmu -lXt -lXext $(X_PRE_LIBS) -lX11 $(X_EXTRA_LIBS) \
+ $(KERNELALLLIBS) -o xgui
+
diff --git a/sci-mathematics/snns/snns-4.2-r8.ebuild b/sci-mathematics/snns/snns-4.2-r8.ebuild
index 0a0e0ddb228f..321f6bb97827 100644
--- a/sci-mathematics/snns/snns-4.2-r8.ebuild
+++ b/sci-mathematics/snns/snns-4.2-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r8.ebuild,v 1.8 2010/06/04 16:03:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r8.ebuild,v 1.9 2010/08/14 08:38:24 xarthisius Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -44,7 +44,8 @@ src_unpack() {
}
src_prepare() {
- epatch "${WORKDIR}/${MYPATCH}.patch"
+ epatch "${WORKDIR}/${MYPATCH}.patch" \
+ "${FILESDIR}/${PV}-ldflags.patch"
if use python; then
epatch "${FILESDIR}/${PV}-fPIC-python.patch"