summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-12 06:19:23 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-12 06:19:23 +0000
commit79c6c288189ab8981bce02ed9ebd30c52891d878 (patch)
tree71c0c5ea43607d86fdc12d9d57c02f821ed1d3ce /sci-mathematics/topcom
parentmarked x86 per bug 425924 (diff)
downloadgentoo-2-79c6c288189ab8981bce02ed9ebd30c52891d878.tar.gz
gentoo-2-79c6c288189ab8981bce02ed9ebd30c52891d878.tar.bz2
gentoo-2-79c6c288189ab8981bce02ed9ebd30c52891d878.zip
sci-mathematics/topcom: Version Bump, fix compilation with gcc-4.7, #426214
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/topcom')
-rw-r--r--sci-mathematics/topcom/ChangeLog11
-rw-r--r--sci-mathematics/topcom/files/topcom-0.17.4-buildsystem.patch105
-rw-r--r--sci-mathematics/topcom/files/topcom-0.17.4-no-internal-libs.patch77
-rw-r--r--sci-mathematics/topcom/metadata.xml12
-rw-r--r--sci-mathematics/topcom/topcom-0.16.2.ebuild36
-rw-r--r--sci-mathematics/topcom/topcom-0.17.4.ebuild53
6 files changed, 267 insertions, 27 deletions
diff --git a/sci-mathematics/topcom/ChangeLog b/sci-mathematics/topcom/ChangeLog
index 53a4bcea5d68..7ffb4d6ef56a 100644
--- a/sci-mathematics/topcom/ChangeLog
+++ b/sci-mathematics/topcom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/topcom
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/topcom/ChangeLog,v 1.1 2010/11/09 17:48:55 tomka Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/topcom/ChangeLog,v 1.2 2012/07/12 06:19:23 jlec Exp $
+
+*topcom-0.17.4 (12 Jul 2012)
+
+ 12 Jul 2012; Justin Lecher <jlec@gentoo.org> topcom-0.16.2.ebuild,
+ +topcom-0.17.4.ebuild, +files/topcom-0.17.4-buildsystem.patch,
+ +files/topcom-0.17.4-no-internal-libs.patch, metadata.xml:
+ Version Bump, fix compilation with gcc-4.7, #426214
*topcom-0.16.2 (09 Nov 2010)
diff --git a/sci-mathematics/topcom/files/topcom-0.17.4-buildsystem.patch b/sci-mathematics/topcom/files/topcom-0.17.4-buildsystem.patch
new file mode 100644
index 000000000000..e8546aa846dc
--- /dev/null
+++ b/sci-mathematics/topcom/files/topcom-0.17.4-buildsystem.patch
@@ -0,0 +1,105 @@
+ lib-src-reg/Makefile.am | 8 +++-----
+ lib-src/Makefile.am | 8 +++-----
+ src-reg/Makefile.am | 12 +++++-------
+ src/Makefile.am | 12 +++++-------
+ wrap-gmp-gmpxx/Makefile.am | 2 +-
+ 5 files changed, 17 insertions(+), 25 deletions(-)
+
+diff --git a/lib-src-reg/Makefile.am b/lib-src-reg/Makefile.am
+index 67c1dc9..202d6fa 100644
+--- a/lib-src-reg/Makefile.am
++++ b/lib-src-reg/Makefile.am
+@@ -10,11 +10,9 @@ SPXinterface.hh \
+ RegularityCheck.hh \
+ LPinterface.hh
+
+-INCLUDES = -I../lib-src
+-INCLUDES += -I../wrap-gmp-gmpxx
+-INCLUDES += -I../external/include
++INCLUDES = -I$(top_srcdir)/lib-src
++INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
++INCLUDES += -I$(top_srcdir)/external/include
+ INCLUDES += -I$(includedir)
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
+-
+-AM_CXXFLAGS = -O2
+diff --git a/lib-src/Makefile.am b/lib-src/Makefile.am
+index defed87..c94109c 100644
+--- a/lib-src/Makefile.am
++++ b/lib-src/Makefile.am
+@@ -88,11 +88,9 @@ VertexFacetTable.hh \
+ VertexFacetTableArray.hh \
+ VirtualChiro.hh
+
+-INCLUDES = -I../lib-src-reg
+-INCLUDES += -I../wrap-gmp-gmpxx
+-INCLUDES += -I../external/include
++INCLUDES = -I$(top_srcdir)/lib-src-reg
++INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
++INCLUDES += -I$(top_srcdir)/external/include
+ INCLUDES += -I$(includedir)
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-35
+-
+-AM_CXXFLAGS = -O2 -g
+diff --git a/src-reg/Makefile.am b/src-reg/Makefile.am
+index b0219a5..e9b00bc 100644
+--- a/src-reg/Makefile.am
++++ b/src-reg/Makefile.am
+@@ -2,15 +2,13 @@ bin_PROGRAMS = checkregularity
+
+ checkregularity_SOURCES = checkregularity.cc
+
+-LDADD = ../lib-src-reg/libCHECKREG.a \
+- ../lib-src/libTOPCOM.a
++LDADD = $(top_builddir)/lib-src-reg/libCHECKREG.a \
++ $(top_builddir)/lib-src/libTOPCOM.a
+
+-INCLUDES = -I../lib-src
+-INCLUDES += -I../lib-src-reg
+-INCLUDES += -I../wrap-gmp-gmpxx
++INCLUDES = -I$(top_srcdir)/lib-src
++INCLUDES += -I$(top_srcdir)/lib-src-reg
++INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
+ INCLUDES += -I$(includedir)
+
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
+-
+-AM_CXXFLAGS = -O2
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 5ba9b22..4c59202 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -85,14 +85,12 @@ santos_triang_SOURCES = santos_triang.cc
+ santos_dim4_triang_SOURCES = santos_dim4_triang.cc
+ santos_22_triang_SOURCES = santos_22_triang.cc
+
+-LDADD = ../lib-src/libTOPCOM.a \
+- ../lib-src-reg/libCHECKREG.a
++LDADD = $(top_builddir)/lib-src/libTOPCOM.a \
++ $(top_builddir)/lib-src-reg/libCHECKREG.a
+
+-INCLUDES = -I../lib-src
+-INCLUDES += -I../lib-src-reg
+-INCLUDES += -I../wrap-gmp-gmpxx
++INCLUDES = -I$(top_srcdir)/lib-src
++INCLUDES += -I$(top_srcdir)/lib-src-reg
++INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
+ INCLUDES += -I$(includedir)
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
+-
+-AM_CXXFLAGS = -O2
+diff --git a/wrap-gmp-gmpxx/Makefile.am b/wrap-gmp-gmpxx/Makefile.am
+index 383e003..d93a637 100644
+--- a/wrap-gmp-gmpxx/Makefile.am
++++ b/wrap-gmp-gmpxx/Makefile.am
+@@ -2,5 +2,5 @@ include_HEADERS = \
+ Integer.h \
+ Rational.h
+
+-INCLUDES = -I../external/include
++INCLUDES = -I$(top_srcdir)/external/include
+ INCLUDES += -I$(includedir)
diff --git a/sci-mathematics/topcom/files/topcom-0.17.4-no-internal-libs.patch b/sci-mathematics/topcom/files/topcom-0.17.4-no-internal-libs.patch
new file mode 100644
index 000000000000..e9cffeec7440
--- /dev/null
+++ b/sci-mathematics/topcom/files/topcom-0.17.4-no-internal-libs.patch
@@ -0,0 +1,77 @@
+ Makefile.am | 4 ----
+ configure.ac | 6 +-----
+ src-reg/Makefile.am | 6 +-----
+ src/Makefile.am | 6 +-----
+ 4 files changed, 3 insertions(+), 19 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 640652f..00ba26a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,2 @@
+ SUBDIRS = wrap-gmp-gmpxx lib-src-reg lib-src src-reg src examples
+ EXTRA_DIST = external/Makefile
+-EXTRA_DIST += external/gmp-5.0.5.tar.bz2
+-EXTRA_DIST += external/cddlib-0.94f-TOPCOM.tar.gz
+-EXTRA_DIST += external/gmpxx-patch
+-
+diff --git a/configure.ac b/configure.ac
+index b737f27..ecd38ce 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,12 +17,8 @@ dnl Replace `main' with a function in -lstdc:
+ dnl AC_CHECK_LIB(stdc, main)
+ dnl Replace `main' with a function in -lstdc++:
+ dnl AC_CHECK_LIB(stdc++, main)
+-dnl Make libgmp:
+-make -C external gmp
+-dnl Make libcddgmp:
+-make -C external cdd
+ dnl Check for soplex:
+-AC_CHECK_LIB(soplex, main, , csh -c 'echo soplex not found: --soplex will not work.')
++AC_CHECK_LIB(soplex, main, , sh -c 'echo soplex not found: --soplex will not work.')
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+diff --git a/src-reg/Makefile.am b/src-reg/Makefile.am
+index c976e34..b0219a5 100644
+--- a/src-reg/Makefile.am
++++ b/src-reg/Makefile.am
+@@ -3,15 +3,11 @@ bin_PROGRAMS = checkregularity
+ checkregularity_SOURCES = checkregularity.cc
+
+ LDADD = ../lib-src-reg/libCHECKREG.a \
+- ../lib-src/libTOPCOM.a \
+- ../external/lib/libcddgmp.a \
+- ../external/lib/libgmpxx.a \
+- ../external/lib/libgmp.a
++ ../lib-src/libTOPCOM.a
+
+ INCLUDES = -I../lib-src
+ INCLUDES += -I../lib-src-reg
+ INCLUDES += -I../wrap-gmp-gmpxx
+-INCLUDES += -I../external/include
+ INCLUDES += -I$(includedir)
+
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 4c35135..5ba9b22 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -86,15 +86,11 @@ santos_dim4_triang_SOURCES = santos_dim4_triang.cc
+ santos_22_triang_SOURCES = santos_22_triang.cc
+
+ LDADD = ../lib-src/libTOPCOM.a \
+- ../lib-src-reg/libCHECKREG.a \
+- ../external/lib/libcddgmp.a \
+- ../external/lib/libgmpxx.a \
+- ../external/lib/libgmp.a
++ ../lib-src-reg/libCHECKREG.a
+
+ INCLUDES = -I../lib-src
+ INCLUDES += -I../lib-src-reg
+ INCLUDES += -I../wrap-gmp-gmpxx
+-INCLUDES += -I../external/include
+ INCLUDES += -I$(includedir)
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
diff --git a/sci-mathematics/topcom/metadata.xml b/sci-mathematics/topcom/metadata.xml
index fb6885a0e2c9..623d96beb1cf 100644
--- a/sci-mathematics/topcom/metadata.xml
+++ b/sci-mathematics/topcom/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
-<email>tomka@gentoo.org</email>
-<name>Thomas Kahle</name>
-</maintainer>
-<herd>sci</herd>
-<longdescription lang="en">
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <herd>sci</herd>
+ <longdescription lang="en">
TOPCOM is a package for computing Triangulations Of Point Configurations and Oriented Matroids
</longdescription>
</pkgmetadata>
diff --git a/sci-mathematics/topcom/topcom-0.16.2.ebuild b/sci-mathematics/topcom/topcom-0.16.2.ebuild
index 869cd6d81722..9647ca58c444 100644
--- a/sci-mathematics/topcom/topcom-0.16.2.ebuild
+++ b/sci-mathematics/topcom/topcom-0.16.2.ebuild
@@ -1,30 +1,34 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/topcom/topcom-0.16.2.ebuild,v 1.1 2010/11/09 17:48:55 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/topcom/topcom-0.16.2.ebuild,v 1.2 2012/07/12 06:19:23 jlec Exp $
-EAPI="2"
+EAPI=4
inherit autotools eutils flag-o-matic
-DESCRIPTION="A package for computing Triangulations Of Point Configurations and Oriented Matroids."
-SRC_URI="http://www.uni-bayreuth.de/departments/wirtschaftsmathematik/rambau/Software/TOPCOM-$PV.tar.gz
- doc? ( http://www.rambau.wm.uni-bayreuth.de/TOPCOM/TOPCOM-manual.html )"
+DESCRIPTION="Computing Triangulations Of Point Configurations and Oriented Matroids"
HOMEPAGE="http://www.rambau.wm.uni-bayreuth.de/TOPCOM/"
+SRC_URI="
+ http://www.uni-bayreuth.de/departments/wirtschaftsmathematik/rambau/Software/TOPCOM-${PV}.tar.gz
+ doc? ( http://www.rambau.wm.uni-bayreuth.de/TOPCOM/TOPCOM-manual.html )"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
-DEPEND=">=dev-libs/gmp-4.1-r1
- >=sci-libs/cddlib-094f"
+DEPEND="
+ dev-libs/gmp
+ sci-libs/cddlib"
RDEPEND="${DEPEND}"
S="${WORKDIR}"/TOPCOM-${PV}
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
src_prepare () {
# Don't compile internal GMP and CDD ...
- epatch "${FILESDIR}"/${PN}-${PV}-no-internal-libs.patch
+ epatch "${FILESDIR}"/${P}-no-internal-libs.patch
# ... and link in tree versions:
append-libs -lgmp -lgmpxx -lcddgmp
@@ -33,15 +37,9 @@ src_prepare () {
}
src_install () {
- emake DESTDIR="${D}" install || die "Install failed"
- dodoc AUTHORS ChangeLog NEWS README || die
+ default
- if use doc; then
- dohtml "${DISTDIR}"/TOPCOM-manual.html || die
- fi
+ use doc && dohtml "${DISTDIR}"/TOPCOM-manual.html
- if use examples; then
- dodir /usr/share/doc/${PF}/examples
- cp -R "${S}"/examples/* "${D}"/usr/share/doc/${PF}/examples || die
- fi
+ use examples && dodoc -r "${S}"/examples
}
diff --git a/sci-mathematics/topcom/topcom-0.17.4.ebuild b/sci-mathematics/topcom/topcom-0.17.4.ebuild
new file mode 100644
index 000000000000..8ded61352495
--- /dev/null
+++ b/sci-mathematics/topcom/topcom-0.17.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/topcom/topcom-0.17.4.ebuild,v 1.1 2012/07/12 06:19:23 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="Computing Triangulations Of Point Configurations and Oriented Matroids"
+HOMEPAGE="http://www.rambau.wm.uni-bayreuth.de/TOPCOM/"
+SRC_URI="
+ http://www.uni-bayreuth.de/departments/wirtschaftsmathematik/rambau/Software/TOPCOM-${PV}.tar.gz
+ doc? ( http://www.rambau.wm.uni-bayreuth.de/TOPCOM/TOPCOM-manual.html )"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc examples static-libs"
+
+DEPEND="
+ >=dev-libs/gmp-5.0.5
+ >=sci-libs/cddlib-094f"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/TOPCOM-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-internal-libs.patch
+ "${FILESDIR}"/${P}-buildsystem.patch
+ )
+
+src_prepare () {
+ # ... and link in tree versions:
+ append-libs -lgmp -lgmpxx -lcddgmp
+
+ find external -delete || die
+
+ mv configure.{in,ac} || die
+
+ autotools-utils_src_prepare
+}
+
+src_install () {
+ autotools-utils_src_install
+
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*a
+
+ use doc && dohtml "${DISTDIR}"/TOPCOM-manual.html
+
+ use examples && dodoc -r "${S}"/examples
+}