summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-09-26 15:18:10 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-09-26 15:18:10 +0000
commit39c99660f0a090f98c0d3808a2607e8a929cfdca (patch)
tree96400b06a37fa15e3fb34002e190c0ae51ea1086 /sci-mathematics
parentVersion bump. (diff)
downloadgentoo-2-39c99660f0a090f98c0d3808a2607e8a929cfdca.tar.gz
gentoo-2-39c99660f0a090f98c0d3808a2607e8a929cfdca.tar.bz2
gentoo-2-39c99660f0a090f98c0d3808a2607e8a929cfdca.zip
Added X useflag since X is optional for building pari-2.3.0 (see bug 141231). Also fixed up the install process such that latex is only used and needed for USE='doc'
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/ChangeLog7
-rw-r--r--sci-mathematics/pari/pari-2.3.0.ebuild21
2 files changed, 23 insertions, 5 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index c5386eb673bd..cf0bf2465d68 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.39 2006/08/24 22:20:23 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.40 2006/09/26 15:18:10 markusle Exp $
+
+ 26 Sep 2006; Markus Dittrich <markusle@gentoo.org> pari-2.3.0.ebuild:
+ Added X useflag since X is optional for building pari-2.3.0
+ (see bug 141231). Also fixed up the install process such that
+ latex is only used and needed for USE="doc".
24 Aug 2006; Herbie Hopkins <herbs@gentoo.org> pari-2.3.0.ebuild:
Removing fPIC workaround as the cause of this was resolved, see bug #114722.
diff --git a/sci-mathematics/pari/pari-2.3.0.ebuild b/sci-mathematics/pari/pari-2.3.0.ebuild
index 231774275bd7..14739c48942a 100644
--- a/sci-mathematics/pari/pari-2.3.0.ebuild
+++ b/sci-mathematics/pari/pari-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.0.ebuild,v 1.3 2006/08/24 22:20:23 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.0.ebuild,v 1.4 2006/09/26 15:18:10 markusle Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -11,11 +11,20 @@ SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
-IUSE="doc emacs"
+IUSE="doc emacs X"
DEPEND="doc? ( virtual/tetex )
sys-libs/readline
- || ( x11-libs/libX11 virtual/x11 )"
+ X? ( || ( x11-libs/libX11 virtual/x11 ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # disable default building of docs during install
+ sed -e "s:install-doc install-examples:install-examples:" \
+ -i config/Makefile.SH || die "Failed to fix makefile"
+}
src_compile() {
# Special handling for sparc
@@ -67,7 +76,9 @@ src_test() {
}
src_install() {
- make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install || die
+ make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install || \
+ die "Install failed"
+
if use emacs; then
insinto /usr/share/emacs/site-lisp
doins emacs/pari.el
@@ -75,6 +86,8 @@ src_install() {
dodoc AUTHORS Announce.2.1 CHANGES README TODO
if use doc; then
+ make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install-doc \
+ || die "Failed to install docs"
insinto /usr/share/doc/${PF}
doins doc/*.pdf || die "Failed to install pdf docs"
fi