summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-10-24 15:48:32 +0000
committerThomas Kahle <tomka@gentoo.org>2010-10-24 15:48:32 +0000
commit41a49cf90bfb426797148cc1ec3c2606edf01054 (patch)
treeee603dd5809c817cc28423e22acef1183c3fee41 /sci-mathematics
parentppc64 stable wrt #341669 (diff)
downloadgentoo-2-41a49cf90bfb426797148cc1ec3c2606edf01054.tar.gz
gentoo-2-41a49cf90bfb426797148cc1ec3c2606edf01054.tar.bz2
gentoo-2-41a49cf90bfb426797148cc1ec3c2606edf01054.zip
New package: sci-mathematics/nauty
Migrated from science overlay, fixes bug 337810 (Portage version: 2.1.9.22/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/nauty/ChangeLog11
-rw-r--r--sci-mathematics/nauty/metadata.xml15
-rw-r--r--sci-mathematics/nauty/nauty-2.4.2.ebuild37
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-mathematics/nauty/ChangeLog b/sci-mathematics/nauty/ChangeLog
new file mode 100644
index 000000000000..c35a6d423076
--- /dev/null
+++ b/sci-mathematics/nauty/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/nauty
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nauty/ChangeLog,v 1.1 2010/10/24 15:48:32 tomka Exp $
+
+*nauty-2.4.2 (24 Oct 2010)
+
+ 24 Oct 2010; Thomas Kahle <tomka@gentoo.org> +nauty-2.4.2.ebuild,
+ +metadata.xml:
+ New ebuild: sci-mathematics/nauty-2.4.2,
+ migrated from science overlay, fixing bug 337810
+
diff --git a/sci-mathematics/nauty/metadata.xml b/sci-mathematics/nauty/metadata.xml
new file mode 100644
index 000000000000..0c5be24442aa
--- /dev/null
+++ b/sci-mathematics/nauty/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+</maintainer>
+<herd>sci-mathematics</herd>
+<longdescription lang="en">
+nauty is a program for computing automorphism groups of graphs and digraphs. It can also produce a
+canonical labelling.
+
+nauty is written in a portable subset of C, and runs on a considerable number of different systems.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/nauty/nauty-2.4.2.ebuild b/sci-mathematics/nauty/nauty-2.4.2.ebuild
new file mode 100644
index 000000000000..8d629af0b619
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nauty/nauty-2.4.2.ebuild,v 1.1 2010/10/24 15:48:32 tomka Exp $
+
+EAPI="2"
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 2 'r')
+MY_PV=$(delete_version_separator 1 ${MY_PV})
+
+DESCRIPTION="program for computing automorphism groups of graphs and digraphs."
+HOMEPAGE="http://cs.anu.edu.au/~bdm/nauty/"
+SRC_URI="http://cs.anu.edu.au/~bdm/${PN}/${PN}${MY_PV}.tar.gz"
+
+LICENSE="nauty"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}${MY_PV}"
+
+src_prepare () {
+ sed -i "s/LDFLAGS=/LDFLAGS=${LDFLAGS}/" makefile.in || die
+}
+
+src_test () {
+ make checks || die "tests failed"
+}
+
+src_install () {
+ dobin addedgeg amtog biplabg catg complg copyg countg \
+ deledgeg directg dreadnaut dretog genbg geng genrang \
+ gentourng labelg listg multig newedgeg NRswitchg pickg \
+ planarg shortg showg || die "install failed"
+ dodoc README formats.txt
+}