summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-20 19:42:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-20 19:42:06 +0000
commit41c46cc3b9d5d83df89b68c9277c5800ebaf41ab (patch)
treeb8f3ec904abc67a582e4617fb36cef1eac1bc983 /sci-mathematics
parentremove old (diff)
downloadgentoo-2-41c46cc3b9d5d83df89b68c9277c5800ebaf41ab.tar.gz
gentoo-2-41c46cc3b9d5d83df89b68c9277c5800ebaf41ab.tar.bz2
gentoo-2-41c46cc3b9d5d83df89b68c9277c5800ebaf41ab.zip
version bump, by Olivier Huber <oli.huber@gmail.com>, bug #350145
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog9
-rw-r--r--sci-mathematics/coq/coq-8.3_p1.ebuild81
2 files changed, 88 insertions, 2 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 0ecaa31058bc..dc3a81244728 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.58 2010/11/20 12:44:09 tomka Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.59 2011/01/20 19:42:06 aballier Exp $
+
+*coq-8.3_p1 (20 Jan 2011)
+
+ 20 Jan 2011; Alexis Ballier <aballier@gentoo.org> +coq-8.3_p1.ebuild:
+ version bump, by Olivier Huber <oli.huber@gmail.com>, bug #350145
20 Nov 2010; Thomas Kahle <tomka@gentoo.org> coq-8.3.ebuild,
+files/coq-8.3-camlp5-6-compat.patch, +files/coq-8.3-make-3.82-compat.patch:
diff --git a/sci-mathematics/coq/coq-8.3_p1.ebuild b/sci-mathematics/coq/coq-8.3_p1.ebuild
new file mode 100644
index 000000000000..1d1ce81f0fcd
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.3_p1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3_p1.ebuild,v 1.1 2011/01/20 19:42:06 aballier Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://${PN}.inria.fr/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ >=dev-ml/camlp5-5.09[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ || ( dev-texlive/texlive-pictures app-text/ptex )
+ || ( dev-texlive/texlive-mathextra app-text/ptex )
+ || ( dev-texlive/texlive-latexextra app-text/ptex )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # configure has an error at line 640 leading to closing a string
+ # to early in the generated coq_config.ml. Here is a wild sed :)
+ # It replaces \"$LABLGTKLIB\" by $LABLGTKLIB
+ sed -i "s/\\\\\"\\\$LABLGTKLIB\\\\\"/\\\$LABLGTKLIB/" configure
+}
+
+src_configure() {
+ ocaml_lib=`ocamlc -where`
+ local myconf="--prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --camlp5dir ${ocaml_lib}/camlp5
+ --lablgtkdir ${ocaml_lib}/lablgtk2"
+
+ use debug && myconf="--debug $myconf"
+ use doc || myconf="$myconf --with-doc no"
+
+ if use gtk; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+ use ocamlopt && myconf="$myconf --opt"
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 || die "make failed"
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ use gtk && domenu "${FILESDIR}/coqide.desktop"
+}