summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-19 12:54:20 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-19 12:54:20 +0000
commit4775cbc07c4ec529db02a1482a22553ec25ce0f9 (patch)
tree4244d272d65e590ba0180f1d04aae357d0284df3 /sci-mathematics
parentAdd PYTHON_USEDEP in deps (diff)
downloadgentoo-2-4775cbc07c4ec529db02a1482a22553ec25ce0f9.tar.gz
gentoo-2-4775cbc07c4ec529db02a1482a22553ec25ce0f9.tar.bz2
gentoo-2-4775cbc07c4ec529db02a1482a22553ec25ce0f9.zip
sci-mathematics/rkward: Version bump, #465682
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/rkward/ChangeLog7
-rw-r--r--sci-mathematics/rkward/rkward-0.6.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sci-mathematics/rkward/ChangeLog b/sci-mathematics/rkward/ChangeLog
index b03d996221b5..39d88fe6ed9a 100644
--- a/sci-mathematics/rkward/ChangeLog
+++ b/sci-mathematics/rkward/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/rkward
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/ChangeLog,v 1.37 2013/04/12 06:48:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/ChangeLog,v 1.38 2013/04/19 12:54:20 jlec Exp $
+
+*rkward-0.6.1 (19 Apr 2013)
+
+ 19 Apr 2013; Justin Lecher <jlec@gentoo.org> +rkward-0.6.1.ebuild:
+ Version bump, #465682
12 Apr 2013; Justin Lecher <jlec@gentoo.org> -rkward-0.5.4.ebuild,
metadata.xml:
diff --git a/sci-mathematics/rkward/rkward-0.6.1.ebuild b/sci-mathematics/rkward/rkward-0.6.1.ebuild
new file mode 100644
index 000000000000..4dce6d18dad8
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/rkward-0.6.1.ebuild,v 1.1 2013/04/19 12:54:20 jlec Exp $
+
+EAPI=5
+
+KDE_DOC_DIRS="doc"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="ca cs da de el es fr it lt pl tr zh_CN"
+
+inherit kde4-base
+
+DESCRIPTION="IDE for the R-project"
+HOMEPAGE="http://rkward.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rkward/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ dev-lang/R
+ $(add_kdebase_dep katepart)"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # to have it compatible with R which had a bad R_HOME
+ unset R_HOME
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ # avoid file collision with kate
+ rm "${ED}"/usr/share/apps/katepart/syntax/r.xml || die
+}