summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-02-08 23:59:47 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-02-08 23:59:47 +0000
commit7ee1652b2dd2c43db124efc9dac59305a13c65f0 (patch)
tree9f09de2ea441499982858e66b1de762eeee7865d /sci-mathematics
parentSparc stable, Bug #207231. (diff)
downloadgentoo-2-7ee1652b2dd2c43db124efc9dac59305a13c65f0.tar.gz
gentoo-2-7ee1652b2dd2c43db124efc9dac59305a13c65f0.tar.bz2
gentoo-2-7ee1652b2dd2c43db124efc9dac59305a13c65f0.zip
Fixed broken autotool detection of java (see bug #209245).
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/scilab/ChangeLog6
-rw-r--r--sci-mathematics/scilab/files/scilab-4.1.2-java-config.patch12
-rw-r--r--sci-mathematics/scilab/scilab-4.1.2.ebuild4
3 files changed, 20 insertions, 2 deletions
diff --git a/sci-mathematics/scilab/ChangeLog b/sci-mathematics/scilab/ChangeLog
index d5aa35764179..5257f5a399c1 100644
--- a/sci-mathematics/scilab/ChangeLog
+++ b/sci-mathematics/scilab/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/scilab
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.42 2008/02/06 17:02:20 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.43 2008/02/08 23:59:46 markusle Exp $
+
+ 08 Feb 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/scilab-4.1.2-java-config.patch, scilab-4.1.2.ebuild:
+ Fixed broken autotool detection of java (see bug #209245).
06 Feb 2008; Markus Dittrich <markusle@gentoo.org> scilab-4.1.2.ebuild:
Added missing tools needed to build code inside scilab
diff --git a/sci-mathematics/scilab/files/scilab-4.1.2-java-config.patch b/sci-mathematics/scilab/files/scilab-4.1.2-java-config.patch
new file mode 100644
index 000000000000..d0cf9cf7dc7e
--- /dev/null
+++ b/sci-mathematics/scilab/files/scilab-4.1.2-java-config.patch
@@ -0,0 +1,12 @@
+diff -Naur scilab-4.1.2/m4/java.m4 scilab-4.1.2.new/m4/java.m4
+--- scilab-4.1.2/m4/java.m4 2006-10-24 09:22:25.000000000 -0500
++++ scilab-4.1.2.new/m4/java.m4 2008-02-08 17:54:12.000000000 -0500
+@@ -17,7 +17,7 @@
+
+ AC_MSG_CHECKING([for java headers])
+
+- _JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[[^/]]*$::'`
++ _JTOPDIR=$JAVA_HOME
+ case "$host_os" in
+ darwin*)
+ _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[[^/]]*$::'`
diff --git a/sci-mathematics/scilab/scilab-4.1.2.ebuild b/sci-mathematics/scilab/scilab-4.1.2.ebuild
index d7b7b98d9266..a0830cea3b83 100644
--- a/sci-mathematics/scilab/scilab-4.1.2.ebuild
+++ b/sci-mathematics/scilab/scilab-4.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.2.ebuild,v 1.2 2008/02/06 17:02:20 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.2.ebuild,v 1.3 2008/02/08 23:59:46 markusle Exp $
inherit eutils fortran toolchain-funcs multilib autotools java-pkg-opt-2
@@ -47,6 +47,8 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-4.1-java-pic.patch
epatch "${FILESDIR}"/${P}-header-fix.patch
epatch "${FILESDIR}"/${PN}-4.1-examples.patch
+ epatch "${FILESDIR}"/${P}-java-config.patch
+ eautoconf
sed -e '/^ATLAS_LAPACKBLAS\>/s,=.*,= $(ATLASDIR)/liblapack.so $(ATLASDIR)/libblas.so $(ATLASDIR)/libcblas.so,' \
-e 's,$(SCIDIR)/libs/lapack.a,,' \