summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-07-10 15:00:26 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-07-10 15:00:26 +0000
commitc38d62a7bd6e671a295ecd14536d1baad5a3be7e (patch)
tree6a02e54f2ef16461f8496cec85004456ae42a55e /sci-mathematics
parentneeds joystick for libsdl (diff)
downloadgentoo-2-c38d62a7bd6e671a295ecd14536d1baad5a3be7e.tar.gz
gentoo-2-c38d62a7bd6e671a295ecd14536d1baad5a3be7e.tar.bz2
gentoo-2-c38d62a7bd6e671a295ecd14536d1baad5a3be7e.zip
Fix build with GCC 4.5 wrt bug 322211. Thanks to Diego for reporting. Apply fedora patch to fix random SIGSEGV
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/drgeo/ChangeLog9
-rw-r--r--sci-mathematics/drgeo/drgeo-1.1.0.ebuild8
-rw-r--r--sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch61
3 files changed, 74 insertions, 4 deletions
diff --git a/sci-mathematics/drgeo/ChangeLog b/sci-mathematics/drgeo/ChangeLog
index 2be0dc3e57dd..642e1a67c924 100644
--- a/sci-mathematics/drgeo/ChangeLog
+++ b/sci-mathematics/drgeo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/drgeo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/ChangeLog,v 1.18 2009/09/20 12:52:43 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/ChangeLog,v 1.19 2010/07/10 15:00:26 xarthisius Exp $
+
+ 10 Jul 2010; Kacper Kowalik <xarthisius@gentoo.org> drgeo-1.1.0.ebuild,
+ +files/drgeo-1.1.0-gcc45.patch:
+ Fix build with GCC 4.5 wrt bug 322211. Thanks to Diego for reporting.
+ Apply fedora patch to fix random SIGSEGV
20 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> drgeo-1.1.0.ebuild:
Migrate to EAPI 2 in order to nuke built_with_use.
diff --git a/sci-mathematics/drgeo/drgeo-1.1.0.ebuild b/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
index e2aa560c273f..3e9e30b532b8 100644
--- a/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
+++ b/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/drgeo-1.1.0.ebuild,v 1.6 2009/09/20 12:52:43 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/drgeo-1.1.0.ebuild,v 1.7 2010/07/10 15:00:26 xarthisius Exp $
EAPI="2"
@@ -31,6 +31,10 @@ RDEPEND=">=x11-libs/gtk+-2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
src_configure() {
default
# Can't make the documentation as it depends on Hyperlatex which isn't
diff --git a/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch b/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
new file mode 100644
index 000000000000..1d8e93e06fea
--- /dev/null
+++ b/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
@@ -0,0 +1,61 @@
+Fix build with GCC 4.5, fix random SIGSEGV
+
+http://bugs.gentoo.org/show_bug.cgi?id=322211
+https://bugzilla.redhat.com/show_bug.cgi?id=454045
+
+--- geo/drgeo_figure.h
++++ geo/drgeo_figure.h
+@@ -322,4 +322,11 @@
+ gboolean showGrid;
+ };
+
++struct
++{
++ drgeoPoint mouse;
++ drgeoFigure *figure;
++}
++drgeoDialogData;
++
+ #endif
+--- geo/drgeo_figure.cc
++++ geo/drgeo_figure.cc
+@@ -48,13 +48,6 @@
+ #include "drgeo_dialog.h"
+ #include "traite.h"
+
+-extern struct
+-{
+- drgeoPoint mouse;
+- drgeoFigure *figure;
+-}
+-drgeoDialogData;
+-
+ typedef struct drgeoSearchValue
+ {
+ gpointer value;
+@@ -1309,7 +1302,7 @@
+ gint
+ drgeoFigure::preferedUndoLevel ()
+ {
+- atoi (drgeoConfigGet (":undoLevel"));
++ return atoi (drgeoConfigGet (":undoLevel"));
+ }
+
+ void
+--- geo/drgeo_dialog.cc
++++ geo/drgeo_dialog.cc
+@@ -38,14 +38,6 @@
+ // Used in the style dialod callback, I know it's ugly, but so easy
+ static drgeoFigure *selected_figure;
+
+-struct
+-{
+- drgeoPoint mouse;
+- drgeoFigure *figure;
+-}
+-drgeoDialogData;
+-
+-
+ static void drgeo_edit_dialog_cb (GtkWidget * dialog,
+ gint button, gpointer entry);
+