summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-05-30 13:25:07 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-05-30 13:25:07 +0000
commitd6825d08210091670b5ae859d83451b5342e3089 (patch)
tree523570f06c378093dea36c6f032db0a31f6078cd /sci-mathematics
parentalpha stable wrt #175560 (diff)
downloadgentoo-2-d6825d08210091670b5ae859d83451b5342e3089.tar.gz
gentoo-2-d6825d08210091670b5ae859d83451b5342e3089.tar.bz2
gentoo-2-d6825d08210091670b5ae859d83451b5342e3089.zip
This revision includes a cleaned up ebuild which now properly builds on amd64 (see bug #179700).
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog9
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-0.9.95-r2.ebuild93
-rw-r--r--sci-mathematics/Macaulay2/files/digest-Macaulay2-0.9.95-r29
3 files changed, 110 insertions, 1 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index bc9378dee455..6f6e1bd36545 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/Macaulay2
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/Macaulay2/ChangeLog,v 1.13 2007/05/25 17:33:43 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/Macaulay2/ChangeLog,v 1.14 2007/05/30 13:25:07 markusle Exp $
+
+*Macaulay2-0.9.95-r2 (30 May 2007)
+
+ 30 May 2007; Markus Dittrich <markusle@gentoo.org>
+ +Macaulay2-0.9.95-r2.ebuild:
+ This revision includes a cleaned up ebuild which now properly
+ builds on amd64 (see bug #179700).
25 May 2007; Markus Dittrich <markusle@gentoo.org>
Macaulay2-0.9.95-r1.ebuild:
diff --git a/sci-mathematics/Macaulay2/Macaulay2-0.9.95-r2.ebuild b/sci-mathematics/Macaulay2/Macaulay2-0.9.95-r2.ebuild
new file mode 100644
index 000000000000..d63768cea7b8
--- /dev/null
+++ b/sci-mathematics/Macaulay2/Macaulay2-0.9.95-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/Macaulay2/Macaulay2-0.9.95-r2.ebuild,v 1.1 2007/05/30 13:25:07 markusle Exp $
+
+inherit elisp-common eutils flag-o-matic toolchain-funcs autotools
+
+IUSE="emacs"
+
+DESCRIPTION="research tool for commutative algebra and algebraic geometry"
+SRC_URI="http://www.math.uiuc.edu/Macaulay2/Downloads/${P}-src.tar.gz
+ ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Factory/factory-3-0-2.tar.gz \
+ ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Libfac/libfac-3-0-2.tar.gz"
+
+HOMEPAGE="http://www.math.uiuc.edu/Macaulay2/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/gdbm
+ dev-libs/gmp
+ dev-libs/ntl
+ dev-libs/boehm-gc
+ virtual/blas
+ virtual/lapack
+ dev-util/ctags
+ sys-libs/ncurses
+ emacs? ( virtual/emacs )"
+
+SITEFILE=70Macaulay2-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-etags-gentoo.patch
+ epatch "${FILESDIR}"/${P}-cpp-fix.patch
+ epatch "${FILESDIR}"/${P}-test-fix.patch
+}
+
+src_compile() {
+ cd "${WORKDIR}/factory"
+ econf --enable-NTL --prefix="${WORKDIR}" || \
+ die "failed to configure factory"
+ emake || die "failed to build factory"
+ make install || die "failed to install factory"
+
+ cd "${WORKDIR}/libfac"
+ CPPFLAGS="-I${WORKDIR}/include" econf --with-NOSTREAMIO \
+ --prefix="${WORKDIR}" || die "failed to configure libfac"
+ emake DEFS=-DHAVE_SINGULAR_ERROR || die "failed to build libfac"
+ make install || die "failed to install libfac"
+
+ CXXFLAGS="${CXXFLAGS} -Wno-deprecated"
+ cd "${S}"
+ sed -e "/^docm2RelDir/s:Macaulay2:${P}:" \
+ -i include/config.Makefile.in || \
+ die "failed to fix makefile"
+ emake -j1 && CPPFLAGS="-I/usr/include/gc -I${WORKDIR}/include" \
+ LDFLAGS="-L${WORKDIR}/$(get_libdir)" \
+ ./configure --prefix="${D}/usr" --disable-encap \
+ --with-lapacklibs="-llapack -lblas" || \
+ die "failed to configure Macaulay"
+ # fix install paths
+ emake -j1 || die "failed to build Macaulay"
+}
+
+src_test() {
+ cd "${S}"
+ make check || die "tests failed"
+}
+
+src_install () {
+ cd "${S}"
+ make install || die "install failed"
+
+ # nothing in here, get rid of it
+ rm -fr "${D}"/usr/$(get_libdir) || \
+ die "failed to remove empty /usr/lib"
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "If you want to set a hot key for Macaulay2 in Emacs add a line similar to"
+ elog "(global-set-key [ f12 ] 'M2)"
+ elog "in order to set it to F12 (or choose a different one."
+ fi
+}
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/Macaulay2/files/digest-Macaulay2-0.9.95-r2 b/sci-mathematics/Macaulay2/files/digest-Macaulay2-0.9.95-r2
new file mode 100644
index 000000000000..0a31d1cb256d
--- /dev/null
+++ b/sci-mathematics/Macaulay2/files/digest-Macaulay2-0.9.95-r2
@@ -0,0 +1,9 @@
+MD5 83a7a7fbfa0bc016cc2525cc0f221694 Macaulay2-0.9.95-src.tar.gz 2875836
+RMD160 f3c5ad889e89d238ca3ede40e692bc42744861a8 Macaulay2-0.9.95-src.tar.gz 2875836
+SHA256 3fd4698d82de76a8356d24dfdba2775794231b5723ee3fda232ce2f0d1e6360a Macaulay2-0.9.95-src.tar.gz 2875836
+MD5 9b1fac924bc754339989d617946ea8c4 factory-3-0-2.tar.gz 503712
+RMD160 3cfaa7e438af75fb1c00501099c0d6c88fbfdd8b factory-3-0-2.tar.gz 503712
+SHA256 463a29232f9e187014bd53bb726cf1628f929ee830fa63d445dcc9a45403d8ed factory-3-0-2.tar.gz 503712
+MD5 d94415a24186bfd4bdb6df491a58d173 libfac-3-0-2.tar.gz 87369
+RMD160 847103ae3fcc870188630028965086c3933a2009 libfac-3-0-2.tar.gz 87369
+SHA256 3fae688d7471e137834e9f89e5677e2ded4d578942b54ce7efa536817799fa74 libfac-3-0-2.tar.gz 87369