summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-07-12 21:33:37 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-07-12 21:33:37 +0000
commitda73a7661a6321539da80b8bf7d2d954cdba65b7 (patch)
tree4416aba9839ac28e43498216fb39c036a3ddd5f2 /sci-mathematics
parentarm stable, bug #373877 (diff)
downloadgentoo-2-da73a7661a6321539da80b8bf7d2d954cdba65b7.tar.gz
gentoo-2-da73a7661a6321539da80b8bf7d2d954cdba65b7.tar.bz2
gentoo-2-da73a7661a6321539da80b8bf7d2d954cdba65b7.zip
Version bump. Thanks to Fabio Rossi for reporting (bug #374891)
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/qtoctave/ChangeLog10
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.10.1.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/sci-mathematics/qtoctave/ChangeLog b/sci-mathematics/qtoctave/ChangeLog
index cfe00f345de9..ddd23f18ab50 100644
--- a/sci-mathematics/qtoctave/ChangeLog
+++ b/sci-mathematics/qtoctave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/qtoctave
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.15 2010/11/13 12:22:56 tomka Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.16 2011/07/12 21:33:37 rafaelmartins Exp $
+
+*qtoctave-0.10.1 (12 Jul 2011)
+
+ 12 Jul 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +qtoctave-0.10.1.ebuild:
+ Version bump. Thanks to Fabio Rossi for reporting (bug #374891)
13 Nov 2010; Thomas Kahle <tomka@gentoo.org> qtoctave-0.9.1-r1.ebuild:
x86 stable per bug #344511
diff --git a/sci-mathematics/qtoctave/qtoctave-0.10.1.ebuild b/sci-mathematics/qtoctave/qtoctave-0.10.1.ebuild
new file mode 100644
index 000000000000..00cacc53965f
--- /dev/null
+++ b/sci-mathematics/qtoctave/qtoctave-0.10.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.10.1.ebuild,v 1.1 2011/07/12 21:33:37 rafaelmartins Exp $
+
+EAPI="2"
+
+CMAKE_IN_SOURCE_BUILD=1
+inherit eutils cmake-utils
+
+PID=2054
+
+DESCRIPTION="QtOctave is a Qt4 front-end for Octave"
+HOMEPAGE="http://forja.rediris.es/projects/csl-qtoctave/"
+SRC_URI="http://forja.rediris.es/frs/download.php/${PID}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-gui-4.6
+ >=x11-libs/qt-svg-4.6"
+
+RDEPEND="${DEPEND}
+ >=sci-mathematics/octave-3.2.0"
+
+DOCS="readme.txt leeme.txt"
+
+src_prepare() {
+ sed -i -e 's/Categories=/Categories=Development;/' \
+ qtoctave/src/config_files/qtoctave.desktop || die 'sed failed.'
+}
+
+src_configure() {
+ mycmakeargs=(-DCMAKE_SKIP_RPATH:BOOL=YES )
+ cmake-utils_src_configure
+}