summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-12-05 10:35:35 +0000
committerMark Wright <gienah@gentoo.org>2012-12-05 10:35:35 +0000
commite7693e8109159e0fb1cdabde3b9a771c2b1c4700 (patch)
treed7dbf1ddcfc8bc96aa92222665199cd4dcc5f2aa /sci-mathematics
parentVersion bump, remove old. (diff)
downloadgentoo-2-e7693e8109159e0fb1cdabde3b9a771c2b1c4700.tar.gz
gentoo-2-e7693e8109159e0fb1cdabde3b9a771c2b1c4700.tar.bz2
gentoo-2-e7693e8109159e0fb1cdabde3b9a771c2b1c4700.zip
EAPI=5 with subslot depends to automatically rebuild spass when isabelle is updated if the isabelle use flag is enabled.
(Portage version: 2.1.11.33/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/spass/ChangeLog6
-rw-r--r--sci-mathematics/spass/spass-3.7.ebuild16
2 files changed, 13 insertions, 9 deletions
diff --git a/sci-mathematics/spass/ChangeLog b/sci-mathematics/spass/ChangeLog
index d5450c934180..15eb26a8abb7 100644
--- a/sci-mathematics/spass/ChangeLog
+++ b/sci-mathematics/spass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/spass
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/ChangeLog,v 1.5 2012/10/22 10:20:57 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/ChangeLog,v 1.6 2012/12/05 10:35:35 gienah Exp $
+
+ 05 Dec 2012; Mark Wright <gienah@gentoo.org> spass-3.7.ebuild:
+ EAPI=5 with subslot depends to automatically rebuild spass when isabelle is
+ updated if the isabelle use flag is enabled.
22 Oct 2012; Mark Wright <gienah@gentoo.org> spass-3.7.ebuild:
Thanks to Imre Vadasz for reporting bug #439178 and providing the fix, -z
diff --git a/sci-mathematics/spass/spass-3.7.ebuild b/sci-mathematics/spass/spass-3.7.ebuild
index 6746c6ba02cf..98a264b7bec2 100644
--- a/sci-mathematics/spass/spass-3.7.ebuild
+++ b/sci-mathematics/spass/spass-3.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/spass-3.7.ebuild,v 1.4 2012/10/22 10:20:57 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/spass-3.7.ebuild,v 1.5 2012/12/05 10:35:35 gienah Exp $
-EAPI=4
+EAPI=5
inherit versionator
@@ -14,13 +14,14 @@ HOMEPAGE="http://www.spass-prover.org/"
SRC_URI="http://www.spass-prover.org/download/sources/${MY_P}.tgz"
LICENSE="BSD-2"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples isabelle"
-RDEPEND=""
-DEPEND="${RDEPEND}
- isabelle? ( >=sci-mathematics/isabelle-2011.1-r1 )"
+RDEPEND="isabelle? (
+ >=sci-mathematics/isabelle-2011.1-r1:=
+ )"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/SPASS-${PV}"
@@ -41,7 +42,6 @@ src_install() {
if use isabelle; then
ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)"
[[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
-
dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
cat <<- EOF >> "${S}/settings"
SPASS_HOME="${ROOT}usr/bin"
@@ -72,7 +72,7 @@ pkg_postrm() {
if [ -f "${ROOT}etc/isabelle/components" ]; then
# Note: this sed should only match the version of this ebuild
# Which is what we want as we do not want to remove the line
- # of a new E being installed during an upgrade.
+ # of a new spass being installed during an upgrade.
sed -e "/contrib\/${PN}-${PV}/d" \
-i "${ROOT}etc/isabelle/components"
fi