summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-04-18 17:57:38 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-04-18 17:57:38 +0000
commit463c79173924dfb83bedb1cca9fa1e19235cc2e7 (patch)
tree8a74f301b563cbc9bc9a409acc806eca270633d3 /sci-misc/boinc
parentupdate to the most recent, 2.0.12. remove non-2.0.x versions, as only 2.0.x i... (diff)
downloadgentoo-2-463c79173924dfb83bedb1cca9fa1e19235cc2e7.tar.gz
gentoo-2-463c79173924dfb83bedb1cca9fa1e19235cc2e7.tar.bz2
gentoo-2-463c79173924dfb83bedb1cca9fa1e19235cc2e7.zip
Fixed compilation problems with USE=-X (see bug #218168).
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/ChangeLog5
-rw-r--r--sci-misc/boinc/boinc-5.10.45.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 575849069d22..9212698cc5d0 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.39 2008/04/17 19:04:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.40 2008/04/18 17:57:38 markusle Exp $
+
+ 18 Apr 2008; Markus Dittrich <markusle@gentoo.org> boinc-5.10.45.ebuild:
+ Fixed compilation problems with USE="-X" (see bug #218168).
17 Apr 2008; Markus Dittrich <markusle@gentoo.org>
+files/boinc-5.10.45-gcc4.3.patch, boinc-4.72.20050813-r3.ebuild,
diff --git a/sci-misc/boinc/boinc-5.10.45.ebuild b/sci-misc/boinc/boinc-5.10.45.ebuild
index 676c266970d4..98532635e4eb 100644
--- a/sci-misc/boinc/boinc-5.10.45.ebuild
+++ b/sci-misc/boinc/boinc-5.10.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.10.45.ebuild,v 1.2 2008/04/17 19:04:16 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.10.45.ebuild,v 1.3 2008/04/18 17:57:38 markusle Exp $
inherit flag-o-matic wxwidgets depend.apache
@@ -48,6 +48,7 @@ src_compile() {
#upstream recommendation for flags
append-flags -O3 -funroll-loops -fforce-addr -ffast-math
+ local wxconf=""
if use X; then
WX_GTK_VER=2.8
if use unicode; then
@@ -55,7 +56,9 @@ src_compile() {
else
need-wxwidgets gtk2
fi
- wxconf="--with-wx-config=${WX_CONFIG}"
+ wxconf="${wxconf} --with-wx-config=${WX_CONFIG}"
+ else
+ wxconf="${wxconf} --without-wxdir"
fi
# Just run the necessary tools directly