summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-08-07 12:55:32 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-08-07 12:55:32 +0000
commitc595430f9f93ac33e79cffe238c0713793fe315d (patch)
treec4bc72aa136a4c30271655b0b07d4d4bdcbf9114 /sci-misc/boinc
parentVersion bump, adding support for freenode mute lists (+q). (diff)
downloadgentoo-2-c595430f9f93ac33e79cffe238c0713793fe315d.tar.gz
gentoo-2-c595430f9f93ac33e79cffe238c0713793fe315d.tar.bz2
gentoo-2-c595430f9f93ac33e79cffe238c0713793fe315d.zip
Version bump. Fix bug #328999, #327695 and hopefully #320747.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/ChangeLog9
-rw-r--r--sci-misc/boinc/boinc-6.10.58-r1.ebuild (renamed from sci-misc/boinc/boinc-6.10.58.ebuild)26
-rw-r--r--sci-misc/boinc/files/6.4.5-glibc210.patch13
-rw-r--r--sci-misc/boinc/files/boinc.init4
4 files changed, 26 insertions, 26 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 30bbc8e46371..cc5620a27fed 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.91 2010/07/19 20:34:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.92 2010/08/07 12:55:31 scarabeus Exp $
+
+*boinc-6.10.58-r1 (07 Aug 2010)
+
+ 07 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/6.4.5-glibc210.patch, -boinc-6.10.58.ebuild,
+ +boinc-6.10.58-r1.ebuild, files/boinc.init:
+ Version bump. Fix bug #328999, #327695 and hopefully #320747.
19 Jul 2010; Tomáš Chvátal <scarabeus@gentoo.org> files/boinc.init:
Whitespace.
diff --git a/sci-misc/boinc/boinc-6.10.58.ebuild b/sci-misc/boinc/boinc-6.10.58-r1.ebuild
index 5faf7451aaca..8d4422468208 100644
--- a/sci-misc/boinc/boinc-6.10.58.ebuild
+++ b/sci-misc/boinc/boinc-6.10.58-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.10.58.ebuild,v 1.1 2010/07/09 16:49:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.10.58-r1.ebuild,v 1.1 2010/08/07 12:55:31 scarabeus Exp $
EAPI="2"
-inherit flag-o-matic depend.apache eutils wxwidgets autotools base
+inherit flag-o-matic depend.apache eutils wxwidgets autotools autotools-utils
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="http://boinc.ssl.berkeley.edu/"
@@ -42,6 +42,8 @@ PATCHES=(
"${FILESDIR}"/6.4.5-glibc210.patch
)
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
src_prepare() {
# use system ssl certificates
mkdir "${S}"/curl
@@ -50,7 +52,7 @@ src_prepare() {
# prevent bad changes in compile flags, bug 286701
sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
- base_src_prepare
+ autotools-utils_src_prepare
eautoreconf
}
@@ -76,17 +78,21 @@ src_configure() {
use client || conf+=" --disable-client"
# configure
- econf \
- --disable-dependency-tracking \
- --enable-unicode \
- --with-ssl \
- $(use_with X x) \
- ${wxconf} \
+ myeconfargs=(
+ --disable-dependency-tracking
+ --disable-static
+ --enable-unicode
+ --with-ssl
+ $(use_with X x)
+ ${wxconf}
${conf}
+ )
+ autotools-utils_src_configure
}
src_install() {
- base_src_install
+ autotools-utils_src_install
+ remove_libtool_files all
dodir /var/lib/${PN}/
keepdir /var/lib/${PN}/
diff --git a/sci-misc/boinc/files/6.4.5-glibc210.patch b/sci-misc/boinc/files/6.4.5-glibc210.patch
deleted file mode 100644
index c1f11f653fc9..000000000000
--- a/sci-misc/boinc/files/6.4.5-glibc210.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: lib/str_util.h
-===================================================================
---- lib/str_util.h (revision 18304)
-+++ lib/str_util.h (working copy)
-@@ -18,6 +18,8 @@
- #ifndef STR_UTIL_H
- #define STR_UTIL_H
-
-+#include "config.h"
-+
- #include <cstdlib>
- #include <ctime>
- #include <cctype>
diff --git a/sci-misc/boinc/files/boinc.init b/sci-misc/boinc/files/boinc.init
index c1dfb909a89c..975ee83d68a9 100644
--- a/sci-misc/boinc/files/boinc.init
+++ b/sci-misc/boinc/files/boinc.init
@@ -72,10 +72,10 @@ start() {
if [ "${SCHED_PARAM}" = "" ]; then
CHRT=""
else
- CHRT="/usr/bin/chrt ${SCHED_PARAM}"
+ CHRT="eval /usr/bin/chrt ${SCHED_PARAM}"
fi
- eval ${CHRT} start-stop-daemon \
+ ${CHRT} start-stop-daemon \
--start --quiet --chdir "${RUNTIMEDIR}" \
--make-pidfile \
--pidfile "${PIDFILE}" \