summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-11 19:10:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-11 19:10:20 +0000
commitc744c675a0449b498e0920bec9af585ddfc18997 (patch)
treea022acc1369f60505d3cebfcc406447d542f09b0 /sci-physics/bullet
parentRemoving gkrellm-bfm after p.mask period is up. Bug #207720 (diff)
downloadgentoo-2-c744c675a0449b498e0920bec9af585ddfc18997.tar.gz
gentoo-2-c744c675a0449b498e0920bec9af585ddfc18997.tar.bz2
gentoo-2-c744c675a0449b498e0920bec9af585ddfc18997.zip
Initial import. Thanks Renato Caldas <seventhguardian@gmail.com> for his initial work. Closing bug #166192
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics/bullet')
-rw-r--r--sci-physics/bullet/ChangeLog11
-rw-r--r--sci-physics/bullet/Manifest4
-rw-r--r--sci-physics/bullet/bullet-2.67.ebuild47
-rw-r--r--sci-physics/bullet/metadata.xml10
4 files changed, 72 insertions, 0 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
new file mode 100644
index 000000000000..82b1ca90d5f5
--- /dev/null
+++ b/sci-physics/bullet/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-physics/bullet
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.1 2008/03/11 19:10:20 bicatali Exp $
+
+*bullet-2.67 (11 Mar 2008)
+
+ 11 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +bullet-2.67.ebuild:
+ Initial import. Thanks Renato Caldas <seventhguardian@gmail.com> for his
+ initial work. Closing bug #166192
+
diff --git a/sci-physics/bullet/Manifest b/sci-physics/bullet/Manifest
new file mode 100644
index 000000000000..3431c1d89253
--- /dev/null
+++ b/sci-physics/bullet/Manifest
@@ -0,0 +1,4 @@
+DIST bullet-2.67.tgz 5918156 RMD160 7d56de4dfee6269686628c1394e0bc297bf693a0 SHA1 7a091558263c056f70fa308b11c05c3926e9e505 SHA256 217a90389f70a651c48eaa5c0c3b1d08086448772438fed44612d847b13a6d03
+EBUILD bullet-2.67.ebuild 1020 RMD160 fd44cb9591ae9b7e3d474f26acfff2cd800c55be SHA1 4feab5c049540f68bb802cddd3dcd6295008399f SHA256 baa048506d281b44ada48f4042386e82da9c9277d336d10c6acd40e9b46f31b2
+MISC ChangeLog 352 RMD160 54581d43d6af1b62251f194ce6935f8926bd8be8 SHA1 7684eaceae3fdb7b8a386a982f7d7bf1543b38d8 SHA256 3475d078a68050e46a4a7e67e1b2b2636a490726babde1e873a73f582245baaa
+MISC metadata.xml 350 RMD160 58e5a06b4029ee0ee2f2de5b1008fbb233beae23 SHA1 7a5d337c1364ca38a28378b7df86ac801b354ca7 SHA256 c2651cf06a3d9498dfb05e05b7899292a7a7fd0a45fd28e4f8eaa7bd2b88b726
diff --git a/sci-physics/bullet/bullet-2.67.ebuild b/sci-physics/bullet/bullet-2.67.ebuild
new file mode 100644
index 000000000000..a197496dccbb
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.67.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.67.ebuild,v 1.1 2008/03/11 19:10:20 bicatali Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.continuousphysics.com/Bullet/"
+SRC_URI="http://bullet.googlecode.com/files/${P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc examples"
+
+RDEPEND="examples? ( virtual/opengl virtual/glut )"
+DEPEND="${DEPEND}
+ || ( dev-util/jam dev-util/ftjam )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:-O3 -fomit-frame-pointer -ffast-math::' \
+ Jamrules || die "sed Jamrules failed"
+}
+
+src_compile() {
+ econf \
+ $(use_with examples x) \
+ $(use_with examples mesa) \
+ || die "econf failed"
+ jam -qa || die "jam failed"
+}
+
+src_test() {
+ jam check || die "jam check failed"
+}
+
+src_install() {
+ jam -sDESTDIR="${D}" install || die "jam install failed"
+ dodoc README ChangeLog.txt AUTHORS || die
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die
+ fi
+}
diff --git a/sci-physics/bullet/metadata.xml b/sci-physics/bullet/metadata.xml
new file mode 100644
index 000000000000..fff1dddb8ce3
--- /dev/null
+++ b/sci-physics/bullet/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ Bullet is a professional open source multi-threaded
+ 3D Collision Detection and Rigid Body Dynamics Library
+ for games and animation.
+</longdescription>
+</pkgmetadata>