summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-14 08:12:45 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-14 08:12:45 +0000
commit29d14ec4599642b8fbf414c19a9b3163619f39ce (patch)
treea12dceae5c5af94a1f698ec36e7b70f4ebc99739 /sci-physics/hepmc/hepmc-2.06.03.ebuild
parentImport from sunrise, I will proxy flow in this case. (diff)
downloadgentoo-2-29d14ec4599642b8fbf414c19a9b3163619f39ce.tar.gz
gentoo-2-29d14ec4599642b8fbf414c19a9b3163619f39ce.tar.bz2
gentoo-2-29d14ec4599642b8fbf414c19a9b3163619f39ce.zip
Fix for compilation with gcc-4.6, #363539
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/hepmc/hepmc-2.06.03.ebuild')
-rw-r--r--sci-physics/hepmc/hepmc-2.06.03.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-physics/hepmc/hepmc-2.06.03.ebuild b/sci-physics/hepmc/hepmc-2.06.03.ebuild
index cab77f156926..c00e70239c98 100644
--- a/sci-physics/hepmc/hepmc-2.06.03.ebuild
+++ b/sci-physics/hepmc/hepmc-2.06.03.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.03.ebuild,v 1.6 2011/02/18 17:10:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.03.ebuild,v 1.7 2011/04/14 08:12:45 jlec Exp $
EAPI=2
+inherit eutils
+
MYP=HepMC-${PV}
DESCRIPTION="Event Record for Monte Carlo Generators"
@@ -21,6 +23,9 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.06.04-gcc46.patch
+}
src_configure() {
# use MeV over GeV and mm over cm
local length_conf="MM"