summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 09:28:05 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 09:28:05 +0000
commitd2ea914365cb86204fac65cf2ceb25541698e858 (patch)
treed6aec302c9dfa268d027d5723340f25b9a665ff9 /sci-physics/pythia
parentRemove unnecessary dep on virtual/fortran (diff)
downloadgentoo-2-d2ea914365cb86204fac65cf2ceb25541698e858.tar.gz
gentoo-2-d2ea914365cb86204fac65cf2ceb25541698e858.tar.bz2
gentoo-2-d2ea914365cb86204fac65cf2ceb25541698e858.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/pythia')
-rw-r--r--sci-physics/pythia/ChangeLog6
-rw-r--r--sci-physics/pythia/pythia-6.4.24.ebuild9
-rw-r--r--sci-physics/pythia/pythia-6.4.25.ebuild9
-rw-r--r--sci-physics/pythia/pythia-8.1.45.ebuild4
-rw-r--r--sci-physics/pythia/pythia-8.1.50.ebuild4
5 files changed, 17 insertions, 15 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 349605a351de..9e008cce34e8 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.40 2011/06/13 21:23:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.41 2011/06/21 09:28:05 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> pythia-6.4.24.ebuild,
+ pythia-6.4.25.ebuild, pythia-8.1.45.ebuild, pythia-8.1.50.ebuild:
+ Added fortran-2.eclass support
*pythia-8.1.50 (13 Jun 2011)
*pythia-6.4.25 (13 Jun 2011)
diff --git a/sci-physics/pythia/pythia-6.4.24.ebuild b/sci-physics/pythia/pythia-6.4.24.ebuild
index 442010f824f9..4665af3206d2 100644
--- a/sci-physics/pythia/pythia-6.4.24.ebuild
+++ b/sci-physics/pythia/pythia-6.4.24.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.24.ebuild,v 1.6 2011/06/07 16:10:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.24.ebuild,v 1.7 2011/06/21 09:28:05 jlec Exp $
EAPI=2
-inherit versionator autotools
+
+inherit autotools fortran-2 versionator
MV=$(get_major_version)
MY_PN=${PN}${MV}
@@ -22,12 +23,10 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2
doc? ( http://home.thep.lu.se/~torbjorn/pythia/lutp${DOC_PV}man2.pdf )
examples? ( mirror://gentoo/${PN}-${EX_PV}-examples.tar.bz2 )"
-LICENSE="public-domain"
SLOT="6"
+LICENSE="public-domain"
KEYWORDS="amd64 x86"
IUSE="doc examples static-libs"
-DEPEND=""
-RDEPEND="${DEPEND}"
src_prepare() {
cp ../pythia6/tpythia6_called_from_cc.F .
diff --git a/sci-physics/pythia/pythia-6.4.25.ebuild b/sci-physics/pythia/pythia-6.4.25.ebuild
index 72e9d952e66b..3f0472626cbc 100644
--- a/sci-physics/pythia/pythia-6.4.25.ebuild
+++ b/sci-physics/pythia/pythia-6.4.25.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.25.ebuild,v 1.1 2011/06/13 21:23:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.25.ebuild,v 1.2 2011/06/21 09:28:05 jlec Exp $
EAPI=4
-inherit versionator autotools
+
+inherit autotools fortran-2 versionator
MV=$(get_major_version)
MY_PN=${PN}${MV}
@@ -22,12 +23,10 @@ SRC_URI="http://dev.gentoo.org/~bicatali/${P}.tar.bz2
doc? ( http://home.thep.lu.se/~torbjorn/pythia/lutp${DOC_PV}man2.pdf )
examples? ( mirror://gentoo/${PN}-${EX_PV}-examples.tar.bz2 )"
-LICENSE="public-domain"
SLOT="6"
+LICENSE="public-domain"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples static-libs"
-DEPEND="virtual/fortran"
-RDEPEND="${DEPEND}"
src_prepare() {
cp ../pythia6/tpythia6_called_from_cc.F .
diff --git a/sci-physics/pythia/pythia-8.1.45.ebuild b/sci-physics/pythia/pythia-8.1.45.ebuild
index f839c5aaee07..b07ffca76a28 100644
--- a/sci-physics/pythia/pythia-8.1.45.ebuild
+++ b/sci-physics/pythia/pythia-8.1.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.45.ebuild,v 1.7 2011/06/07 16:10:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.45.ebuild,v 1.8 2011/06/21 09:28:05 jlec Exp $
EAPI=2
@@ -13,8 +13,8 @@ DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
-LICENSE="GPL-2"
SLOT="8"
+LICENSE="GPL-2"
KEYWORDS="amd64 x86"
IUSE="doc examples +hepmc static-libs"
diff --git a/sci-physics/pythia/pythia-8.1.50.ebuild b/sci-physics/pythia/pythia-8.1.50.ebuild
index fa8bfaea8274..95f9c6001d3b 100644
--- a/sci-physics/pythia/pythia-8.1.50.ebuild
+++ b/sci-physics/pythia/pythia-8.1.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.50.ebuild,v 1.1 2011/06/13 21:23:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.50.ebuild,v 1.2 2011/06/21 09:28:05 jlec Exp $
EAPI=4
@@ -13,8 +13,8 @@ DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
-LICENSE="GPL-2"
SLOT="8"
+LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples +hepmc static-libs"