summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-10 07:19:12 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-10 07:19:12 +0000
commite7820ca08b4262f501b3ba2c508a33e1b4a19405 (patch)
tree1586331d36f2f36e0908626764adb59c17f2032c /sci-physics/root
parentNow do not optimize dictionary upon upstream recomendation, remove buggy gcc4... (diff)
downloadgentoo-2-e7820ca08b4262f501b3ba2c508a33e1b4a19405.tar.gz
gentoo-2-e7820ca08b4262f501b3ba2c508a33e1b4a19405.tar.bz2
gentoo-2-e7820ca08b4262f501b3ba2c508a33e1b4a19405.zip
Now do not optimize dictionary upon upstream recomendation, remove buggy gcc44 patch (fixing bug #305871), update various patches, documentation (bug #307915) and cleaned up some seds
(Portage version: 2.2_rc66/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/root-5.26.00-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-physics/root/root-5.26.00-r2.ebuild b/sci-physics/root/root-5.26.00-r2.ebuild
index f507a98fd68a..d1a56ec0d4a7 100644
--- a/sci-physics/root/root-5.26.00-r2.ebuild
+++ b/sci-physics/root/root-5.26.00-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.26.00-r2.ebuild,v 1.1 2010/03/10 07:17:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.26.00-r2.ebuild,v 1.2 2010/03/10 07:19:12 bicatali Exp $
EAPI=2
inherit versionator eutils qt4 elisp-common fdo-mime toolchain-funcs flag-o-matic
@@ -89,7 +89,7 @@ pkg_setup() {
if use openmp && \
[[ $(tc-getCC)$ == *gcc* ]] && \
( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] || \
- ! built_with_use sys-devel/gcc openmp ); then
+ ! has_version sys-devel/gcc[openmp] ); then
ewarn "You are using gcc and OpenMP is available with gcc >= 4.2"
ewarn "If you want to build this package with OpenMP, abort now,"
ewarn "and set CC to an OpenMP capable compiler"