summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-06 20:50:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-06 20:50:27 +0000
commit1ca87335330e31c42d978384c8b9708a54e7f20d (patch)
treeab807cb65140c30b58bd21a8f16b4b9e89723dab /sci-physics
parentFix underlinking in tests, bug 370161 (diff)
downloadgentoo-2-1ca87335330e31c42d978384c8b9708a54e7f20d.tar.gz
gentoo-2-1ca87335330e31c42d978384c8b9708a54e7f20d.tar.bz2
gentoo-2-1ca87335330e31c42d978384c8b9708a54e7f20d.zip
Version bump
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog7
-rw-r--r--sci-physics/clhep/clhep-2.1.1.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index 181253105cfe..8b25640ae27a 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/clhep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.35 2011/06/28 20:00:38 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.36 2011/08/06 20:50:27 bicatali Exp $
+
+*clhep-2.1.1.0 (06 Aug 2011)
+
+ 06 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> +clhep-2.1.1.0.ebuild:
+ Version bump
28 Jun 2011; Brent Baude <ranger@gentoo.org> clhep-2.1.0.1.ebuild:
Marking clhep-2.1.0.1 ppc for bug 354009
diff --git a/sci-physics/clhep/clhep-2.1.1.0.ebuild b/sci-physics/clhep/clhep-2.1.1.0.ebuild
new file mode 100644
index 000000000000..835c683e1eea
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.1.1.0.ebuild,v 1.1 2011/08/06 20:50:27 bicatali Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://www.cern.ch/clhep"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/${P}.tgz"
+LICENSE="public-domain"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+IUSE="exceptions static-libs"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ for d in $(find . -name configure.ac); do
+ # respect user flags and fix some compilers stuff
+ sed -i \
+ -e 's:^g++):*g++):g' \
+ -e 's:^icc):icc|icpc):g' \
+ -e '/AM_CXXFLAGS=/s:-O ::g' \
+ ${d} || die
+ # need to rebuild because original configurations
+ # have buggy detection
+ done
+ for d in $(find . -name Makefile.am | xargs grep -l ": %\.cc"); do
+ sed -i \
+ -e 's|: %\.cc|: %\.cc \$(shareddir)|' \
+ -e 's|all-local: \$(shareddir)|all-local: |' \
+ ${d} || die
+ # fixing parallel build
+ done
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable exceptions) \
+ $(use_enable static-libs static)
+}