summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-20 16:40:35 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-20 16:40:35 +0000
commit5e051a7c2464b02edb3f6b0804d7c00981970283 (patch)
tree71e7e5ed06184fd17e02912148a5429d8f07e8d7 /sci-physics
parentsci-biology/vaal: Version BUmp (diff)
downloadgentoo-2-5e051a7c2464b02edb3f6b0804d7c00981970283.tar.gz
gentoo-2-5e051a7c2464b02edb3f6b0804d7c00981970283.tar.bz2
gentoo-2-5e051a7c2464b02edb3f6b0804d7c00981970283.zip
sci-physics/harminv: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/harminv/ChangeLog8
-rw-r--r--sci-physics/harminv/harminv-1.3.1.ebuild10
-rw-r--r--sci-physics/harminv/metadata.xml4
3 files changed, 13 insertions, 9 deletions
diff --git a/sci-physics/harminv/ChangeLog b/sci-physics/harminv/ChangeLog
index dd9ad46b3434..5e566553d456 100644
--- a/sci-physics/harminv/ChangeLog
+++ b/sci-physics/harminv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/harminv
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/harminv/ChangeLog,v 1.5 2012/08/07 16:48:15 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/harminv/ChangeLog,v 1.6 2013/02/20 16:40:35 jlec Exp $
+
+ 20 Feb 2013; Justin Lecher <jlec@gentoo.org> harminv-1.3.1.ebuild,
+ metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
07 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> harminv-1.3.1.ebuild,
metadata.xml:
diff --git a/sci-physics/harminv/harminv-1.3.1.ebuild b/sci-physics/harminv/harminv-1.3.1.ebuild
index 680176ff71bc..558b6c40db19 100644
--- a/sci-physics/harminv/harminv-1.3.1.ebuild
+++ b/sci-physics/harminv/harminv-1.3.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/harminv/harminv-1.3.1.ebuild,v 1.5 2012/08/07 16:48:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/harminv/harminv-1.3.1.ebuild,v 1.6 2013/02/20 16:40:35 jlec Exp $
EAPI=4
AUTOTOOLS_AUTORECONF=true
-inherit autotools-utils eutils
+inherit autotools-utils eutils toolchain-funcs
DESCRIPTION="Extraction of complex frequencies and amplitudes from time series"
HOMEPAGE="http://ab-initio.mit.edu/harminv/"
@@ -25,8 +25,8 @@ PATCHES=( "${FILESDIR}"/${P}-configure.ac.patch )
src_configure() {
local myeconfargs=(
- --with-blas="$(pkg-config --libs blas)"
- --with-lapack="$(pkg-config --libs lapack)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
)
autotools-utils_src_configure
}
diff --git a/sci-physics/harminv/metadata.xml b/sci-physics/harminv/metadata.xml
index 1e2085ba073d..1d4bdde16401 100644
--- a/sci-physics/harminv/metadata.xml
+++ b/sci-physics/harminv/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-physics</herd>
-<longdescription lang="en">
+ <herd>sci-physics</herd>
+ <longdescription lang="en">
Harminv is a program to solve the problem of harmonic inversion,
given a discrete-time, finite-length signal that consists of a sum of
finitely-many sinusoids (possibly exponentially decaying) in a given