summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-18 16:19:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-18 16:19:40 +0000
commit67963dbf563fa12216fbcee94513af684b12479c (patch)
tree8a093aca124f7d31d50e369d1d52b692c4448974 /sci-physics
parentReplace CPPSERV 0.2.6 with 0.2.8 (diff)
downloadgentoo-2-67963dbf563fa12216fbcee94513af684b12479c.tar.gz
gentoo-2-67963dbf563fa12216fbcee94513af684b12479c.tar.bz2
gentoo-2-67963dbf563fa12216fbcee94513af684b12479c.zip
Version bumps
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pythia/ChangeLog9
-rw-r--r--sci-physics/pythia/pythia-6.4.20.ebuild65
-rw-r--r--sci-physics/pythia/pythia-8.1.20.ebuild73
3 files changed, 146 insertions, 1 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 6fbe0afc10c5..ba453ffe5298 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.7 2009/03/03 18:33:18 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.8 2009/03/18 16:19:40 bicatali Exp $
+
+*pythia-8.1.20 (18 Mar 2009)
+*pythia-6.4.20 (18 Mar 2009)
+
+ 18 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +pythia-6.4.20.ebuild, +pythia-8.1.20.ebuild:
+ Version bumps
03 Mar 2009; Ferris McCormick <fmccor@gentoo.org> pythia-6.4.19.ebuild,
pythia-8.1.08-r1.ebuild:
diff --git a/sci-physics/pythia/pythia-6.4.20.ebuild b/sci-physics/pythia/pythia-6.4.20.ebuild
new file mode 100644
index 000000000000..34a2e58e8246
--- /dev/null
+++ b/sci-physics/pythia/pythia-6.4.20.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.20.ebuild,v 1.1 2009/03/18 16:19:40 bicatali Exp $
+
+EAPI=2
+inherit fortran versionator autotools
+
+MV=$(get_major_version)
+MY_PN=${PN}${MV}
+DOC_PV=0613
+EX_PV=6.4.18
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://projects.hepforge.org/pythia6/"
+
+# pythia6 from root is needed for some files to interface pythia6 with root.
+# To produce a split version on mirror do:
+# svn export http://svn.hepforge.org/pythia6/tags/v_6_4_19/ pythia-6.4.19
+# tar cjf pythia-6.4.19.tar.bz2
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ ftp://root.cern.ch/root/pythia6.tar.gz
+ doc? ( http://home.thep.lu.se/~torbjorn/pythia/lutp${DOC_PV}man2.pdf )
+ examples? ( mirror://gentoo/${PN}-${EX_PV}-examples.tar.bz2 )"
+
+LICENSE="public-domain"
+SLOT="6"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples"
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp ../pythia6/tpythia6_called_from_cc.F .
+ cp ../pythia6/pythia6_common_address.c .
+ cat > configure.ac <<-EOF
+ AC_INIT(${PN},${PV})
+ AM_INIT_AUTOMAKE
+ AC_PROG_F77
+ AC_PROG_LIBTOOL
+ AC_CHECK_LIB(m,sqrt)
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ echo >> Makefile.am "lib_LTLIBRARIES = libpythia6.la"
+ echo >> Makefile.am "libpythia6_la_SOURCES = \ "
+ # replace wildcard from makefile to ls in shell
+ for f in py*.f struct*.f up*.f fh*.f; do
+ echo >> Makefile.am " ${f} \\"
+ done
+ echo >> Makefile.am " ssmssm.f sugra.f visaje.f pdfset.f \\"
+ echo >> Makefile.am " tpythia6_called_from_cc.F pythia6_common_address.c"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc update_notes.txt README
+ insinto /usr/share/doc/${PF}/
+ if use doc; then
+ doins "${DISTDIR}"/lutp${DOC_PV}man2.pdf || die
+ fi
+ if use examples; then
+ doins -r "${WORKDIR}"/examples || die
+ fi
+}
diff --git a/sci-physics/pythia/pythia-8.1.20.ebuild b/sci-physics/pythia/pythia-8.1.20.ebuild
new file mode 100644
index 000000000000..a0de0c9a2bbe
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.20.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.20.ebuild,v 1.1 2009/03/18 16:19:40 bicatali Exp $
+
+EAPI=1
+
+inherit eutils versionator
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="8"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples +hepmc"
+
+DEPEND="hepmc? ( sci-physics/hepmc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use hepmc && export HEPMCVERSION=2 HEPMCLOCATION=/usr
+ # homemade configure script creates a useless config.mk
+ rm -f config.mk && touch config.mk
+ emake SHAREDLIBS=yes LDFLAGSSHARED="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ cd "${S}"/examples
+ # use emake for parallel instead of long runmains
+ emake \
+ $(ls main0{1..9}*.cc main1{0..5}*.cc | sed -e 's/.cc//') \
+ || die "emake tests failed"
+ for i in main0{1..9}*.exe main1{0..5}*.exe; do
+ ./${i} > ${i}.out || die "test ${i} failed"
+ done
+ if use hepmc; then
+ emake main31 main32 || die "emake tests for hepmc failed"
+ ./main31.exe > main31.exe.out || die
+ ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
+ fi
+ emake clean && rm -f main*out
+}
+
+src_install() {
+ dolib.so lib/*so || die "shared lib install failed"
+ dolib.a lib/archive/* || die "static lib install failed"
+
+ insinto /usr/include/${PN}
+ doins include/* || die "headers install failed"
+
+ # xmldoc needed by root
+ insinto /usr/share/${PN}
+ doins -r xmldoc || die "xmldoc install failed"
+ echo PYTHIA8DATA=/usr/share/${PN}/xmldoc >> 99pythia8
+ doenvd 99pythia8
+
+ insinto /usr/share/doc/${PF}
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ doins worksheet.pdf || die "doc install failed"
+ mv htmldoc html
+ doins -r html || die "html doc install failed"
+ fi
+ if use examples; then
+ doins -r examples || die "examples install failed"
+ fi
+}