summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-06-06 19:17:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-06-06 19:17:37 +0000
commitd21db67ff7c8e09f5d0eee5ab1376a84b6ab6337 (patch)
tree8c0924784d095a9432f430047d5b52a58f1e52e8 /sci-physics
parentAdd ~alpha/~ia64 (diff)
downloadgentoo-2-d21db67ff7c8e09f5d0eee5ab1376a84b6ab6337.tar.gz
gentoo-2-d21db67ff7c8e09f5d0eee5ab1376a84b6ab6337.tar.bz2
gentoo-2-d21db67ff7c8e09f5d0eee5ab1376a84b6ab6337.zip
Initial import, closing bug #98233
(Portage version: 2.1.5.4)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog10
-rw-r--r--sci-physics/clhep/Manifest5
-rw-r--r--sci-physics/clhep/clhep-2.0.3.3.ebuild51
-rw-r--r--sci-physics/clhep/files/clhep-2.0.3.3-gcc43.patch10
-rw-r--r--sci-physics/clhep/metadata.xml10
5 files changed, 86 insertions, 0 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
new file mode 100644
index 000000000000..ca6a741c9cb6
--- /dev/null
+++ b/sci-physics/clhep/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/clhep
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.1 2008/06/06 19:17:37 bicatali Exp $
+
+*clhep-2.0.3.3 (06 Jun 2008)
+
+ 06 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/clhep-2.0.3.3-gcc43.patch, +metadata.xml, +clhep-2.0.3.3.ebuild:
+ Initial import, closing bug #98233
+
diff --git a/sci-physics/clhep/Manifest b/sci-physics/clhep/Manifest
new file mode 100644
index 000000000000..1039c90d19e5
--- /dev/null
+++ b/sci-physics/clhep/Manifest
@@ -0,0 +1,5 @@
+AUX clhep-2.0.3.3-gcc43.patch 344 RMD160 559f03569fe8d306537c44e569a5ca3f148463d5 SHA1 b77566a6fb11b906218c139041346ca3e75fa1c5 SHA256 68e3c185d69f52cbf795c111b7b4da7e6e3caf41eb91593d848501bb69218970
+DIST clhep-2.0.3.3-src.tgz 5053788 RMD160 ecb999268bb722cdf39a9ea4b788b1e7e5aa26ec SHA1 5aec5fae980655dd977843807c9afc1752810b8f SHA256 a382f31a63c2a63d89159aa0afead9a44a5b44ede716f25d93bbf783b92eec81
+EBUILD clhep-2.0.3.3.ebuild 1219 RMD160 a2a0a582d1623ba70a98b4957956cc1353ba1131 SHA1 1fd1108ae4b06c702e64722c98e989145501e48b SHA256 c2c2f03d0f7fbc55ca657e8f79cef4d0eec6ec9511095ba66f442c21a47f0f12
+MISC ChangeLog 315 RMD160 8ba13d36cc76bd8c0a765215713d3c9126c877da SHA1 f4341ce76d69e2ddfd3f01d96aca69f63e4f69d3 SHA256 489511358ba250e339c0743f7a3a077e8d6c2c3d95590df42368131846f3500f
+MISC metadata.xml 401 RMD160 9b3b01a3ccc10ad8340a6fa83a47857ae8678fa9 SHA1 239babd5b008f5275190c1cf49c89fa6b2820c8d SHA256 45c2367f8d7b1c0a99250fba662e51a7bce383a8f9accda46328c6c101842e18
diff --git a/sci-physics/clhep/clhep-2.0.3.3.ebuild b/sci-physics/clhep/clhep-2.0.3.3.ebuild
new file mode 100644
index 000000000000..4f2304a6c396
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.0.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.0.3.3.ebuild,v 1.1 2008/06/06 19:17:37 bicatali Exp $
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://www.cern.ch/clhep"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/distributions/${P}-src.tgz"
+
+LICENSE="public-domain"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="exceptions"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ for d in $(find . -name configure.in); do
+ pushd ${d/configure.in/}
+ # respect user flags and fix some compilers stuff
+ sed -i \
+ -e 's:^g++):*g++):g' \
+ -e 's:^icc):icc|icpc):g' \
+ -e '/AM_CXXFLAGS=/s:-O ::g' \
+ configure.in || die
+ # need to rebuild because original configurations
+ # have buggy detection
+ eautoconf
+ popd
+ done
+}
+
+src_compile() {
+ # use ld LDFLAGS for intel compiler
+ [[ $(tc-getCXX) = i*c ]] && \
+ export LDFLAGS="$(raw-ldflags)"
+ econf $(use_enable exceptions) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog || die
+}
diff --git a/sci-physics/clhep/files/clhep-2.0.3.3-gcc43.patch b/sci-physics/clhep/files/clhep-2.0.3.3-gcc43.patch
new file mode 100644
index 000000000000..c93a38beedfd
--- /dev/null
+++ b/sci-physics/clhep/files/clhep-2.0.3.3-gcc43.patch
@@ -0,0 +1,10 @@
+--- Random/test/testRandom.cc.orig 2003-07-17 19:20:29.000000000 +0000
++++ Random/test/testRandom.cc 2008-06-06 19:12:09.000000000 +0000
+@@ -3,6 +3,7 @@
+ // ----------------------------------------------------------------------
+ #include "CLHEP/Random/Randomize.h"
+ #include <iostream>
++#include <cstdlib>
+
+ using std::cout;
+ using std::endl;
diff --git a/sci-physics/clhep/metadata.xml b/sci-physics/clhep/metadata.xml
new file mode 100644
index 000000000000..a392c9ee92eb
--- /dev/null
+++ b/sci-physics/clhep/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ A Class Library for High Energy Physics is intended to be a set of
+ HEP-specific foundation and utility classes such as random
+ generators, physics vectors, geometry and linear algebra.
+</longdescription>
+</pkgmetadata>