summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-09-27 10:00:15 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-09-27 10:00:15 +0000
commit38babfb4ba3fcee63d23068a4e80949e804d5f1b (patch)
tree0827e224167c0e827467d372d6e655c3c7722ad6 /sci-visualization/gle
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-38babfb4ba3fcee63d23068a4e80949e804d5f1b.tar.gz
gentoo-2-38babfb4ba3fcee63d23068a4e80949e804d5f1b.tar.bz2
gentoo-2-38babfb4ba3fcee63d23068a4e80949e804d5f1b.zip
Version bump
(Portage version: 2.2_rc87/cvs/Linux i686)
Diffstat (limited to 'sci-visualization/gle')
-rw-r--r--sci-visualization/gle/ChangeLog8
-rw-r--r--sci-visualization/gle/files/gle-4.2.3-parallel.patch21
-rw-r--r--sci-visualization/gle/gle-4.2.3.ebuild (renamed from sci-visualization/gle/gle-4.2.1.ebuild)28
3 files changed, 48 insertions, 9 deletions
diff --git a/sci-visualization/gle/ChangeLog b/sci-visualization/gle/ChangeLog
index 1e40db1b997b..6d7af8c093b9 100644
--- a/sci-visualization/gle/ChangeLog
+++ b/sci-visualization/gle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/gle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/ChangeLog,v 1.10 2010/01/08 15:48:04 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/ChangeLog,v 1.11 2010/09/27 10:00:15 grozin Exp $
+
+*gle-4.2.3 (27 Sep 2010)
+
+ 27 Sep 2010; Andrey Grozin <grozin@gentoo.org> -gle-4.2.1.ebuild,
+ +gle-4.2.3.ebuild, +files/gle-4.2.3-parallel.patch:
+ Version bump
08 Jan 2010; Andrey Grozin <grozin@gentoo.org> gle-4.2.2.ebuild,
-files/gle-4.2.2-ncurses.patch:
diff --git a/sci-visualization/gle/files/gle-4.2.3-parallel.patch b/sci-visualization/gle/files/gle-4.2.3-parallel.patch
new file mode 100644
index 000000000000..1eff8c067102
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.3-parallel.patch
@@ -0,0 +1,21 @@
+--- src/gui/MakefileAC.in.orig 2010-01-06 20:10:04.000000000 +0000
++++ src/gui/MakefileAC.in 2010-01-06 20:21:15.000000000 +0000
+@@ -84,14 +84,14 @@
+ qmake:
+ $(QMAKE_PROG) $(QMAKE_OPTS)
+
+-domake:
+- $(MAKE_PROG)
++domake: Makefile
++ $(MAKE)
+
+-repmake:
++repmake: Makefile
+ perl ../../platform/autopackage/qt-replace.pl Makefile
+
+ doclean:
+- -$(MAKE_PROG) clean
++ -$(MAKE) clean
+ -@$(RM) qgle install_qgle_name_mac Makefile
+ -@$(RMDIR) moc
+ -@$(RMDIR) objects
diff --git a/sci-visualization/gle/gle-4.2.1.ebuild b/sci-visualization/gle/gle-4.2.3.ebuild
index 5f53929d923e..3306862a0ec1 100644
--- a/sci-visualization/gle/gle-4.2.1.ebuild
+++ b/sci-visualization/gle/gle-4.2.3.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/gle-4.2.1.ebuild,v 1.3 2009/12/27 16:35:09 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/gle-4.2.3.ebuild,v 1.1 2010/09/27 10:00:15 grozin Exp $
+
EAPI=2
-inherit eutils elisp-common qt4
+inherit eutils elisp-common qt4 flag-o-matic autotools
+
DESCRIPTION="Graphics Layout Engine"
HOMEPAGE="http://glx.sourceforge.net/"
MY_P=${PN}-graphics-${PV}
-MAN_V="4.2.0"
+MAN_V=4.2.2
SRC_URI="mirror://sourceforge/glx/${MY_P}f-src.tar.gz
doc? ( mirror://sourceforge/glx/${PN}-manual-${MAN_V}.pdf
mirror://sourceforge/glx/GLEusersguide.pdf )"
@@ -30,8 +32,19 @@ RDEPEND="${DEPEND}
S="${WORKDIR}"/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallel.patch
+ eaclocal
+ eautoconf
+}
+
src_configure() {
- econf $(use_with qt4 qt /usr) \
+ # CPPFLAGS are understood as C++ flags
+ append-cppflags ${CXXFLAGS}
+ econf \
+ --without-rpath \
+ --with-manip \
+ $(use_with qt4 qt /usr) \
$(use_with X x) \
$(use_with jpeg) \
$(use_with png) \
@@ -39,9 +52,7 @@ src_configure() {
}
src_compile() {
- # emake failed in src/gui (probably qmake stuff)
- emake -j1 || die "emake failed"
-
+ emake || die "emake failed"
if use emacs; then
cd contrib/editors/highlighting
mv ${PN}-emacs.el ${PN}-mode.el
@@ -52,6 +63,7 @@ src_compile() {
src_install() {
# -jN failed to install some data files
emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ #emake DESTDIR="${D}" install || die "emake install failed"
rmdir "${D}"/usr/share/doc/gle-graphics || die "rmdir gle-graphics failed"
dodoc README.txt