summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-01 12:50:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-01 12:50:16 +0000
commit84a4c192b248e917abe402d9f6bc7b909134a39f (patch)
tree601011afb71fdd0ce6eaff25e17068531219a134 /sci-visualization/xgraph
parentamd64/x86 stable, bug #257048 (diff)
downloadgentoo-2-84a4c192b248e917abe402d9f6bc7b909134a39f.tar.gz
gentoo-2-84a4c192b248e917abe402d9f6bc7b909134a39f.tar.bz2
gentoo-2-84a4c192b248e917abe402d9f6bc7b909134a39f.zip
Added some security fixes from debian, added examples flag
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/xgraph')
-rw-r--r--sci-visualization/xgraph/ChangeLog10
-rw-r--r--sci-visualization/xgraph/metadata.xml11
-rw-r--r--sci-visualization/xgraph/xgraph-12.1-r2.ebuild41
3 files changed, 59 insertions, 3 deletions
diff --git a/sci-visualization/xgraph/ChangeLog b/sci-visualization/xgraph/ChangeLog
index ba2f0ad6e9c6..1ff00c09882b 100644
--- a/sci-visualization/xgraph/ChangeLog
+++ b/sci-visualization/xgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/xgraph
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/ChangeLog,v 1.8 2008/02/06 21:43:31 grobian Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/ChangeLog,v 1.9 2009/02/01 12:50:16 bicatali Exp $
+
+*xgraph-12.1-r2 (01 Feb 2009)
+
+ 01 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +xgraph-12.1-r2.ebuild:
+ Added some security fixes from debian, added examples flag
06 Feb 2008; Fabian Groffen <grobian@gentoo.org> xgraph-12.1-r1.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/sci-visualization/xgraph/metadata.xml b/sci-visualization/xgraph/metadata.xml
index d369d068ffb8..96df77f1e460 100644
--- a/sci-visualization/xgraph/metadata.xml
+++ b/sci-visualization/xgraph/metadata.xml
@@ -1,5 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Accepts data files or stdin in a form similar to the unix program
+ graph and displays line graphs, scatter plots, or bar charts on an
+ X11 display. Fully annotated with title, axis numbering and
+ labels, and legend. Zooming with the mouse is supported. Can
+ generate hardcopy output to Postscript printers and HPGL
+ plotters. Output can be directly pasted into idraw (drawtool) for
+ further annotation. Particularly useful in shell scripts.
+ </longdescription>
</pkgmetadata>
diff --git a/sci-visualization/xgraph/xgraph-12.1-r2.ebuild b/sci-visualization/xgraph/xgraph-12.1-r2.ebuild
new file mode 100644
index 000000000000..b68b1e7494d1
--- /dev/null
+++ b/sci-visualization/xgraph/xgraph-12.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xgraph/xgraph-12.1-r2.ebuild,v 1.1 2009/02/01 12:50:16 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DEB_PR=10
+DESCRIPTION="X11 Plotting Utility"
+HOMEPAGE="http://www.isi.edu/nsnam/xgraph/"
+SRC_URI="http://www.isi.edu/nsnam/dist/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.diff.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+DEPEND="x11-libs/libSM
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PR}.diff
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Compilation failed."
+ dodoc README*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Failed to install example files."
+ fi
+
+ dodir /usr/share/man/man1
+ mv "${D}"/usr/share/man/manm/xgraph.man \
+ "${D}"/usr/share/man/man1/xgraph.1 || \
+ die "Failed to correct man page location."
+ rm -Rf "${D}"/usr/share/man/manm/ || \
+ die "Failed to remove bogus manm directory."
+}