summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-03-18 22:38:22 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-03-18 22:38:22 +0000
commit59fd62baf92ad9f1befe5e631d86839d89cd880a (patch)
tree9a33cbb8741730f8a1a5d834db4f1fd27597b467 /sci-visualization
parentFix bug #167480 and #171290. (diff)
downloadgentoo-2-59fd62baf92ad9f1befe5e631d86839d89cd880a.tar.gz
gentoo-2-59fd62baf92ad9f1befe5e631d86839d89cd880a.tar.bz2
gentoo-2-59fd62baf92ad9f1befe5e631d86839d89cd880a.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/labplot/ChangeLog7
-rw-r--r--sci-visualization/labplot/files/digest-labplot-1.5.1.56
-rw-r--r--sci-visualization/labplot/labplot-1.5.1.5.ebuild78
3 files changed, 90 insertions, 1 deletions
diff --git a/sci-visualization/labplot/ChangeLog b/sci-visualization/labplot/ChangeLog
index 4e31f9ff3202..4fd9eac527cd 100644
--- a/sci-visualization/labplot/ChangeLog
+++ b/sci-visualization/labplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/labplot
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/ChangeLog,v 1.10 2007/03/15 22:24:05 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/ChangeLog,v 1.11 2007/03/18 22:38:22 carlo Exp $
+
+*labplot-1.5.1.5 (18 Mar 2007)
+
+ 18 Mar 2007; Carsten Lohrke <carlo@gentoo.org> +labplot-1.5.1.5.ebuild:
+ Version bump.
15 Mar 2007; Danny van Dyk <kugelfang@gentoo.org> labplot-1.5.1.3.ebuild,
labplot-1.5.1.4.ebuild:
diff --git a/sci-visualization/labplot/files/digest-labplot-1.5.1.5 b/sci-visualization/labplot/files/digest-labplot-1.5.1.5
new file mode 100644
index 000000000000..884449e72c03
--- /dev/null
+++ b/sci-visualization/labplot/files/digest-labplot-1.5.1.5
@@ -0,0 +1,6 @@
+MD5 9247a4871b00e1a5a435ed48150761a8 LabPlot-1.5.1.tar.gz 10733976
+RMD160 404fe6f2c39685ed6b336c71dff3d549b3f4faa4 LabPlot-1.5.1.tar.gz 10733976
+SHA256 25f17e55e3483db33601c10ec292a77de627e7eca2effbd3a77942538a6cbfde LabPlot-1.5.1.tar.gz 10733976
+MD5 1f2031d72c8b39d123131428e1ee980a LabPlot-1.5.1_1.5.1.5.diff.gz 233161
+RMD160 4183272ec66ab4fbff8e642076895ba5a989e72a LabPlot-1.5.1_1.5.1.5.diff.gz 233161
+SHA256 e1dbca7e4b9b84d1a6300ef926545571969cfcb8ffb38f9ba07d4ccad97faebf LabPlot-1.5.1_1.5.1.5.diff.gz 233161
diff --git a/sci-visualization/labplot/labplot-1.5.1.5.ebuild b/sci-visualization/labplot/labplot-1.5.1.5.ebuild
new file mode 100644
index 000000000000..e1d0ddb89ec9
--- /dev/null
+++ b/sci-visualization/labplot/labplot-1.5.1.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/labplot-1.5.1.5.ebuild,v 1.1 2007/03/18 22:38:22 carlo Exp $
+
+inherit eutils gnuconfig kde
+
+PV_BUGFIX="${PV/?.?.?/}"
+MY_PV="${PV%${PV_BUGFIX}}"
+MY_P="LabPlot-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+BUGFIX="LabPlot-${MY_PV}_${PV}.diff"
+
+DESCRIPTION="LabPlot is a KDE application for data plotting and function analysis."
+HOMEPAGE="http://labplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/labplot/${MY_P}.tar.gz"
+[[ -n PV_BUGFIX ]] && SRC_URI="${SRC_URI} mirror://sourceforge/labplot/${BUGFIX}.gz"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="cdf fftw imagemagick jpeg2k kexi opengl tiff"
+
+DEPEND=">=sci-libs/gsl-1.6
+ sci-libs/netcdf
+ virtual/ghostscript
+ x11-libs/qwtplot3d
+ media-libs/audiofile
+ fftw? ( >=sci-libs/fftw-3 )
+ imagemagick? ( >=media-gfx/imagemagick-5.5.6-r1 )
+ jpeg2k? ( >=media-libs/jasper-1.700.5-r1 )
+ tiff? ( >=media-libs/tiff-3.5.5 )
+ opengl? ( virtual/opengl )
+ kexi? ( || ( app-office/kexi app-office/koffice ) )
+ !amd64? ( cdf? ( sci-libs/cdf )
+ >=media-gfx/pstoedit-3.33 )"
+RDEPEND="${DEPEND}"
+need-kde 3.4
+
+[[ -n PV_BUGFIX ]] && PATCHES="${WORKDIR}/${BUGFIX}"
+
+src_unpack() {
+ kde_src_unpack
+ # let's make sure we don't use included libs
+ echo "# Using shared libs!" >| netcdf/netcdf.h
+ echo "# Using shared libs!" >| qwtplot3d/qwt3d_plot.h
+ echo "# Using shared libs!" >| audiofile/audiofile.h
+}
+
+src_compile() {
+ export QTDIR="${ROOT}/usr/qt/3"
+ export QWT3D_PATH="${ROOT}/usr"
+ export KEXIDB_DIR="${ROOT}/usr"
+
+ # texvc not in Portage and I'm not keen maintaining it
+ # qsa ebuilds in bad shape atm.
+ local myconf="--disable-fftw --enable-gsl --enable-ps2eps \
+ --disable-texvc --disable-ocaml --enable-netcdf --enable-audiofile \
+ --enable-system-qwtplot3d --enable-libundo --disable-qsa"
+
+ if use amd64; then
+ myconf="${myconf} --disable-cdf"
+ else
+ myconf="${myconf} $(use_enable cdf)"
+ fi
+
+ local myconf="${myconf} \
+ $(use_enable fftw fftw3) \
+ $(use_enable imagemagick ImageMagick) \
+ $(use_enable jpeg2k jasper) \
+ $(use_enable tiff) \
+ $(use_enable kexi KexiDB) \
+ $(use_enable opengl)"
+ gnuconfig_update
+ kde_src_compile
+}
+