summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-02-14 20:49:26 +0000
committerPeter Volkov <pva@gentoo.org>2010-02-14 20:49:26 +0000
commit61026d25560bb4ff8cf471b7562be67a79dcc954 (patch)
tree5c3d641469f2c21ae8725af685efa2f996cb7857 /sci-visualization
parentVersion bump for qtiplot. (diff)
downloadgentoo-2-61026d25560bb4ff8cf471b7562be67a79dcc954.tar.gz
gentoo-2-61026d25560bb4ff8cf471b7562be67a79dcc954.tar.bz2
gentoo-2-61026d25560bb4ff8cf471b7562be67a79dcc954.zip
Version bump, bug #304533, thank Samuli Suominen for report.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/qtiplot/ChangeLog11
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-QTeXEngine.patch62
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-gl2ps.patch56
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-liborigin.patch90
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.7.11-r3.ebuild181
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.7.12.ebuild (renamed from sci-visualization/qtiplot/qtiplot-0.9.7.11-r2.ebuild)23
6 files changed, 232 insertions, 191 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index dd42f4a700c1..4e0b03a65d6f 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.53 2010/01/12 19:59:17 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.54 2010/02/14 20:49:25 pva Exp $
+
+*qtiplot-0.9.7.12 (14 Feb 2010)
+
+ 14 Feb 2010; Peter Volkov <pva@gentoo.org> -qtiplot-0.9.7.11-r2.ebuild,
+ -qtiplot-0.9.7.11-r3.ebuild, +qtiplot-0.9.7.12.ebuild,
+ +files/qtiplot-0.9.7.12-system-QTeXEngine.patch,
+ +files/qtiplot-0.9.7.12-system-gl2ps.patch,
+ +files/qtiplot-0.9.7.12-system-liborigin.patch:
+ Version bump, bug #304533, thank Samuli Suominen for report.
*qtiplot-0.9.7.11-r4 (12 Jan 2010)
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-QTeXEngine.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-QTeXEngine.patch
new file mode 100644
index 000000000000..5577ec937c38
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-QTeXEngine.patch
@@ -0,0 +1,62 @@
+=== modified file 'build.conf.example'
+--- build.conf.example 2010-01-21 22:49:21 +0000
++++ build.conf.example 2010-02-14 15:04:17 +0000
+@@ -69,6 +69,13 @@
+ win32:QWT3D_LIBS = $$QTI_ROOT/3rdparty/qwtplot3d/lib/qwtplot3d.dll
+ unix:QWT3D_LIBS = $$QTI_ROOT/3rdparty/qwtplot3d/lib/libqwtplot3d.a
+
++##########################################################
++## QTeXEngine - uncomment if you wish to use system copy
++# http://soft.proindependent.com/qtexengine/
++##########################################################
++#
++# QTEXENGINE_LIBS = -lQTeXEngine
++
+ ###########################################################
+ ## libxls - optional. you don't have to set these variables
+ # http://libxls.sourceforge.net/
+
+=== modified file 'qtiplot/qtiplot.pro'
+--- qtiplot/qtiplot.pro 2010-01-21 22:49:21 +0000
++++ qtiplot/qtiplot.pro 2010-02-14 15:00:58 +0000
+@@ -11,7 +11,6 @@
+ # local copy included
+ INCLUDEPATH += ../3rdparty/liborigin
+ INCLUDEPATH += ../3rdparty/zlib
+-INCLUDEPATH += ../3rdparty/QTeXEngine/src
+
+ # configurable
+ INCLUDEPATH += $$MUPARSER_INCLUDEPATH
+@@ -24,6 +23,7 @@
+ LIBS += $$MUPARSER_LIBS
+ LIBS += $$QWT_LIBS
+ LIBS += $$QWT3D_LIBS
++LIBS += $$QTEXENGINE_LIBS
+ LIBS += $$GSL_LIBS
+ LIBS += $$BOOST_LIBS
+
+@@ -143,14 +143,16 @@
+ include(src/table/table.pri)
+ include(src/scripting/scripting.pri)
+
+-###############################################################
+-##################### TeX export: QTeXEngine ##################
+-###############################################################
++isEmpty(QTEXENGINE_LIBS) {
++ ###############################################################
++ ##################### TeX export: QTeXEngine ##################
++ ###############################################################
+
+-INCLUDEPATH += ../3rdparty/QTeXEngine/src
+-HEADERS += ../3rdparty/QTeXEngine/src/QTeXEngine.h
+-SOURCES += ../3rdparty/QTeXEngine/src/QTeXPaintEngine.cpp
+-SOURCES += ../3rdparty/QTeXEngine/src/QTeXPaintDevice.cpp
++ INCLUDEPATH += ../3rdparty/QTeXEngine/src
++ HEADERS += ../3rdparty/QTeXEngine/src/QTeXEngine.h
++ SOURCES += ../3rdparty/QTeXEngine/src/QTeXPaintEngine.cpp
++ SOURCES += ../3rdparty/QTeXEngine/src/QTeXPaintDevice.cpp
++}
+
+ ###############################################################
+ ##################### Scripting: PYTHON + SIP + PyQT ##########
+
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-gl2ps.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-gl2ps.patch
new file mode 100644
index 000000000000..b0419c2f390d
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-gl2ps.patch
@@ -0,0 +1,56 @@
+=== modified file '3rdparty/qwtplot3d/qwtplot3d.pri'
+--- 3rdparty/qwtplot3d/qwtplot3d.pri 2010-01-21 22:49:21 +0000
++++ 3rdparty/qwtplot3d/qwtplot3d.pri 2010-02-14 17:22:07 +0000
+@@ -8,6 +8,8 @@
+ 3rdparty\gl2ps
+ INCLUDEPATH += .
+
++LIBS+=-lgl2ps
++
+ # Input
+ HEADERS += include/qwt3d_extglwidget.h \
+ include/qwt3d_color.h \
+@@ -37,8 +39,7 @@
+ include/qwt3d_volumeplot.h \
+ include/qwt3d_graphplot.h \
+ include/qwt3d_multiplot.h \
+- include/qwt3d_io_gl2ps.h \
+- 3rdparty/gl2ps/gl2ps.h
++ include/qwt3d_io_gl2ps.h
+ SOURCES += src/qwt3d_extglwidget.cpp \
+ src/qwt3d_axis.cpp \
+ src/qwt3d_color.cpp \
+@@ -62,5 +63,4 @@
+ src/qwt3d_function.cpp \
+ src/qwt3d_gridplot.cpp \
+ src/qwt3d_meshplot.cpp \
+- src/qwt3d_io_gl2ps.cpp \
+- 3rdparty/gl2ps/gl2ps.c
++ src/qwt3d_io_gl2ps.cpp
+
+=== modified file '3rdparty/qwtplot3d/src/qwt3d_io_gl2ps.cpp'
+--- 3rdparty/qwtplot3d/src/qwt3d_io_gl2ps.cpp 2010-01-21 22:49:21 +0000
++++ 3rdparty/qwtplot3d/src/qwt3d_io_gl2ps.cpp 2010-02-14 17:12:09 +0000
+@@ -6,7 +6,7 @@
+ #include <locale.h>
+
+ #include "qwt3d_openglhelper.h"
+-#include "../3rdparty/gl2ps/gl2ps.h"
++#include "gl2ps.h"
+ #include "qwt3d_io_gl2ps.h"
+ #include "qwt3d_plot.h"
+
+
+=== modified file '3rdparty/qwtplot3d/src/qwt3d_label.cpp'
+--- 3rdparty/qwtplot3d/src/qwt3d_label.cpp 2010-01-21 22:49:21 +0000
++++ 3rdparty/qwtplot3d/src/qwt3d_label.cpp 2010-02-14 17:13:01 +0000
+@@ -1,7 +1,7 @@
+ #include <qbitmap.h>
+ #include "qwt3d_label.h"
+ #include "qwt3d_plot.h"
+-#include "../3rdparty/gl2ps/gl2ps.h"
++#include "gl2ps.h"
+
+ using namespace Qwt3D;
+
+
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-liborigin.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-liborigin.patch
new file mode 100644
index 000000000000..3e89b243e2ec
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.12-system-liborigin.patch
@@ -0,0 +1,90 @@
+=== modified file 'build.conf.example'
+--- build.conf.example 2010-02-14 15:07:01 +0000
++++ build.conf.example 2010-02-14 15:16:08 +0000
+@@ -118,6 +118,14 @@
+ EMF_ENGINE_LIBS = $$QTI_ROOT/3rdparty/EmfEngine/libEmfEngine.a
+
+ ##########################################################
++## liborigin - keep commented if you wish to use local copy
++# http://sourceforge.net/projects/liborigin/
++##########################################################
++
++# LIB_ORIGIN_INCLUDEPATH = /usr/include/liborigin2
++# LIB_ORIGIN_LIBS = -lorigin2
++
++##########################################################
+ ## python - only used if python is needed
+ ##########################################################
+
+
+=== modified file 'qtiplot/qtiplot.pro'
+--- qtiplot/qtiplot.pro 2010-02-14 15:07:01 +0000
++++ qtiplot/qtiplot.pro 2010-02-14 15:13:58 +0000
+@@ -9,7 +9,6 @@
+ #############################################################################
+
+ # local copy included
+-INCLUDEPATH += ../3rdparty/liborigin
+ INCLUDEPATH += ../3rdparty/zlib
+
+ # configurable
+@@ -18,6 +17,7 @@
+ INCLUDEPATH += $$QWT3D_INCLUDEPATH
+ INCLUDEPATH += $$GSL_INCLUDEPATH
+ INCLUDEPATH += $$BOOST_INCLUDEPATH
++INCLUDEPATH += $$LIB_ORIGIN_INCLUDEPATH
+
+ # configurable libs
+ LIBS += $$MUPARSER_LIBS
+@@ -26,6 +26,7 @@
+ LIBS += $$QTEXENGINE_LIBS
+ LIBS += $$GSL_LIBS
+ LIBS += $$BOOST_LIBS
++LIBS += $$LIB_ORIGIN_LIBS
+
+ #############################################################################
+ ###################### BASIC PROJECT PROPERTIES #############################
+@@ -154,6 +155,10 @@
+ SOURCES += ../3rdparty/QTeXEngine/src/QTeXPaintDevice.cpp
+ }
+
++isEmpty(LIB_ORIGIN_LIBS) {
++ INCLUDEPATH += ../3rdparty/liborigin
++}
++
+ ###############################################################
+ ##################### Scripting: PYTHON + SIP + PyQT ##########
+ ###############################################################
+
+=== modified file 'qtiplot/src/origin/origin.pri'
+--- qtiplot/src/origin/origin.pri 2009-10-18 01:48:15 +0000
++++ qtiplot/src/origin/origin.pri 2010-02-14 15:11:15 +0000
+@@ -4,14 +4,17 @@
+ INCLUDEPATH += src/origin/
+
+ HEADERS += src/origin/importOPJ.h
+-HEADERS += ../3rdparty/liborigin/OriginObj.h
+-HEADERS += ../3rdparty/liborigin/OriginFile.h
+-HEADERS += ../3rdparty/liborigin/OriginParser.h
+-HEADERS += ../3rdparty/liborigin/OriginDefaultParser.h
+-HEADERS += ../3rdparty/liborigin/Origin750Parser.h
+-
+ SOURCES += src/origin/importOPJ.cpp
+-SOURCES += ../3rdparty/liborigin/OriginFile.cpp
+-SOURCES += ../3rdparty/liborigin/OriginParser.cpp
+-SOURCES += ../3rdparty/liborigin/OriginDefaultParser.cpp
+-SOURCES += ../3rdparty/liborigin/Origin750Parser.cpp
++
++isEmpty(LIB_ORIGIN_LIBS) {
++ HEADERS += ../3rdparty/liborigin/OriginObj.h
++ HEADERS += ../3rdparty/liborigin/OriginFile.h
++ HEADERS += ../3rdparty/liborigin/OriginParser.h
++ HEADERS += ../3rdparty/liborigin/OriginDefaultParser.h
++ HEADERS += ../3rdparty/liborigin/Origin750Parser.h
++
++ SOURCES += ../3rdparty/liborigin/OriginFile.cpp
++ SOURCES += ../3rdparty/liborigin/OriginParser.cpp
++ SOURCES += ../3rdparty/liborigin/OriginDefaultParser.cpp
++ SOURCES += ../3rdparty/liborigin/Origin750Parser.cpp
++}
+
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.7.11-r3.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.7.11-r3.ebuild
deleted file mode 100644
index 050a27279e1e..000000000000
--- a/sci-visualization/qtiplot/qtiplot-0.9.7.11-r3.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.11-r3.ebuild,v 1.1 2010/01/12 18:07:37 pva Exp $
-
-EAPI=2
-inherit eutils qt4 fdo-mime python
-
-DESCRIPTION="Qt based clone of the Origin plotting package"
-HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
-SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc python ods xls"
-
-LANGS="cn cz de es fr ro ru ja sv"
-for l in ${LANGS}; do
- lu=${l/cz/cs}
- lu=${lu/cn/zh_CN}
- IUSE="${IUSE} linguas_${lu}"
-done
-
-# qwtplot3d much modified from original upstream
-# >=x11-libs/qwt-5.3 they are using trunk checkouts
-CDEPEND="
- x11-libs/qt-opengl:4
- x11-libs/qt-qt3support:4
- x11-libs/qt-assistant:4
- x11-libs/qt-svg:4
- >=x11-libs/gl2ps-1.3.5
- >=dev-cpp/muParser-1.30
- >=dev-libs/boost-1.35.0
- >=sci-libs/liborigin-20090406:2
- sci-libs/gsl
- dev-libs/boost
- dev-tex/qtexengine
- xls? ( dev-libs/libxls )
- ods? ( dev-libs/quazip )"
-# Still unable to build
-# emf? ( media-libs/libemf
-# media-libs/emfengine )
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- python? ( >=dev-python/sip-4.9 )
- doc? ( app-text/docbook-sgml-utils
- >=app-text/docbook-xml-dtd-4.4-r2:4.4 )"
-
-RDEPEND="${CDEPEND}
- python? ( >=dev-lang/python-2.5
- dev-python/PyQt4[X]
- dev-python/pygsl
- dev-python/rpy
- sci-libs/scipy )"
-
-PATCHES=(
- "${FILESDIR}/${P}-system-QTeXEngine.patch"
- "${FILESDIR}/${P}-system-liborigin.patch"
- "${FILESDIR}/${P}-system-gl2ps.patch"
- "${FILESDIR}/${PN}-0.9.7.10-dont-install-qwt.patch"
- "${FILESDIR}/${P}-transparency.patch"
- )
-
-src_prepare() {
- qt4_src_prepare
-
- rm -rf 3rdparty/{liborigin,QTeXEngine,/qwtplot3d/3rdparty/gl2ps/}
-
- # Check build.conf for changes on bump.
- cat >build.conf <<-EOF
- # Automatically generated by Gentoo ebuild
- isEmpty( QTI_ROOT ) {
- message( "each file including this config needs to set QTI_ROOT to the dir containing this file!" )
- }
-
- MUPARSER_LIBS = \$\$system(pkg-config --libs muparser)
- GSL_LIBS = \$\$system(pkg-config --libs gsl)
- BOOST_INCLUDEPATH = /usr/include/boost
- BOOST_LIBS = -lboost_date_time-mt -lboost_thread-mt
- QWT_INCLUDEPATH = \$\$QTI_ROOT/3rdparty/qwt/src
- QWT_LIBS = \$\$QTI_ROOT/3rdparty/qwt/lib/libqwt.a
- LIB_ORIGIN_INCLUDEPATH = /usr/include/liborigin2
- LIB_ORIGIN_LIBS = -lorigin2
- SYS_LIBS = -lQTeXEngine -lgl2ps
-
- PYTHON = python
- LUPDATE = lupdate
- LRELEASE = lrelease
-
- SCRIPTING_LANGS += muParser
-
- CONFIG += release
- CONFIG += CustomInstall
-
- EOF
-
- use python && echo "SCRIPTING_LANGS += Python" >> build.conf
- use xls && echo "XLS_LIBS = -lxlsreader" >> build.conf
- if use ods; then
- echo "QUAZIP_INCLUDEPATH = /usr/include/quazip" >> build.conf
- echo "QUAZIP_LIBS = -lquazip" >> build.conf
- fi
-
- # Fails to build...
- #if use emf; then
- # echo "EMF_ENGINE_INCLUDEPATH = /usr/include/libEMF" >> build.conf
- # echo "EMF_ENGINE_LIBS = -lEMF" >> build.conf
- #fi
-
- python_version
-
- sed -e "s:doc/${PN}/manual:doc/${PF}/html:" \
- -e "s:local/${PN}:$(get_libdir)/python${PYVER}/site-packages:" \
- -i qtiplot/qtiplot.pro || die
-
- sed -e '/INSTALLS.*documentation/d' \
- -e '/INSTALLS.*manual/d' \
- -i qtiplot/qtiplot.pro || die
- sed -e '/manual/d' -i qtiplot.pro || die
-
- # Drop langs only if LINGUAS is not empty
- if [[ -n ${LINGUAS} ]]; then
- for l in ${LANGS}; do
- lu=${l/cz/cs}
- lu=${lu/cn/zh_CN}
- use linguas_${lu} || \
- sed -e "s:translations/qtiplot_${l}.[tq][sm]::" \
- -i qtiplot/qtiplot.pro || die
- done
- fi
- chmod -x qtiplot/qti_wordlist.txt
-
- # sed out debian paths
- sed -e 's:\(/usr/share/sgml/\)docbook/stylesheet/dsssl/modular\(/html/docbook.dsl\):\1stylesheets/dsssl/docbook\2:' \
- -i manual/qtiplot.dsl || die
- sed -e 's:\(/usr/share/\)xml/docbook/stylesheet/nwalsh\(/html/chunk.xsl\):\1sgml/docbook/xsl-stylesheets\2:' \
- -i manual/qtiplot_html.xsl || die
-}
-
-src_configure() {
- use amd64 && export QMAKESPEC="linux-g++-64"
- eqmake4
-}
-
-src_compile() {
- emake || die "emake failed"
- lrelease qtiplot/qtiplot.pro || die
- if use doc; then
- cd manual
- emake web || die "html docbook building failed"
- fi
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die 'emake install failed'
- newicon qtiplot_logo.png qtiplot.png
- make_desktop_entry qtiplot "QtiPlot Scientific Plotting" qtiplot
- if use doc; then
- insinto /usr/share/doc/${PF}/html
- doins -r manual/html/* || die "install manual failed"
- fi
-
- if [[ -n ${LINGUAS} ]]; then
- insinto /usr/share/${PN}/translations
- for l in ${LANGS}; do
- lu=${l/cz/cs}
- lu=${lu/cn/zh_CN}
- use linguas_${lu} && \
- doins qtiplot/translations/qtiplot_${l}.qm
- done
- fi
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.7.11-r2.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.7.12.ebuild
index 004e290ff4bd..157a4ffbf9d2 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.7.11-r2.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.7.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.11-r2.ebuild,v 1.2 2010/01/12 17:50:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.12.ebuild,v 1.1 2010/02/14 20:49:25 pva Exp $
EAPI=2
inherit eutils qt4 fdo-mime python
@@ -29,7 +29,7 @@ CDEPEND="
x11-libs/qt-assistant:4
x11-libs/qt-svg:4
>=x11-libs/gl2ps-1.3.5
- >=dev-cpp/muParser-1.30
+ >=dev-cpp/muParser-1.32
>=dev-libs/boost-1.35.0
>=sci-libs/liborigin-20090406:2
sci-libs/gsl
@@ -41,9 +41,6 @@ CDEPEND="
# emf? ( media-libs/libemf
# media-libs/emfengine )
-# TODO: check GL2PS_HAVE_ZLIB
-# CONFIG += BrowserPlugin
-
DEPEND="${CDEPEND}
dev-util/pkgconfig
python? ( >=dev-python/sip-4.9 )
@@ -82,9 +79,12 @@ src_prepare() {
BOOST_LIBS = -lboost_date_time-mt -lboost_thread-mt
QWT_INCLUDEPATH = \$\$QTI_ROOT/3rdparty/qwt/src
QWT_LIBS = \$\$QTI_ROOT/3rdparty/qwt/lib/libqwt.a
+ QWT3D_INCLUDEPATH = \$\$QTI_ROOT/3rdparty/qwtplot3d/include
+ QWT3D_LIBS = \$\$QTI_ROOT/3rdparty/qwtplot3d/lib/libqwtplot3d.a
LIB_ORIGIN_INCLUDEPATH = /usr/include/liborigin2
LIB_ORIGIN_LIBS = -lorigin2
- SYS_LIBS = -lQTeXEngine -lgl2ps
+ QTEXENGINE_LIBS = -lQTeXEngine
+ SYS_LIBS = -lgl2ps
PYTHON = python
LUPDATE = lupdate
@@ -94,6 +94,7 @@ src_prepare() {
CONFIG += release
CONFIG += CustomInstall
+ DEFINES += SCRIPTING_CONSOLE
EOF
@@ -104,6 +105,8 @@ src_prepare() {
echo "QUAZIP_LIBS = -lquazip" >> build.conf
fi
+ sed '/^INSTALLS/d;' -i 3rdparty/qwtplot3d/qwtplot3d.pro || die
+
# Fails to build...
#if use emf; then
# echo "EMF_ENGINE_INCLUDEPATH = /usr/include/libEMF" >> build.conf
@@ -112,8 +115,8 @@ src_prepare() {
python_version
- sed -e "s:doc/${PN}/manual:doc/${PF}/html:" \
- -e "s:local/${PN}:$(get_libdir)/python${PYVER}/site-packages:" \
+ sed -e "s:doc/${PN}/manual:doc/${PN}/html:" \
+ -e "s:/usr/local/${PN}:$(python_get_sitedir)/qtiplot:" \
-i qtiplot/qtiplot.pro || die
sed -e '/INSTALLS.*documentation/d' \
@@ -159,7 +162,7 @@ src_install() {
newicon qtiplot_logo.png qtiplot.png
make_desktop_entry qtiplot "QtiPlot Scientific Plotting" qtiplot
if use doc; then
- insinto /usr/share/doc/${PF}/html
+ insinto /usr/share/doc/${PN}/html
doins -r manual/html/* || die "install manual failed"
fi
@@ -176,8 +179,10 @@ src_install() {
pkg_postinst() {
fdo-mime_desktop_database_update
+ python_mod_optimize "$(python_get_sitedir)/qtiplot"
}
pkg_postrm() {
fdo-mime_desktop_database_update
+ python_mod_cleanup "$(python_get_sitedir)/qtiplot"
}