summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-08-07 22:08:22 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-08-07 22:08:22 +0000
commitc1b7d65ab23b38b7928d27b051102834a367694a (patch)
treeebf2b66a992ab53fcba2e764a4a172e87fb32a81 /sci-visualization
parentEAPI=2; fix building with USE=python (bug #280005) (diff)
downloadgentoo-2-c1b7d65ab23b38b7928d27b051102834a367694a.tar.gz
gentoo-2-c1b7d65ab23b38b7928d27b051102834a367694a.tar.bz2
gentoo-2-c1b7d65ab23b38b7928d27b051102834a367694a.zip
Version bump (fixes bug #279641).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/scidavis/ChangeLog8
-rw-r--r--sci-visualization/scidavis/files/scidavis-0.2.3-profile.patch67
-rw-r--r--sci-visualization/scidavis/scidavis-0.2.3.ebuild82
3 files changed, 156 insertions, 1 deletions
diff --git a/sci-visualization/scidavis/ChangeLog b/sci-visualization/scidavis/ChangeLog
index 61ea833af3cd..94caa1f1100a 100644
--- a/sci-visualization/scidavis/ChangeLog
+++ b/sci-visualization/scidavis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/scidavis
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/scidavis/ChangeLog,v 1.7 2009/08/07 19:56:32 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/scidavis/ChangeLog,v 1.8 2009/08/07 22:08:22 markusle Exp $
+
+*scidavis-0.2.3 (07 Aug 2009)
+
+ 07 Aug 2009; Markus Dittrich <markusle@gentoo.org> +scidavis-0.2.3.ebuild,
+ +files/scidavis-0.2.3-profile.patch:
+ Version bump (fixes bug #279641).
07 Aug 2009; Markus Dittrich <markusle@gentoo.org> scidavis-0.2.2.ebuild:
Added explicit dependency for qt-qt3support (fixes bug #280531).
diff --git a/sci-visualization/scidavis/files/scidavis-0.2.3-profile.patch b/sci-visualization/scidavis/files/scidavis-0.2.3-profile.patch
new file mode 100644
index 000000000000..92753c25cf42
--- /dev/null
+++ b/sci-visualization/scidavis/files/scidavis-0.2.3-profile.patch
@@ -0,0 +1,67 @@
+diff -Naur scidavis-0.2.3/scidavis/scidavis.pro scidavis-0.2.3.new/scidavis/scidavis.pro
+--- scidavis-0.2.3/scidavis/scidavis.pro 2009-06-28 05:35:12.000000000 -0400
++++ scidavis-0.2.3.new/scidavis/scidavis.pro 2009-08-07 17:53:39.000000000 -0400
+@@ -51,7 +51,7 @@
+ ### scidavisrc.py and scidavisUtil.py, respectively. Alternatively you can also put scidavisrc.py
+ ### (or ".scidavis.py") into the users home directory. scidavisUtil.py must be either in the
+ ### directory specified here or somewhere else in the python path (sys.path) where "import" can find it
+-unix: pythonconfig.path = /etc # where scidavisrc.py is installed
++unix: pythonconfig.path = $$INSTALLBASE/share/scidavis # where scidavisrc.py is installed
+ win32: pythonconfig.path = $$INSTALLBASE
+ unix: pythonutils.path = $$INSTALLBASE/share/scidavis # where the scidavisUtil python modules is installed
+ win32: pythonutils.path = $$INSTALLBASE
+@@ -70,7 +70,8 @@
+ ### Note to packagers: If you want to use systemwide installed liborigin
+ ### instead of the one provided in "3rdparty", uncomment the following 2 lines:
+ # CONFIG += dynamic_liborigin
+-# LIBS += -lorigin
++#LIBS += -lorigin2
++#INCLUDEPATH += /usr/include/liborigin2
+ ### Unfortunately, due to liborigin being in alpha stage, we cannot promise
+ ### that SciDAVis works with any other version that the one in "3rdparty".
+ ################### end of liborigin block
+@@ -82,18 +83,17 @@
+ ### are compiled against Qt4), dynamically against everything else.
+ #############################################################################
+
+-unix:INCLUDEPATH += ../3rdparty/qwtplot3d/include
+-unix:LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a
++unix:INCLUDEPATH += /usr/include/qwtplot3d
++unix:LIBS += -lqwtplot3d
+
+-unix:INCLUDEPATH += ../3rdparty/qwt/src
+-unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
++unix:INCLUDEPATH += /usr/include/qwt5
++unix:LIBS += -lqwt
+
+-unix:LIBS += -L/usr/lib$${libsuff}
+-unix:LIBS += -lgsl -lgslcblas -lz
+-### muparser 1.30 does not compile as a shared lib on Linux
+-unix:LIBS += -L/usr/local/lib$${libsuff}
+-unix:LIBS += /usr/local/lib/libmuparser.a
+-unix:INCLUDEPATH += /usr/local/include
++unix:INCLUDEPATH += $$system(pkg-config --cflags gsl)
++unix:LIBS += $$system(pkg-config --libs gsl)
++unix:LIBS += $$system(pkg-config --libs muparser)
++unix:INCLUDEPATH += $$system(pkg-config --cflags muparser)
++unix:LIBS += -lz
+
+ #############################################################################
+ ### Link everything dynamically
+diff -Naur scidavis-0.2.3/scidavis/sourcefiles.pri scidavis-0.2.3.new/scidavis/sourcefiles.pri
+--- scidavis-0.2.3/scidavis/sourcefiles.pri 2009-03-16 17:08:31.000000000 -0400
++++ scidavis-0.2.3.new/scidavis/sourcefiles.pri 2009-08-07 17:53:39.000000000 -0400
+@@ -44,12 +44,8 @@
+ ###################### DOCUMENTATION ########################################
+
+ documentation.files += ../manual/html \
+- ../INSTALL.html \
+ ../scidavis.css \
+- ../scidavis-logo.png \
+- ../README \
+- ../CHANGES \
+- ../gpl.txt
++ ../scidavis-logo.png
+
+ ###################### DESKTOP INTEGRATION ##################################
+
diff --git a/sci-visualization/scidavis/scidavis-0.2.3.ebuild b/sci-visualization/scidavis/scidavis-0.2.3.ebuild
new file mode 100644
index 000000000000..7d4472860bbc
--- /dev/null
+++ b/sci-visualization/scidavis/scidavis-0.2.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/scidavis/scidavis-0.2.3.ebuild,v 1.1 2009/08/07 22:08:22 markusle Exp $
+
+EAPI=2
+inherit eutils qt4 fdo-mime
+
+DESCRIPTION="Scientific Data Analysis and Visualization"
+HOMEPAGE="http://scidavis.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+LANGS="de es fr ja ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+CDEPEND="sys-libs/zlib
+ =x11-libs/qwt-5.1*[svg]
+ >=x11-libs/qwtplot3d-0.2.7
+ x11-libs/qt-assistant:4
+ x11-libs/qt-qt3support:4
+ >=dev-cpp/muParser-1.30
+ >=sci-libs/gsl-1.8"
+# remove because unsupported for now
+# sci-libs/liborigin:2"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ python? ( >=dev-python/sip-4.7 )"
+
+RDEPEND="${CDEPEND}
+ python? ( >=dev-python/PyQt4-4.4[X]
+ dev-python/pygsl
+ sci-libs/scipy )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-profile.patch
+ sed -i -e '/lgsl/d' fitPlugins/*/*.pro || die "sed gsl link failed"
+ sed -i \
+ -e "s:doc/${PN}:doc/${PF}:g" \
+ ${PN}/${PN}.pro || die "sed doc dir failed"
+ # the libsuff thingy does not work
+ sed -i \
+ -e "s|/usr/lib\$\${libsuff}|/usr/$(get_libdir)|g" \
+ -i fit*/*/*.pro || die "sed plugins failed"
+
+ if use python; then
+ sed -i \
+ -e '/^include( python.pri )$/d' \
+ ${PN}/${PN}.pro || die "sed python failed"
+ fi
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'emake install failed'
+ dodoc README CHANGES
+ doicon scidavis/icons/hicolor-48/scidavis.png
+ cd ${PN}/translations
+ insinto /usr/share/${PN}/translations
+ for l in ${LANGS}; do
+ if use linguas_${l}; then
+ doins ${PN}_${l}.qm
+ fi
+ done
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}