summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2004-10-19 08:07:45 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2004-10-19 08:07:45 +0000
commitdebbb4a00fb941a17786ee79492777033cfacad3 (patch)
tree0d65726e6539a8d5bda36ca592e6cedee184b8f8 /sys-apps/acpid
parentKEYWORDS ~amd64. (Manifest recommit) (diff)
downloadgentoo-2-debbb4a00fb941a17786ee79492777033cfacad3.tar.gz
gentoo-2-debbb4a00fb941a17786ee79492777033cfacad3.tar.bz2
gentoo-2-debbb4a00fb941a17786ee79492777033cfacad3.zip
Version bump."
Diffstat (limited to 'sys-apps/acpid')
-rw-r--r--sys-apps/acpid/ChangeLog9
-rw-r--r--sys-apps/acpid/Manifest4
-rw-r--r--sys-apps/acpid/acpid-1.0.4.ebuild51
-rw-r--r--sys-apps/acpid/files/acpid-1.0.4-default22
-rw-r--r--sys-apps/acpid/files/acpid-1.0.4-default.sh26
-rw-r--r--sys-apps/acpid/files/digest-acpid-1.0.41
6 files changed, 112 insertions, 1 deletions
diff --git a/sys-apps/acpid/ChangeLog b/sys-apps/acpid/ChangeLog
index 3d614c8bde73..9f270432448b 100644
--- a/sys-apps/acpid/ChangeLog
+++ b/sys-apps/acpid/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/acpid
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/ChangeLog,v 1.16 2004/06/24 21:57:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/ChangeLog,v 1.17 2004/10/19 08:07:45 brix Exp $
+
+*acpid-1.0.4 (19 Oct 2004)
+
+ 19 Oct 2004; Henrik Brix Andersen <brix@gentoo.org>
+ +files/acpid-1.0.4-default, +files/acpid-1.0.4-default.sh,
+ +acpid-1.0.4.ebuild:
+ Version bump.
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> acpid-1.0.2-r2.ebuild:
Add inherit eutils
diff --git a/sys-apps/acpid/Manifest b/sys-apps/acpid/Manifest
index 7d3216faefad..4f7a3dd955ae 100644
--- a/sys-apps/acpid/Manifest
+++ b/sys-apps/acpid/Manifest
@@ -1,10 +1,14 @@
MD5 f36145bfb43bffa92b213b98cbdf029b acpid-1.0.1.ebuild 979
MD5 59dafcbde974c87be5ed6c7df71aeb5f acpid-1.0.2-r1.ebuild 1092
MD5 7f87ba021e502f28ada350d3930b6b24 ChangeLog 2118
+MD5 a9193cf7baf581b89762436463e3b04b acpid-1.0.4.ebuild 1216
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 181626193da65fce4562bb8e2921411b acpid-1.0.2-r2.ebuild 1230
+MD5 57b21137b849bbaed476b5226cba903a files/acpid-1.0.4-default.sh 453
MD5 3cc2de9822a0f65e061e31184ad2e91f files/default.sh-gentoo.patch 550
+MD5 5c3df49ff6ddda1509443aeb0f233c67 files/acpid-1.0.4-default 751
MD5 ee393ad4dd2a122f9382473999330386 files/acpid.rc6 646
MD5 1ad4b7deead64fc207ea20bd1c340973 files/digest-acpid-1.0.1 62
+MD5 e193d813bbbabf9aceb89ba3c612e58e files/digest-acpid-1.0.4 62
MD5 4bf4b207e7f3c9f7a966c62236dd73be files/digest-acpid-1.0.2-r1 62
MD5 4bf4b207e7f3c9f7a966c62236dd73be files/digest-acpid-1.0.2-r2 62
diff --git a/sys-apps/acpid/acpid-1.0.4.ebuild b/sys-apps/acpid/acpid-1.0.4.ebuild
new file mode 100644
index 000000000000..38dc670bb46f
--- /dev/null
+++ b/sys-apps/acpid/acpid-1.0.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.4.ebuild,v 1.1 2004/10/19 08:07:45 brix Exp $
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://acpid.sourceforge.net"
+SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc ~alpha ~amd64 ~ia64"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ virtual/linux-sources"
+
+src_compile() {
+ # DO NOT COMPILE WITH OPTIMISATIONS (bug #22365)
+ # That is a note to the devs. IF you are a user, go ahead and optimise
+ # if you want, but we won't support bugs associated with that.
+ make INSTPREFIX=${D} || die
+}
+
+src_install() {
+ # needed since the Makefile doesn't do 'mkdir -p $(BINDIR)'
+ dodir /usr/bin
+
+ make INSTPREFIX=${D} install || die
+
+ exeinto /etc/acpi
+ newexe ${FILESDIR}/${P}-default.sh default.sh || die
+
+ insinto /etc/acpi/events
+ newins ${FILESDIR}/${P}-default default || die
+
+ dodoc README Changelog TODO
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/acpid.rc6 acpid || die
+
+ if use doc; then
+ docinto examples
+ dodoc samples/{acpi_handler.sh,sample.conf}
+
+ docinto examples/battery
+ dodoc samples/battery/*
+
+ docinto examples/panasonic
+ dodoc samples/panasonic/*
+ fi
+}
diff --git a/sys-apps/acpid/files/acpid-1.0.4-default b/sys-apps/acpid/files/acpid-1.0.4-default
new file mode 100644
index 000000000000..9cfb06ef42cd
--- /dev/null
+++ b/sys-apps/acpid/files/acpid-1.0.4-default
@@ -0,0 +1,22 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/files/acpid-1.0.4-default,v 1.1 2004/10/19 08:07:45 brix Exp $
+
+# This is the ACPID default configuration, it takes all
+# events and passes them to /etc/acpi/default.sh for further
+# processing.
+
+# event keeps a regular expression matching the event. To get
+# power events only, just use something like "event=button power.*"
+# to catch it.
+# action keeps the command to be executed after an event occurs
+# In case of the power event above, your entry may look this way:
+#event=button power.*
+#action=/sbin/init 0
+
+# Optionally you can specify the placeholder %e. It will pass
+# through the whole kernel event message to the program you've
+# specified.
+
+event=.*
+action=/etc/acpi/default.sh %e
diff --git a/sys-apps/acpid/files/acpid-1.0.4-default.sh b/sys-apps/acpid/files/acpid-1.0.4-default.sh
new file mode 100644
index 000000000000..3db4156ffddc
--- /dev/null
+++ b/sys-apps/acpid/files/acpid-1.0.4-default.sh
@@ -0,0 +1,26 @@
+#!/bin/sh
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/files/acpid-1.0.4-default.sh,v 1.1 2004/10/19 08:07:45 brix Exp $
+
+# Default acpi script that takes an entry for all actions
+
+set $*
+
+group=${1/\/*/}
+action=${1/*\//}
+
+case "$group" in
+ button)
+ case "$action" in
+ power) /sbin/init 0
+ ;;
+ *) logger "ACPI action $action is not defined"
+ ;;
+ esac
+ ;;
+
+ *)
+ logger "ACPI group $group / action $action is not defined"
+ ;;
+esac
diff --git a/sys-apps/acpid/files/digest-acpid-1.0.4 b/sys-apps/acpid/files/digest-acpid-1.0.4
new file mode 100644
index 000000000000..37c23c5f0323
--- /dev/null
+++ b/sys-apps/acpid/files/digest-acpid-1.0.4
@@ -0,0 +1 @@
+MD5 3aff94e92186e99ed5fd6dcee2db7c74 acpid-1.0.4.tar.gz 23416